linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Mark Brown <broonie@kernel.org>
To: Kuninori Morimoto <kuninori.morimoto.gx@renesas.com>
Cc: Mark Brown <broonie@kernel.org>, Rob Herring <robh+dt@kernel.org>,
	Mark Brown <broonie@kernel.org>,
	Linux-DT <devicetree@vger.kernel.org>,
	Linux-ALSA <alsa-devel@alsa-project.org>,
	Liam Girdwood <lgirdwood@gmail.com>,
	Linux-Kernel <linux-kernel@vger.kernel.org>,
	Simon <horms@verge.net.au>,
	Laurent <laurent.pinchart@ideasonboard.com>,
	Grant Likely <grant.likely@linaro.org>,
	Frank Rowand <frowand.list@gmail.com>,
	Guennadi <g.liakhovetski@gmx.de>,
	alsa-devel@alsa-project.org
Subject: Applied "ASoC: simple-scu-card: code sync: tidyup props/link naming" to the asoc tree
Date: Fri, 28 Oct 2016 19:48:26 +0100	[thread overview]
Message-ID: <E1c0CCY-0005wB-R3@finisterre> (raw)
In-Reply-To: <87oa2j4c5j.wl%kuninori.morimoto.gx@renesas.com>

The patch

   ASoC: simple-scu-card: code sync: tidyup props/link naming

has been applied to the asoc tree at

   git://git.kernel.org/pub/scm/linux/kernel/git/broonie/sound.git 

All being well this means that it will be integrated into the linux-next
tree (usually sometime in the next 24 hours) and sent to Linus during
the next merge window (or sooner if it is a bug fix), however if
problems are discovered then the patch may be dropped or reverted.  

You may get further e-mails resulting from automated or manual testing
and review of the tree, please engage with people reporting problems and
send followup patches addressing any issues that are reported if needed.

If any updates are required or you are submitting further changes they
should be sent as incremental updates against current git, existing
patches will not be replaced.

Please add any relevant lists and maintainers to the CCs when replying
to this mail.

Thanks,
Mark

>From 193599264f3eb632f43f83f738b17241f91dbd5a Mon Sep 17 00:00:00 2001
From: Kuninori Morimoto <kuninori.morimoto.gx@renesas.com>
Date: Fri, 28 Oct 2016 03:38:00 +0000
Subject: [PATCH] ASoC: simple-scu-card: code sync: tidyup props/link naming

simple sound card family are using very similar style, but because of its
historical reason, there are small differences. For example pointer style,
function name, caller postion etc...
This patch synchronizes style to other simple card family so that be enable
to easy reviewing.

This patch uses dai_link/dai_props instead of links/props.

Signed-off-by: Kuninori Morimoto <kuninori.morimoto.gx@renesas.com>
Signed-off-by: Mark Brown <broonie@kernel.org>
---
 sound/soc/generic/simple-scu-card.c | 14 +++++++-------
 1 file changed, 7 insertions(+), 7 deletions(-)

diff --git a/sound/soc/generic/simple-scu-card.c b/sound/soc/generic/simple-scu-card.c
index 1704b187f6ee..348e9a7c4d10 100644
--- a/sound/soc/generic/simple-scu-card.c
+++ b/sound/soc/generic/simple-scu-card.c
@@ -254,8 +254,8 @@ static int asoc_simple_card_parse_of(struct device_node *node,
 static int asoc_simple_card_probe(struct platform_device *pdev)
 {
 	struct simple_card_data *priv;
-	struct snd_soc_dai_link *links;
-	struct asoc_simple_dai *props;
+	struct snd_soc_dai_link *dai_link;
+	struct asoc_simple_dai *dai_props;
 	struct device *dev = &pdev->dev;
 	struct device_node *np = pdev->dev.of_node;
 	int num, ret;
@@ -267,13 +267,13 @@ static int asoc_simple_card_probe(struct platform_device *pdev)
 
 	num = of_get_child_count(np);
 
-	props = devm_kzalloc(dev, sizeof(*props) * num, GFP_KERNEL);
-	links = devm_kzalloc(dev, sizeof(*links) * num, GFP_KERNEL);
-	if (!props || !links)
+	dai_props = devm_kzalloc(dev, sizeof(*dai_props) * num, GFP_KERNEL);
+	dai_link  = devm_kzalloc(dev, sizeof(*dai_link)  * num, GFP_KERNEL);
+	if (!dai_props || !dai_link)
 		return -ENOMEM;
 
-	priv->dai_props				= props;
-	priv->dai_link				= links;
+	priv->dai_props				= dai_props;
+	priv->dai_link				= dai_link;
 
 	/* Init snd_soc_card */
 	priv->snd_card.owner			= THIS_MODULE;
-- 
2.10.1

  reply	other threads:[~2016-10-28 18:48 UTC|newest]

Thread overview: 41+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2016-10-17  8:30 [PATCH 0/23] ASoC: add OF graph base simple-card Kuninori Morimoto
2016-10-17  8:32 ` [PATCH 01/23] ASoC: simple-scu-card: code sync: follow to simple family style Kuninori Morimoto
2016-10-28 18:49   ` Applied "ASoC: simple-scu-card: code sync: follow to simple family style" to the asoc tree Mark Brown
2016-10-17  8:32 ` [PATCH 02/23] ASoC: simple-scu-card: code sync: rename asoc_simple_card_priv Kuninori Morimoto
2016-10-28 18:48   ` Applied "ASoC: simple-scu-card: code sync: rename asoc_simple_card_priv" to the asoc tree Mark Brown
2016-10-17  8:32 ` [PATCH 03/23] ASoC: simple-scu-card: code sync: tidyup props/link naming Kuninori Morimoto
2016-10-28 18:48   ` Mark Brown [this message]
2016-10-17  8:33 ` [PATCH 04/23] ASoC: soc-core: adjust for graph on snd_soc_of_parse_card_name Kuninori Morimoto
2016-11-11 15:28   ` Applied "ASoC: soc-core: adjust for graph on snd_soc_of_parse_card_name" to the asoc tree Mark Brown
2016-10-17  8:33 ` [PATCH 05/23] ASoC: soc-core: adjust for graph on snd_soc_of_parse_audio_simple_widgets Kuninori Morimoto
2016-11-11 15:28   ` Applied "ASoC: soc-core: adjust for graph on snd_soc_of_parse_audio_simple_widgets" to the asoc tree Mark Brown
2016-10-17  8:33 ` [PATCH 06/23] ASoC: soc-core: adjust for graph on snd_soc_of_parse_audio_routing Kuninori Morimoto
2016-11-11 15:29   ` Applied "ASoC: soc-core: adjust for graph on snd_soc_of_parse_audio_routing" to the asoc tree Mark Brown
2016-10-17  8:34 ` [PATCH 07/23] ASoC: soc-core: adjust for graph on snd_soc_of_parse_audio_prefix Kuninori Morimoto
2016-11-11 15:28   ` Applied "ASoC: soc-core: adjust for graph on snd_soc_of_parse_audio_prefix" to the asoc tree Mark Brown
2016-10-17  8:34 ` [PATCH 08/23] ASoC: soc-core: snd_soc_get_dai_name() become non static Kuninori Morimoto
2016-10-18  7:27   ` [alsa-devel] " Jean-Francois Moine
2016-11-11 15:28   ` Applied "ASoC: soc-core: snd_soc_get_dai_name() become non static" to the asoc tree Mark Brown
2016-10-17  8:34 ` [PATCH 09/23] ASoC: simple-card-utils: remove unnecessary cpu/codec pointer check Kuninori Morimoto
2016-10-28 18:48   ` Applied "ASoC: simple-card-utils: remove unnecessary cpu/codec pointer check" to the asoc tree Mark Brown
2016-10-17  8:34 ` [PATCH 10/23] ASoC: simple-card-utils: adjust for graph on asoc_simple_card_parse_card_name Kuninori Morimoto
2016-10-17  8:35 ` [PATCH 11/23] Documentation: of: add type property Kuninori Morimoto
2016-10-17  8:35 ` [PATCH 12/23] of_graph: add of_graph_get_remote_endpoint() Kuninori Morimoto
2016-10-17  8:36 ` [PATCH 13/23] of_graph: add of_graph_port_type_is() Kuninori Morimoto
2016-10-17  8:36 ` [PATCH 14/23] of_graph: add of_graph_get_port_parent() Kuninori Morimoto
2016-10-17  8:36 ` [PATCH 15/23] of_graph: add of_graph_get_top_port() Kuninori Morimoto
2016-10-17  8:37 ` [PATCH 16/23] of_graph: add for_each_of_port() / for_each_of_endpoint_in_port() Kuninori Morimoto
2016-10-17  8:37 ` [PATCH 17/23] of_graph: add of_graph_get_endpoint_count() Kuninori Morimoto
2016-10-17  8:37 ` [PATCH 18/23] ASoC: simple-card-utils: add asoc_simple_card_parse_graph_dai() Kuninori Morimoto
2016-10-17  8:38 ` [PATCH 19/23] ASoC: simple-card-utils: add asoc_simple_card_try_to_probe_graph_card() Kuninori Morimoto
2016-10-17  8:38 ` [PATCH 20/23] ASoC: add simple-graph-card document Kuninori Morimoto
2016-10-18 15:53   ` Rob Herring
2016-10-19  1:36     ` Kuninori Morimoto
2016-10-19  2:39       ` Rob Herring
2016-10-19  6:13         ` Kuninori Morimoto
2016-10-21  5:45       ` Kuninori Morimoto
2016-10-17  8:38 ` [PATCH 21/23] ASoC: add simple-graph-card support Kuninori Morimoto
2016-10-17  8:39 ` [PATCH 22/23] ASoC: add simple-graph-scu-card document Kuninori Morimoto
2016-10-17  8:39 ` [PATCH 23/23] ASoC: add simple-graph-scu-card support Kuninori Morimoto
2016-10-18  7:10 ` [alsa-devel] [PATCH 0/23] ASoC: add OF graph base simple-card Jean-Francois Moine
2016-10-18  8:44   ` Kuninori Morimoto

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=E1c0CCY-0005wB-R3@finisterre \
    --to=broonie@kernel.org \
    --cc=alsa-devel@alsa-project.org \
    --cc=devicetree@vger.kernel.org \
    --cc=frowand.list@gmail.com \
    --cc=g.liakhovetski@gmx.de \
    --cc=grant.likely@linaro.org \
    --cc=horms@verge.net.au \
    --cc=kuninori.morimoto.gx@renesas.com \
    --cc=laurent.pinchart@ideasonboard.com \
    --cc=lgirdwood@gmail.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=robh+dt@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).