linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* [PATCH 00/17] gpiolib: cdev: pre-uAPI v2 cleanups
@ 2020-07-08  4:15 Kent Gibson
  2020-07-08  4:15 ` [PATCH 01/17] gpiolib: move gpiolib-sysfs function declarations into their own header Kent Gibson
                   ` (17 more replies)
  0 siblings, 18 replies; 20+ messages in thread
From: Kent Gibson @ 2020-07-08  4:15 UTC (permalink / raw)
  To: linux-kernel, linux-gpio, bgolaszewski, linus.walleij; +Cc: Kent Gibson

This collection of patches provides improvements to or
address minor problems in gpiolib-cdev.

The majority of the patches (1-7, 9-11) have been pulled directly from
my "gpio: cdev: add uAPI V2" patch set, as they are not related to any
uAPI changes.
The remaining patches were either split out of the remaining patches
from that set, as they are not directly part of the uAPI changes, or
were inspired by fixes for issues in that set, or were only noticed
subsequent to that set.

Changes since "gpio: cdev: add uAPI V2":
 - rebase onto latest gpio/devel
 - fix typo in patch 1 commit description
 - replace patch 8 with the blocking notifier call chain patch
 - rename priv to cdev instead of gcdev in patch 9
 - fix error handling in patch 10
 - add patches 12 to 17

Kent Gibson (17):
  gpiolib: move gpiolib-sysfs function declarations into their own
    header
  gpiolib: cdev: sort includes
  gpiolib: cdev: minor indentation fixes
  gpiolib: cdev: refactor gpiohandle_flags_to_desc_flags
  gpiolib: cdev: rename 'filep' and 'filp' to 'file' to be consistent
    with other use
  gpiolib: cdev: rename numdescs to num_descs
  gpiolib: cdev: remove pointless decrement of i
  gpiolib: cdev: use blocking notifier call chain instead of atomic
  gpiolib: cdev: rename priv to cdev
  gpiolib: cdev: fix minor race in GET_LINEINFO_WATCH
  gpiolib: cdev: remove recalculation of offset
  gpiolib: cdev: refactor linehandle cleanup into linehandle_free
  gpiolib: cdev: refactor lineevent cleanup into lineevent_free
  gpio: uapi: fix misplaced comment line
  tools: gpio: fix spurious close warning in lsgpio
  tools: gpio: fix spurious close warning in gpio-utils
  tools: gpio: fix spurious close warning in gpio-event-mon

 drivers/gpio/gpiolib-cdev.c  | 385 ++++++++++++++++-------------------
 drivers/gpio/gpiolib-sysfs.c |   1 +
 drivers/gpio/gpiolib-sysfs.h |  24 +++
 drivers/gpio/gpiolib.c       |  15 +-
 drivers/gpio/gpiolib.h       |  20 +-
 include/uapi/linux/gpio.h    |   2 +-
 tools/gpio/gpio-event-mon.c  |   3 +-
 tools/gpio/gpio-utils.c      |   4 +-
 tools/gpio/lsgpio.c          |   3 +-
 9 files changed, 217 insertions(+), 240 deletions(-)
 create mode 100644 drivers/gpio/gpiolib-sysfs.h


base-commit: b239e4454e59bc85d466eb5630da46f6a876df77
-- 
2.27.0


^ permalink raw reply	[flat|nested] 20+ messages in thread

end of thread, other threads:[~2020-07-09 13:19 UTC | newest]

Thread overview: 20+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2020-07-08  4:15 [PATCH 00/17] gpiolib: cdev: pre-uAPI v2 cleanups Kent Gibson
2020-07-08  4:15 ` [PATCH 01/17] gpiolib: move gpiolib-sysfs function declarations into their own header Kent Gibson
2020-07-08  4:15 ` [PATCH 02/17] gpiolib: cdev: sort includes Kent Gibson
2020-07-08  4:15 ` [PATCH 03/17] gpiolib: cdev: minor indentation fixes Kent Gibson
2020-07-08  4:15 ` [PATCH 04/17] gpiolib: cdev: refactor gpiohandle_flags_to_desc_flags Kent Gibson
2020-07-08  4:15 ` [PATCH 05/17] gpiolib: cdev: rename 'filep' and 'filp' to 'file' to be consistent with other use Kent Gibson
2020-07-08  4:15 ` [PATCH 06/17] gpiolib: cdev: rename numdescs to num_descs Kent Gibson
2020-07-08  4:15 ` [PATCH 07/17] gpiolib: cdev: remove pointless decrement of i Kent Gibson
2020-07-08  4:15 ` [PATCH 08/17] gpiolib: cdev: use blocking notifier call chain instead of atomic Kent Gibson
2020-07-09 10:06   ` Bartosz Golaszewski
2020-07-08  4:15 ` [PATCH 09/17] gpiolib: cdev: rename priv to cdev Kent Gibson
2020-07-08  4:15 ` [PATCH 10/17] gpiolib: cdev: fix minor race in GET_LINEINFO_WATCH Kent Gibson
2020-07-08  4:15 ` [PATCH 11/17] gpiolib: cdev: remove recalculation of offset Kent Gibson
2020-07-08  4:15 ` [PATCH 12/17] gpiolib: cdev: refactor linehandle cleanup into linehandle_free Kent Gibson
2020-07-08  4:15 ` [PATCH 13/17] gpiolib: cdev: refactor lineevent cleanup into lineevent_free Kent Gibson
2020-07-08  4:15 ` [PATCH 14/17] gpio: uapi: fix misplaced comment line Kent Gibson
2020-07-08  4:15 ` [PATCH 15/17] tools: gpio: fix spurious close warning in lsgpio Kent Gibson
2020-07-08  4:15 ` [PATCH 16/17] tools: gpio: fix spurious close warning in gpio-utils Kent Gibson
2020-07-08  4:16 ` [PATCH 17/17] tools: gpio: fix spurious close warning in gpio-event-mon Kent Gibson
2020-07-09 13:19 ` [PATCH 00/17] gpiolib: cdev: pre-uAPI v2 cleanups Bartosz Golaszewski

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).