linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* [PATCH] vfio: amba: Rename pl330_ids[] to vfio_amba_ids[]
@ 2024-02-26 11:09 Geert Uytterhoeven
  2024-02-26 11:11 ` Geert Uytterhoeven
                   ` (2 more replies)
  0 siblings, 3 replies; 4+ messages in thread
From: Geert Uytterhoeven @ 2024-02-26 11:09 UTC (permalink / raw)
  To: Antonios Motakis, Eric Auger, Alex Williamson
  Cc: kvm, linux-kernel, Geert Uytterhoeven

Obviously drivers/vfio/platform/vfio_amba.c started its life as a
simplified copy of drivers/dma/pl330.c, but not all variable names were
updated.

Signed-off-by: Geert Uytterhoeven <geert+renesas@glider.be>
---
 drivers/vfio/platform/vfio_amba.c | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/drivers/vfio/platform/vfio_amba.c b/drivers/vfio/platform/vfio_amba.c
index 6464b3939ebcfb53..485c6f9161a91be0 100644
--- a/drivers/vfio/platform/vfio_amba.c
+++ b/drivers/vfio/platform/vfio_amba.c
@@ -122,16 +122,16 @@ static const struct vfio_device_ops vfio_amba_ops = {
 	.detach_ioas	= vfio_iommufd_physical_detach_ioas,
 };
 
-static const struct amba_id pl330_ids[] = {
+static const struct amba_id vfio_amba_ids[] = {
 	{ 0, 0 },
 };
 
-MODULE_DEVICE_TABLE(amba, pl330_ids);
+MODULE_DEVICE_TABLE(amba, vfio_amba_ids);
 
 static struct amba_driver vfio_amba_driver = {
 	.probe = vfio_amba_probe,
 	.remove = vfio_amba_remove,
-	.id_table = pl330_ids,
+	.id_table = vfio_amba_ids,
 	.drv = {
 		.name = "vfio-amba",
 		.owner = THIS_MODULE,
-- 
2.34.1


^ permalink raw reply related	[flat|nested] 4+ messages in thread

* Re: [PATCH] vfio: amba: Rename pl330_ids[] to vfio_amba_ids[]
  2024-02-26 11:09 [PATCH] vfio: amba: Rename pl330_ids[] to vfio_amba_ids[] Geert Uytterhoeven
@ 2024-02-26 11:11 ` Geert Uytterhoeven
  2024-02-26 14:54 ` Jason Gunthorpe
  2024-03-05 23:13 ` Alex Williamson
  2 siblings, 0 replies; 4+ messages in thread
From: Geert Uytterhoeven @ 2024-02-26 11:11 UTC (permalink / raw)
  To: Antonios Motakis
  Cc: Eric Auger, Alex Williamson, kvm, linux-kernel, Geert Uytterhoeven

CC Antonios' new address
(time to update all references in the Linux kernel source tree?)

On Mon, Feb 26, 2024 at 12:09 PM Geert Uytterhoeven
<geert+renesas@glider.be> wrote:
> Obviously drivers/vfio/platform/vfio_amba.c started its life as a
> simplified copy of drivers/dma/pl330.c, but not all variable names were
> updated.
>
> Signed-off-by: Geert Uytterhoeven <geert+renesas@glider.be>
> ---
>  drivers/vfio/platform/vfio_amba.c | 6 +++---
>  1 file changed, 3 insertions(+), 3 deletions(-)
>
> diff --git a/drivers/vfio/platform/vfio_amba.c b/drivers/vfio/platform/vfio_amba.c
> index 6464b3939ebcfb53..485c6f9161a91be0 100644
> --- a/drivers/vfio/platform/vfio_amba.c
> +++ b/drivers/vfio/platform/vfio_amba.c
> @@ -122,16 +122,16 @@ static const struct vfio_device_ops vfio_amba_ops = {
>         .detach_ioas    = vfio_iommufd_physical_detach_ioas,
>  };
>
> -static const struct amba_id pl330_ids[] = {
> +static const struct amba_id vfio_amba_ids[] = {
>         { 0, 0 },
>  };
>
> -MODULE_DEVICE_TABLE(amba, pl330_ids);
> +MODULE_DEVICE_TABLE(amba, vfio_amba_ids);
>
>  static struct amba_driver vfio_amba_driver = {
>         .probe = vfio_amba_probe,
>         .remove = vfio_amba_remove,
> -       .id_table = pl330_ids,
> +       .id_table = vfio_amba_ids,
>         .drv = {
>                 .name = "vfio-amba",
>                 .owner = THIS_MODULE,
> --
> 2.34.1

Gr{oetje,eeting}s,

                        Geert

-- 
Geert Uytterhoeven -- There's lots of Linux beyond ia32 -- geert@linux-m68k.org

In personal conversations with technical people, I call myself a hacker. But
when I'm talking to journalists I just say "programmer" or something like that.
                                -- Linus Torvalds

^ permalink raw reply	[flat|nested] 4+ messages in thread

* Re: [PATCH] vfio: amba: Rename pl330_ids[] to vfio_amba_ids[]
  2024-02-26 11:09 [PATCH] vfio: amba: Rename pl330_ids[] to vfio_amba_ids[] Geert Uytterhoeven
  2024-02-26 11:11 ` Geert Uytterhoeven
@ 2024-02-26 14:54 ` Jason Gunthorpe
  2024-03-05 23:13 ` Alex Williamson
  2 siblings, 0 replies; 4+ messages in thread
From: Jason Gunthorpe @ 2024-02-26 14:54 UTC (permalink / raw)
  To: Geert Uytterhoeven
  Cc: Antonios Motakis, Eric Auger, Alex Williamson, kvm, linux-kernel

On Mon, Feb 26, 2024 at 12:09:26PM +0100, Geert Uytterhoeven wrote:
> Obviously drivers/vfio/platform/vfio_amba.c started its life as a
> simplified copy of drivers/dma/pl330.c, but not all variable names were
> updated.
> 
> Signed-off-by: Geert Uytterhoeven <geert+renesas@glider.be>
> ---
>  drivers/vfio/platform/vfio_amba.c | 6 +++---
>  1 file changed, 3 insertions(+), 3 deletions(-)

Reviewed-by: Jason Gunthorpe <jgg@nvidia.com>

Jason

^ permalink raw reply	[flat|nested] 4+ messages in thread

* Re: [PATCH] vfio: amba: Rename pl330_ids[] to vfio_amba_ids[]
  2024-02-26 11:09 [PATCH] vfio: amba: Rename pl330_ids[] to vfio_amba_ids[] Geert Uytterhoeven
  2024-02-26 11:11 ` Geert Uytterhoeven
  2024-02-26 14:54 ` Jason Gunthorpe
@ 2024-03-05 23:13 ` Alex Williamson
  2 siblings, 0 replies; 4+ messages in thread
From: Alex Williamson @ 2024-03-05 23:13 UTC (permalink / raw)
  To: Geert Uytterhoeven; +Cc: Antonios Motakis, Eric Auger, kvm, linux-kernel

On Mon, 26 Feb 2024 12:09:26 +0100
Geert Uytterhoeven <geert+renesas@glider.be> wrote:

> Obviously drivers/vfio/platform/vfio_amba.c started its life as a
> simplified copy of drivers/dma/pl330.c, but not all variable names were
> updated.
> 
> Signed-off-by: Geert Uytterhoeven <geert+renesas@glider.be>
> ---
>  drivers/vfio/platform/vfio_amba.c | 6 +++---
>  1 file changed, 3 insertions(+), 3 deletions(-)
> 
> diff --git a/drivers/vfio/platform/vfio_amba.c b/drivers/vfio/platform/vfio_amba.c
> index 6464b3939ebcfb53..485c6f9161a91be0 100644
> --- a/drivers/vfio/platform/vfio_amba.c
> +++ b/drivers/vfio/platform/vfio_amba.c
> @@ -122,16 +122,16 @@ static const struct vfio_device_ops vfio_amba_ops = {
>  	.detach_ioas	= vfio_iommufd_physical_detach_ioas,
>  };
>  
> -static const struct amba_id pl330_ids[] = {
> +static const struct amba_id vfio_amba_ids[] = {
>  	{ 0, 0 },
>  };
>  
> -MODULE_DEVICE_TABLE(amba, pl330_ids);
> +MODULE_DEVICE_TABLE(amba, vfio_amba_ids);
>  
>  static struct amba_driver vfio_amba_driver = {
>  	.probe = vfio_amba_probe,
>  	.remove = vfio_amba_remove,
> -	.id_table = pl330_ids,
> +	.id_table = vfio_amba_ids,
>  	.drv = {
>  		.name = "vfio-amba",
>  		.owner = THIS_MODULE,

Applied to vfio next branch for v6.9.  Thanks,

Alex


^ permalink raw reply	[flat|nested] 4+ messages in thread

end of thread, other threads:[~2024-03-05 23:13 UTC | newest]

Thread overview: 4+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2024-02-26 11:09 [PATCH] vfio: amba: Rename pl330_ids[] to vfio_amba_ids[] Geert Uytterhoeven
2024-02-26 11:11 ` Geert Uytterhoeven
2024-02-26 14:54 ` Jason Gunthorpe
2024-03-05 23:13 ` Alex Williamson

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).