linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* [PATCH v2 0/5] of: generic infrastructure fixes
@ 2016-05-16 16:52 Pantelis Antoniou
  2016-05-16 16:52 ` [PATCH v2 1/5] of: rename *_node_sysfs to _node_post Pantelis Antoniou
                   ` (4 more replies)
  0 siblings, 5 replies; 14+ messages in thread
From: Pantelis Antoniou @ 2016-05-16 16:52 UTC (permalink / raw)
  To: Rob Herring
  Cc: Frank Rowand, Matt Porter, Grant Likely, Koen Kooi,
	Guenter Roeck, Marek Vasut, Geert Uytterhoeven, devicetree,
	linux-kernel, Pantelis Antoniou, Pantelis Antoniou

The first patch renames the *_node_sysfs methods to _node_post since
this is more accurate when more work takes place besides sysfs
tweaking when the next patch is using a hashtable for phandles.
This is a win for very large blobs with a large number of phandles.
Current we use an exhaustive search which is not optimal at all.

The third patch adds a unittest/benchmark for hashed phandles
along with figures about performance.

A long standing request of applied overlays populating
the symbol list is implemented; this allows staggered overlay
application with a symbol from a previous overlay being used
by another after it.

Finally a pr_fmt for the overlay files is used for
uncluttering the printout a bit.

Changes since v1:
* Reworked phandle hash according to maintainer requests
* Added unittest/benchmark for phandle hash
* Reworked the overlay symbol patch
* Added pr_fmt patch


Pantelis Antoniou (5):
  of: rename *_node_sysfs to _node_post
  of: Support hashtable lookups for phandles
  of: unittest: hashed phandles unitest
  of: overlay: Pick up label symbols from overlays.
  of: overlay: Add pr_fmt for clarity

 drivers/of/base.c       |  45 +++++++++++--
 drivers/of/dynamic.c    |  18 +++--
 drivers/of/of_private.h |  37 ++++++++++-
 drivers/of/overlay.c    | 173 ++++++++++++++++++++++++++++++++++++------------
 drivers/of/unittest.c   |  72 +++++++++++++++++++-
 include/linux/of.h      |   2 +
 6 files changed, 289 insertions(+), 58 deletions(-)

-- 
1.7.12

^ permalink raw reply	[flat|nested] 14+ messages in thread

end of thread, other threads:[~2016-05-17  6:36 UTC | newest]

Thread overview: 14+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2016-05-16 16:52 [PATCH v2 0/5] of: generic infrastructure fixes Pantelis Antoniou
2016-05-16 16:52 ` [PATCH v2 1/5] of: rename *_node_sysfs to _node_post Pantelis Antoniou
2016-05-16 16:52 ` [PATCH v2 2/5] of: Support hashtable lookups for phandles Pantelis Antoniou
2016-05-16 19:37   ` Rob Herring
2016-05-16 20:13     ` Pantelis Antoniou
2016-05-16 16:52 ` [PATCH v2 3/5] of: unittest: hashed phandles unitest Pantelis Antoniou
2016-05-16 19:04   ` Geert Uytterhoeven
2016-05-16 19:38   ` Rob Herring
2016-05-16 16:52 ` [PATCH v2 4/5] of: overlay: Pick up label symbols from overlays Pantelis Antoniou
2016-05-16 19:06   ` Geert Uytterhoeven
2016-05-16 19:27     ` Pantelis Antoniou
2016-05-16 19:40       ` Geert Uytterhoeven
2016-05-17  6:36         ` Geert Uytterhoeven
2016-05-16 16:52 ` [PATCH v2 5/5] of: overlay: Add pr_fmt for clarity Pantelis Antoniou

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).