linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* [PATCH] mac80211: Use kstrdup to simplify code
@ 2015-07-08 19:32 Christophe JAILLET
  2015-07-08 19:53 ` Emmanuel Grumbach
  2015-07-08 20:22 ` [PATCH v2] brcmsmac: " Christophe JAILLET
  0 siblings, 2 replies; 5+ messages in thread
From: Christophe JAILLET @ 2015-07-08 19:32 UTC (permalink / raw)
  To: kvalo, brudley, arend, frankyl, meuleman
  Cc: linux-wireless, brcm80211-dev-list, netdev, linux-kernel,
	kernel-janitors, Christophe JAILLET

Replace a kmalloc+strcpy by an equivalent kstrdup in order to improve
readability.

Signed-off-by: Christophe JAILLET <christophe.jaillet@wanadoo.fr>
---
 drivers/net/wireless/brcm80211/brcmsmac/mac80211_if.c | 4 +---
 1 file changed, 1 insertion(+), 3 deletions(-)

diff --git a/drivers/net/wireless/brcm80211/brcmsmac/mac80211_if.c b/drivers/net/wireless/brcm80211/brcmsmac/mac80211_if.c
index 4813506..8a6c077 100644
--- a/drivers/net/wireless/brcm80211/brcmsmac/mac80211_if.c
+++ b/drivers/net/wireless/brcm80211/brcmsmac/mac80211_if.c
@@ -1476,9 +1476,7 @@ struct brcms_timer *brcms_init_timer(struct brcms_info *wl,
 	wl->timers = t;
 
 #ifdef DEBUG
-	t->name = kmalloc(strlen(name) + 1, GFP_ATOMIC);
-	if (t->name)
-		strcpy(t->name, name);
+	t->name = kstrdup(name, GFP_ATOMIC);
 #endif
 
 	return t;
-- 
2.1.4


^ permalink raw reply related	[flat|nested] 5+ messages in thread

* Re: [PATCH] mac80211: Use kstrdup to simplify code
  2015-07-08 19:32 [PATCH] mac80211: Use kstrdup to simplify code Christophe JAILLET
@ 2015-07-08 19:53 ` Emmanuel Grumbach
  2015-07-08 20:22 ` [PATCH v2] brcmsmac: " Christophe JAILLET
  1 sibling, 0 replies; 5+ messages in thread
From: Emmanuel Grumbach @ 2015-07-08 19:53 UTC (permalink / raw)
  To: Christophe JAILLET
  Cc: Kalle Valo, brudley, Arend van Spriel, frankyl, meuleman,
	linux-wireless, brcm80211-dev-list, netdev, linux-kernel,
	kernel-janitors

The subject is wrong. You are not patch mac80211, but bcrmsmac.

On Wed, Jul 8, 2015 at 10:32 PM, Christophe JAILLET
<christophe.jaillet@wanadoo.fr> wrote:
> Replace a kmalloc+strcpy by an equivalent kstrdup in order to improve
> readability.
>
> Signed-off-by: Christophe JAILLET <christophe.jaillet@wanadoo.fr>
> ---
>  drivers/net/wireless/brcm80211/brcmsmac/mac80211_if.c | 4 +---
>  1 file changed, 1 insertion(+), 3 deletions(-)
>
> diff --git a/drivers/net/wireless/brcm80211/brcmsmac/mac80211_if.c b/drivers/net/wireless/brcm80211/brcmsmac/mac80211_if.c
> index 4813506..8a6c077 100644
> --- a/drivers/net/wireless/brcm80211/brcmsmac/mac80211_if.c
> +++ b/drivers/net/wireless/brcm80211/brcmsmac/mac80211_if.c
> @@ -1476,9 +1476,7 @@ struct brcms_timer *brcms_init_timer(struct brcms_info *wl,
>         wl->timers = t;
>
>  #ifdef DEBUG
> -       t->name = kmalloc(strlen(name) + 1, GFP_ATOMIC);
> -       if (t->name)
> -               strcpy(t->name, name);
> +       t->name = kstrdup(name, GFP_ATOMIC);
>  #endif
>
>         return t;
> --
> 2.1.4
>
> --
> To unsubscribe from this list: send the line "unsubscribe linux-wireless" in
> the body of a message to majordomo@vger.kernel.org
> More majordomo info at  http://vger.kernel.org/majordomo-info.html

^ permalink raw reply	[flat|nested] 5+ messages in thread

* [PATCH v2] brcmsmac: Use kstrdup to simplify code
  2015-07-08 19:32 [PATCH] mac80211: Use kstrdup to simplify code Christophe JAILLET
  2015-07-08 19:53 ` Emmanuel Grumbach
@ 2015-07-08 20:22 ` Christophe JAILLET
  2015-07-09 18:36   ` Arend van Spriel
  2015-07-21 14:59   ` [v2] " Kalle Valo
  1 sibling, 2 replies; 5+ messages in thread
From: Christophe JAILLET @ 2015-07-08 20:22 UTC (permalink / raw)
  To: kvalo, brudley, arend, frankyl, meuleman
  Cc: linux-wireless, brcm80211-dev-list, netdev, linux-kernel,
	kernel-janitors, Christophe JAILLET

Replace a kmalloc+strcpy by an equivalent kstrdup in order to improve
readability.

Signed-off-by: Christophe JAILLET <christophe.jaillet@wanadoo.fr>
---
v2: fix the subject

 drivers/net/wireless/brcm80211/brcmsmac/mac80211_if.c | 4 +---
 1 file changed, 1 insertion(+), 3 deletions(-)

diff --git a/drivers/net/wireless/brcm80211/brcmsmac/mac80211_if.c b/drivers/net/wireless/brcm80211/brcmsmac/mac80211_if.c
index 4813506..8a6c077 100644
--- a/drivers/net/wireless/brcm80211/brcmsmac/mac80211_if.c
+++ b/drivers/net/wireless/brcm80211/brcmsmac/mac80211_if.c
@@ -1476,9 +1476,7 @@ struct brcms_timer *brcms_init_timer(struct brcms_info *wl,
 	wl->timers = t;
 
 #ifdef DEBUG
-	t->name = kmalloc(strlen(name) + 1, GFP_ATOMIC);
-	if (t->name)
-		strcpy(t->name, name);
+	t->name = kstrdup(name, GFP_ATOMIC);
 #endif
 
 	return t;
-- 
2.1.4


^ permalink raw reply related	[flat|nested] 5+ messages in thread

* Re: [PATCH v2] brcmsmac: Use kstrdup to simplify code
  2015-07-08 20:22 ` [PATCH v2] brcmsmac: " Christophe JAILLET
@ 2015-07-09 18:36   ` Arend van Spriel
  2015-07-21 14:59   ` [v2] " Kalle Valo
  1 sibling, 0 replies; 5+ messages in thread
From: Arend van Spriel @ 2015-07-09 18:36 UTC (permalink / raw)
  To: Christophe JAILLET, kvalo, brudley, frankyl, meuleman
  Cc: linux-wireless, brcm80211-dev-list, netdev, linux-kernel,
	kernel-janitors

On 07/08/2015 10:22 PM, Christophe JAILLET wrote:
> Replace a kmalloc+strcpy by an equivalent kstrdup in order to improve
> readability.

Not sure if readability is really the issue here. At most it is a small 
reduction of driver code by using kstrdup(). Anyway, the patch looks fine so

Acked-by: Arend van Spriel <arend@broadcom.com>
> Signed-off-by: Christophe JAILLET <christophe.jaillet@wanadoo.fr>
> ---
> v2: fix the subject
>
>   drivers/net/wireless/brcm80211/brcmsmac/mac80211_if.c | 4 +---
>   1 file changed, 1 insertion(+), 3 deletions(-)
>
> diff --git a/drivers/net/wireless/brcm80211/brcmsmac/mac80211_if.c b/drivers/net/wireless/brcm80211/brcmsmac/mac80211_if.c
> index 4813506..8a6c077 100644
> --- a/drivers/net/wireless/brcm80211/brcmsmac/mac80211_if.c
> +++ b/drivers/net/wireless/brcm80211/brcmsmac/mac80211_if.c
> @@ -1476,9 +1476,7 @@ struct brcms_timer *brcms_init_timer(struct brcms_info *wl,
>   	wl->timers = t;
>
>   #ifdef DEBUG
> -	t->name = kmalloc(strlen(name) + 1, GFP_ATOMIC);
> -	if (t->name)
> -		strcpy(t->name, name);
> +	t->name = kstrdup(name, GFP_ATOMIC);
>   #endif
>
>   	return t;
>


^ permalink raw reply	[flat|nested] 5+ messages in thread

* Re: [v2] brcmsmac: Use kstrdup to simplify code
  2015-07-08 20:22 ` [PATCH v2] brcmsmac: " Christophe JAILLET
  2015-07-09 18:36   ` Arend van Spriel
@ 2015-07-21 14:59   ` Kalle Valo
  1 sibling, 0 replies; 5+ messages in thread
From: Kalle Valo @ 2015-07-21 14:59 UTC (permalink / raw)
  To: Christophe Jaillet
  Cc: brudley, arend, frankyl, meuleman, linux-wireless,
	brcm80211-dev-list, netdev, linux-kernel, kernel-janitors,
	Christophe JAILLET


> Replace a kmalloc+strcpy by an equivalent kstrdup in order to improve
> readability.
> 
> Signed-off-by: Christophe JAILLET <christophe.jaillet@wanadoo.fr>
> Acked-by: Arend van Spriel <arend@broadcom.com>

Thanks, applied to wireless-drivers-next.git.

Kalle Valo

^ permalink raw reply	[flat|nested] 5+ messages in thread

end of thread, other threads:[~2015-07-21 14:59 UTC | newest]

Thread overview: 5+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2015-07-08 19:32 [PATCH] mac80211: Use kstrdup to simplify code Christophe JAILLET
2015-07-08 19:53 ` Emmanuel Grumbach
2015-07-08 20:22 ` [PATCH v2] brcmsmac: " Christophe JAILLET
2015-07-09 18:36   ` Arend van Spriel
2015-07-21 14:59   ` [v2] " Kalle Valo

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).