linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* [PATCH] openrisc: rename or32 code & comments to or1k
@ 2021-07-16  2:23 Randy Dunlap
  2021-07-16  6:11 ` kernel test robot
  2021-07-19  4:39 ` Stafford Horne
  0 siblings, 2 replies; 5+ messages in thread
From: Randy Dunlap @ 2021-07-16  2:23 UTC (permalink / raw)
  To: linux-kernel
  Cc: Randy Dunlap, Jonas Bonn, Stefan Kristiansson, Stafford Horne, openrisc

From Documentation/openrisc/todo.rst, rename "or32" in the
source code to "or1k" since this is the name that has been
settled on.

Signed-off-by: Randy Dunlap <rdunlap@infradead.org>
Cc: Jonas Bonn <jonas@southpole.se>
Cc: Stefan Kristiansson <stefan.kristiansson@saunalahti.fi>
Cc: Stafford Horne <shorne@gmail.com>
Cc: openrisc@lists.librecores.org
---
 arch/openrisc/include/asm/pgtable.h     |    6 +++---
 arch/openrisc/include/asm/thread_info.h |    2 +-
 arch/openrisc/kernel/entry.S            |    4 ++--
 arch/openrisc/kernel/head.S             |    6 +++---
 arch/openrisc/kernel/setup.c            |    4 ++--
 arch/openrisc/lib/Makefile              |    2 +-
 arch/openrisc/mm/fault.c                |    2 +-
 7 files changed, 13 insertions(+), 13 deletions(-)

--- linux-next-20210715.orig/arch/openrisc/include/asm/pgtable.h
+++ linux-next-20210715/arch/openrisc/include/asm/pgtable.h
@@ -12,7 +12,7 @@
  * et al.
  */
 
-/* or32 pgtable.h - macros and functions to manipulate page tables
+/* or1k pgtable.h - macros and functions to manipulate page tables
  *
  * Based on:
  * include/asm-cris/pgtable.h
@@ -29,14 +29,14 @@
 
 /*
  * The Linux memory management assumes a three-level page table setup. On
- * or32, we use that, but "fold" the mid level into the top-level page
+ * or1k, we use that, but "fold" the mid level into the top-level page
  * table. Since the MMU TLB is software loaded through an interrupt, it
  * supports any page table structure, so we could have used a three-level
  * setup, but for the amounts of memory we normally use, a two-level is
  * probably more efficient.
  *
  * This file contains the functions and defines necessary to modify and use
- * the or32 page table tree.
+ * the or1k page table tree.
  */
 
 extern void paging_init(void);
--- linux-next-20210715.orig/arch/openrisc/include/asm/thread_info.h
+++ linux-next-20210715/arch/openrisc/include/asm/thread_info.h
@@ -25,7 +25,7 @@
 
 /* THREAD_SIZE is the size of the task_struct/kernel_stack combo.
  * normally, the stack is found by doing something like p + THREAD_SIZE
- * in or32, a page is 8192 bytes, which seems like a sane size
+ * in or1k, a page is 8192 bytes, which seems like a sane size
  */
 
 #define THREAD_SIZE_ORDER 0
--- linux-next-20210715.orig/arch/openrisc/lib/Makefile
+++ linux-next-20210715/arch/openrisc/lib/Makefile
@@ -1,6 +1,6 @@
 # SPDX-License-Identifier: GPL-2.0-only
 #
-# Makefile for or32 specific library files..
+# Makefile for or1k specific library files..
 #
 
 obj-y	:= delay.o string.o memset.o memcpy.o
--- linux-next-20210715.orig/arch/openrisc/mm/fault.c
+++ linux-next-20210715/arch/openrisc/mm/fault.c
@@ -28,7 +28,7 @@ unsigned long pte_misses;	/* updated by
 unsigned long pte_errors;	/* updated by do_page_fault() */
 
 /* __PHX__ :: - check the vmalloc_fault in do_page_fault()
- *            - also look into include/asm-or32/mmu_context.h
+ *            - also look into include/asm/mmu_context.h
  */
 volatile pgd_t *current_pgd[NR_CPUS];
 
--- linux-next-20210715.orig/arch/openrisc/kernel/entry.S
+++ linux-next-20210715/arch/openrisc/kernel/entry.S
@@ -326,7 +326,7 @@ EXCEPTION_ENTRY(_data_page_fault_handler
 1:	l.ori   r6,r0,0x0                  // !write access
 2:
 
-	/* call fault.c handler in or32/mm/fault.c */
+	/* call fault.c handler in openrisc/mm/fault.c */
 	l.jal   do_page_fault
 	 l.nop
 	l.j     _ret_from_exception
@@ -348,7 +348,7 @@ EXCEPTION_ENTRY(_insn_page_fault_handler
 	/* r4 set be EXCEPTION_HANDLE */   // effective address of fault
 	l.ori	r6,r0,0x0		   // !write access
 
-	/* call fault.c handler in or32/mm/fault.c */
+	/* call fault.c handler in openrisc/mm/fault.c */
 	l.jal   do_page_fault
 	 l.nop
 	l.j     _ret_from_exception
--- linux-next-20210715.orig/arch/openrisc/kernel/head.S
+++ linux-next-20210715/arch/openrisc/kernel/head.S
@@ -599,7 +599,7 @@ flush_tlb:
 	l.jal	_flush_tlb
 	 l.nop
 
-/* The MMU needs to be enabled before or32_early_setup is called */
+/* The MMU needs to be enabled before or1k_early_setup is called */
 
 enable_mmu:
 	/*
@@ -641,9 +641,9 @@ enable_mmu:
 	/* magic number mismatch, set fdt pointer to null */
 	l.or	r25,r0,r0
 _fdt_found:
-	/* pass fdt pointer to or32_early_setup in r3 */
+	/* pass fdt pointer to or1k_early_setup in r3 */
 	l.or	r3,r0,r25
-	LOAD_SYMBOL_2_GPR(r24, or32_early_setup)
+	LOAD_SYMBOL_2_GPR(r24, or1k_early_setup)
 	l.jalr r24
 	 l.nop
 
--- linux-next-20210715.orig/arch/openrisc/kernel/setup.c
+++ linux-next-20210715/arch/openrisc/kernel/setup.c
@@ -209,7 +209,7 @@ void __init setup_cpuinfo(void)
 }
 
 /**
- * or32_early_setup
+ * or1k_early_setup
  *
  * Handles the pointer to the device tree that this kernel is to use
  * for establishing the available platform devices.
@@ -217,7 +217,7 @@ void __init setup_cpuinfo(void)
  * Falls back on built-in device tree in case null pointer is passed.
  */
 
-void __init or32_early_setup(void *fdt)
+void __init or1k_early_setup(void *fdt)
 {
 	if (fdt)
 		pr_info("FDT at %p\n", fdt);

^ permalink raw reply	[flat|nested] 5+ messages in thread

* Re: [PATCH] openrisc: rename or32 code & comments to or1k
  2021-07-16  2:23 [PATCH] openrisc: rename or32 code & comments to or1k Randy Dunlap
@ 2021-07-16  6:11 ` kernel test robot
  2021-07-19  4:39 ` Stafford Horne
  1 sibling, 0 replies; 5+ messages in thread
From: kernel test robot @ 2021-07-16  6:11 UTC (permalink / raw)
  To: Randy Dunlap, linux-kernel
  Cc: kbuild-all, Randy Dunlap, Jonas Bonn, Stefan Kristiansson,
	Stafford Horne, openrisc

[-- Attachment #1: Type: text/plain, Size: 3021 bytes --]

Hi Randy,

Thank you for the patch! Perhaps something to improve:

[auto build test WARNING on openrisc/for-next]
[also build test WARNING on linux/master linus/master v5.14-rc1 next-20210715]
[If your patch is applied to the wrong git tree, kindly drop us a note.
And when submitting patch, we suggest to use '--base' as documented in
https://git-scm.com/docs/git-format-patch]

url:    https://github.com/0day-ci/linux/commits/Randy-Dunlap/openrisc-rename-or32-code-comments-to-or1k/20210716-102427
base:   https://github.com/openrisc/linux.git for-next
config: openrisc-buildonly-randconfig-r002-20210716 (attached as .config)
compiler: or1k-linux-gcc (GCC) 10.3.0
reproduce (this is a W=1 build):
        wget https://raw.githubusercontent.com/intel/lkp-tests/master/sbin/make.cross -O ~/bin/make.cross
        chmod +x ~/bin/make.cross
        # https://github.com/0day-ci/linux/commit/d5551791af9959a80485de163c57a26be971ae5e
        git remote add linux-review https://github.com/0day-ci/linux
        git fetch --no-tags linux-review Randy-Dunlap/openrisc-rename-or32-code-comments-to-or1k/20210716-102427
        git checkout d5551791af9959a80485de163c57a26be971ae5e
        # save the attached .config to linux build tree
        COMPILER_INSTALL_PATH=$HOME/0day COMPILER=gcc-10.3.0 make.cross ARCH=openrisc 

If you fix the issue, kindly add following tag as appropriate
Reported-by: kernel test robot <lkp@intel.com>

All warnings (new ones prefixed by >>):

>> arch/openrisc/kernel/setup.c:220:13: warning: no previous prototype for 'or1k_early_setup' [-Wmissing-prototypes]
     220 | void __init or1k_early_setup(void *fdt)
         |             ^~~~~~~~~~~~~~~~
   arch/openrisc/kernel/setup.c:246:13: warning: no previous prototype for 'detect_unit_config' [-Wmissing-prototypes]
     246 | void __init detect_unit_config(unsigned long upr, unsigned long mask,
         |             ^~~~~~~~~~~~~~~~~~

Kconfig warnings: (for reference only)
   WARNING: unmet direct dependencies detected for LOCKDEP
   Depends on DEBUG_KERNEL && LOCK_DEBUGGING_SUPPORT && (FRAME_POINTER || MIPS || PPC || S390 || MICROBLAZE || ARM || ARC || X86)
   Selected by
   - LOCK_STAT && DEBUG_KERNEL && LOCK_DEBUGGING_SUPPORT
   - DEBUG_LOCK_ALLOC && DEBUG_KERNEL && LOCK_DEBUGGING_SUPPORT


vim +/or1k_early_setup +220 arch/openrisc/kernel/setup.c

   210	
   211	/**
   212	 * or1k_early_setup
   213	 *
   214	 * Handles the pointer to the device tree that this kernel is to use
   215	 * for establishing the available platform devices.
   216	 *
   217	 * Falls back on built-in device tree in case null pointer is passed.
   218	 */
   219	
 > 220	void __init or1k_early_setup(void *fdt)
   221	{
   222		if (fdt)
   223			pr_info("FDT at %p\n", fdt);
   224		else {
   225			fdt = __dtb_start;
   226			pr_info("Compiled-in FDT at %p\n", fdt);
   227		}
   228		early_init_devtree(fdt);
   229	}
   230	

---
0-DAY CI Kernel Test Service, Intel Corporation
https://lists.01.org/hyperkitty/list/kbuild-all@lists.01.org

[-- Attachment #2: .config.gz --]
[-- Type: application/gzip, Size: 24125 bytes --]

^ permalink raw reply	[flat|nested] 5+ messages in thread

* Re: [PATCH] openrisc: rename or32 code & comments to or1k
  2021-07-16  2:23 [PATCH] openrisc: rename or32 code & comments to or1k Randy Dunlap
  2021-07-16  6:11 ` kernel test robot
@ 2021-07-19  4:39 ` Stafford Horne
  2021-07-19  5:00   ` Randy Dunlap
  1 sibling, 1 reply; 5+ messages in thread
From: Stafford Horne @ 2021-07-19  4:39 UTC (permalink / raw)
  To: Randy Dunlap; +Cc: linux-kernel, Jonas Bonn, Stefan Kristiansson, openrisc

On Thu, Jul 15, 2021 at 07:23:38PM -0700, Randy Dunlap wrote:
> From Documentation/openrisc/todo.rst, rename "or32" in the
> source code to "or1k" since this is the name that has been
> settled on.

Hello, the kernel test robot found a build failure with this.

Will you send the update for that?

> Signed-off-by: Randy Dunlap <rdunlap@infradead.org>
> Cc: Jonas Bonn <jonas@southpole.se>
> Cc: Stefan Kristiansson <stefan.kristiansson@saunalahti.fi>
> Cc: Stafford Horne <shorne@gmail.com>
> Cc: openrisc@lists.librecores.org
> ---
>  arch/openrisc/include/asm/pgtable.h     |    6 +++---
>  arch/openrisc/include/asm/thread_info.h |    2 +-
>  arch/openrisc/kernel/entry.S            |    4 ++--
>  arch/openrisc/kernel/head.S             |    6 +++---
>  arch/openrisc/kernel/setup.c            |    4 ++--
>  arch/openrisc/lib/Makefile              |    2 +-
>  arch/openrisc/mm/fault.c                |    2 +-
>  7 files changed, 13 insertions(+), 13 deletions(-)
> 
> --- linux-next-20210715.orig/arch/openrisc/include/asm/pgtable.h
> +++ linux-next-20210715/arch/openrisc/include/asm/pgtable.h
> @@ -12,7 +12,7 @@
>   * et al.
>   */
>  
> -/* or32 pgtable.h - macros and functions to manipulate page tables
> +/* or1k pgtable.h - macros and functions to manipulate page tables
>   *
>   * Based on:
>   * include/asm-cris/pgtable.h
> @@ -29,14 +29,14 @@
>  
>  /*
>   * The Linux memory management assumes a three-level page table setup. On
> - * or32, we use that, but "fold" the mid level into the top-level page
> + * or1k, we use that, but "fold" the mid level into the top-level page
>   * table. Since the MMU TLB is software loaded through an interrupt, it
>   * supports any page table structure, so we could have used a three-level
>   * setup, but for the amounts of memory we normally use, a two-level is
>   * probably more efficient.
>   *
>   * This file contains the functions and defines necessary to modify and use
> - * the or32 page table tree.
> + * the or1k page table tree.
>   */
>  
>  extern void paging_init(void);
> --- linux-next-20210715.orig/arch/openrisc/include/asm/thread_info.h
> +++ linux-next-20210715/arch/openrisc/include/asm/thread_info.h
> @@ -25,7 +25,7 @@
>  
>  /* THREAD_SIZE is the size of the task_struct/kernel_stack combo.
>   * normally, the stack is found by doing something like p + THREAD_SIZE
> - * in or32, a page is 8192 bytes, which seems like a sane size
> + * in or1k, a page is 8192 bytes, which seems like a sane size
>   */
>  
>  #define THREAD_SIZE_ORDER 0
> --- linux-next-20210715.orig/arch/openrisc/lib/Makefile
> +++ linux-next-20210715/arch/openrisc/lib/Makefile
> @@ -1,6 +1,6 @@
>  # SPDX-License-Identifier: GPL-2.0-only
>  #
> -# Makefile for or32 specific library files..
> +# Makefile for or1k specific library files..
>  #
>  
>  obj-y	:= delay.o string.o memset.o memcpy.o
> --- linux-next-20210715.orig/arch/openrisc/mm/fault.c
> +++ linux-next-20210715/arch/openrisc/mm/fault.c
> @@ -28,7 +28,7 @@ unsigned long pte_misses;	/* updated by
>  unsigned long pte_errors;	/* updated by do_page_fault() */
>  
>  /* __PHX__ :: - check the vmalloc_fault in do_page_fault()
> - *            - also look into include/asm-or32/mmu_context.h
> + *            - also look into include/asm/mmu_context.h
>   */
>  volatile pgd_t *current_pgd[NR_CPUS];
>  
> --- linux-next-20210715.orig/arch/openrisc/kernel/entry.S
> +++ linux-next-20210715/arch/openrisc/kernel/entry.S
> @@ -326,7 +326,7 @@ EXCEPTION_ENTRY(_data_page_fault_handler
>  1:	l.ori   r6,r0,0x0                  // !write access
>  2:
>  
> -	/* call fault.c handler in or32/mm/fault.c */
> +	/* call fault.c handler in openrisc/mm/fault.c */
>  	l.jal   do_page_fault
>  	 l.nop
>  	l.j     _ret_from_exception
> @@ -348,7 +348,7 @@ EXCEPTION_ENTRY(_insn_page_fault_handler
>  	/* r4 set be EXCEPTION_HANDLE */   // effective address of fault
>  	l.ori	r6,r0,0x0		   // !write access
>  
> -	/* call fault.c handler in or32/mm/fault.c */
> +	/* call fault.c handler in openrisc/mm/fault.c */
>  	l.jal   do_page_fault
>  	 l.nop
>  	l.j     _ret_from_exception
> --- linux-next-20210715.orig/arch/openrisc/kernel/head.S
> +++ linux-next-20210715/arch/openrisc/kernel/head.S
> @@ -599,7 +599,7 @@ flush_tlb:
>  	l.jal	_flush_tlb
>  	 l.nop
>  
> -/* The MMU needs to be enabled before or32_early_setup is called */
> +/* The MMU needs to be enabled before or1k_early_setup is called */
>  
>  enable_mmu:
>  	/*
> @@ -641,9 +641,9 @@ enable_mmu:
>  	/* magic number mismatch, set fdt pointer to null */
>  	l.or	r25,r0,r0
>  _fdt_found:
> -	/* pass fdt pointer to or32_early_setup in r3 */
> +	/* pass fdt pointer to or1k_early_setup in r3 */
>  	l.or	r3,r0,r25
> -	LOAD_SYMBOL_2_GPR(r24, or32_early_setup)
> +	LOAD_SYMBOL_2_GPR(r24, or1k_early_setup)
>  	l.jalr r24
>  	 l.nop
>  
> --- linux-next-20210715.orig/arch/openrisc/kernel/setup.c
> +++ linux-next-20210715/arch/openrisc/kernel/setup.c
> @@ -209,7 +209,7 @@ void __init setup_cpuinfo(void)
>  }
>  
>  /**
> - * or32_early_setup
> + * or1k_early_setup
>   *
>   * Handles the pointer to the device tree that this kernel is to use
>   * for establishing the available platform devices.
> @@ -217,7 +217,7 @@ void __init setup_cpuinfo(void)
>   * Falls back on built-in device tree in case null pointer is passed.
>   */
>  
> -void __init or32_early_setup(void *fdt)
> +void __init or1k_early_setup(void *fdt)
>  {
>  	if (fdt)
>  		pr_info("FDT at %p\n", fdt);

^ permalink raw reply	[flat|nested] 5+ messages in thread

* Re: [PATCH] openrisc: rename or32 code & comments to or1k
  2021-07-19  4:39 ` Stafford Horne
@ 2021-07-19  5:00   ` Randy Dunlap
  2021-07-19  7:22     ` Stafford Horne
  0 siblings, 1 reply; 5+ messages in thread
From: Randy Dunlap @ 2021-07-19  5:00 UTC (permalink / raw)
  To: Stafford Horne; +Cc: linux-kernel, Jonas Bonn, Stefan Kristiansson, openrisc

On 7/18/21 9:39 PM, Stafford Horne wrote:
> On Thu, Jul 15, 2021 at 07:23:38PM -0700, Randy Dunlap wrote:
>> From Documentation/openrisc/todo.rst, rename "or32" in the
>> source code to "or1k" since this is the name that has been
>> settled on.
> 
> Hello, the kernel test robot found a build failure with this.
> 
> Will you send the update for that?
> 

Hi,

The robot problems are not related to this patch (they were
there before this patch), but I will send an update if you insist.

-- 
~Randy


^ permalink raw reply	[flat|nested] 5+ messages in thread

* Re: [PATCH] openrisc: rename or32 code & comments to or1k
  2021-07-19  5:00   ` Randy Dunlap
@ 2021-07-19  7:22     ` Stafford Horne
  0 siblings, 0 replies; 5+ messages in thread
From: Stafford Horne @ 2021-07-19  7:22 UTC (permalink / raw)
  To: Randy Dunlap; +Cc: linux-kernel, Jonas Bonn, Stefan Kristiansson, openrisc

On Sun, Jul 18, 2021 at 10:00:42PM -0700, Randy Dunlap wrote:
> On 7/18/21 9:39 PM, Stafford Horne wrote:
> > On Thu, Jul 15, 2021 at 07:23:38PM -0700, Randy Dunlap wrote:
> >> From Documentation/openrisc/todo.rst, rename "or32" in the
> >> source code to "or1k" since this is the name that has been
> >> settled on.
> > 
> > Hello, the kernel test robot found a build failure with this.
> > 
> > Will you send the update for that?
> > 
> 
> Hi,
> 
> The robot problems are not related to this patch (they were
> there before this patch), but I will send an update if you insist.

No problem,  I didn't investigate but just thought you had missed renaming
something.  In that case I will queue this and also look into fixing the robot
warning.

Thank you

-Stafford

^ permalink raw reply	[flat|nested] 5+ messages in thread

end of thread, other threads:[~2021-07-19  7:22 UTC | newest]

Thread overview: 5+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2021-07-16  2:23 [PATCH] openrisc: rename or32 code & comments to or1k Randy Dunlap
2021-07-16  6:11 ` kernel test robot
2021-07-19  4:39 ` Stafford Horne
2021-07-19  5:00   ` Randy Dunlap
2021-07-19  7:22     ` Stafford Horne

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).