linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* [PATCH] greybus: using pm_runtime_resume_and_get to simplify the code
@ 2022-04-20  3:06 cgel.zte
  2022-04-20  8:01 ` Johan Hovold
  0 siblings, 1 reply; 2+ messages in thread
From: cgel.zte @ 2022-04-20  3:06 UTC (permalink / raw)
  To: johan; +Cc: elder, gregkh, greybus-dev, linux-kernel, Minghao Chi, Zeal Robot

From: Minghao Chi <chi.minghao@zte.com.cn>

Using pm_runtime_resume_and_get() to replace pm_runtime_get_sync and
pm_runtime_put_noidle. This change is just to simplify the code, no
actual functional changes.

Reported-by: Zeal Robot <zealci@zte.com.cn>
Signed-off-by: Minghao Chi <chi.minghao@zte.com.cn>
---
 drivers/greybus/core.c | 6 ++----
 1 file changed, 2 insertions(+), 4 deletions(-)

diff --git a/drivers/greybus/core.c b/drivers/greybus/core.c
index e546c6431877..434aa5d9dd47 100644
--- a/drivers/greybus/core.c
+++ b/drivers/greybus/core.c
@@ -174,11 +174,9 @@ static int greybus_probe(struct device *dev)
 	if (!id)
 		return -ENODEV;
 
-	retval = pm_runtime_get_sync(&bundle->intf->dev);
-	if (retval < 0) {
-		pm_runtime_put_noidle(&bundle->intf->dev);
+	retval = pm_runtime_resume_and_get(&bundle->intf->dev);
+	if (retval < 0)
 		return retval;
-	}
 
 	retval = gb_control_bundle_activate(bundle->intf->control, bundle->id);
 	if (retval) {
-- 
2.25.1



^ permalink raw reply related	[flat|nested] 2+ messages in thread

* Re: [PATCH] greybus: using pm_runtime_resume_and_get to simplify the code
  2022-04-20  3:06 [PATCH] greybus: using pm_runtime_resume_and_get to simplify the code cgel.zte
@ 2022-04-20  8:01 ` Johan Hovold
  0 siblings, 0 replies; 2+ messages in thread
From: Johan Hovold @ 2022-04-20  8:01 UTC (permalink / raw)
  To: cgel.zte
  Cc: elder, gregkh, greybus-dev, linux-kernel, Minghao Chi, Zeal Robot

On Wed, Apr 20, 2022 at 03:06:58AM +0000, cgel.zte@gmail.com wrote:
> From: Minghao Chi <chi.minghao@zte.com.cn>

Why are you sending patches from a random non-personal gmail address?

> Using pm_runtime_resume_and_get() to replace pm_runtime_get_sync and
> pm_runtime_put_noidle. This change is just to simplify the code, no
> actual functional changes.
> 
> Reported-by: Zeal Robot <zealci@zte.com.cn>

And why is this here?

> Signed-off-by: Minghao Chi <chi.minghao@zte.com.cn>
> ---
>  drivers/greybus/core.c | 6 ++----
>  1 file changed, 2 insertions(+), 4 deletions(-)
> 
> diff --git a/drivers/greybus/core.c b/drivers/greybus/core.c
> index e546c6431877..434aa5d9dd47 100644
> --- a/drivers/greybus/core.c
> +++ b/drivers/greybus/core.c
> @@ -174,11 +174,9 @@ static int greybus_probe(struct device *dev)
>  	if (!id)
>  		return -ENODEV;
>  
> -	retval = pm_runtime_get_sync(&bundle->intf->dev);
> -	if (retval < 0) {
> -		pm_runtime_put_noidle(&bundle->intf->dev);
> +	retval = pm_runtime_resume_and_get(&bundle->intf->dev);
> +	if (retval < 0)
>  		return retval;
> -	}

NAK.

Greybus is using the pm_runtime_get_sync() consistently and mixing it up
with the new helper that uses a different naming scheme is just
confusing.

Use the new helper for your own code if you prefer, but there's really
no need to go around submitting this automatic conversions for code
that's already in the tree.

>  	retval = gb_control_bundle_activate(bundle->intf->control, bundle->id);
>  	if (retval) {

Johan

^ permalink raw reply	[flat|nested] 2+ messages in thread

end of thread, other threads:[~2022-04-20  8:01 UTC | newest]

Thread overview: 2+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2022-04-20  3:06 [PATCH] greybus: using pm_runtime_resume_and_get to simplify the code cgel.zte
2022-04-20  8:01 ` Johan Hovold

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).