linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* [PATCH net-next 0/4] net: hns3: cleanup and optimization
@ 2022-09-27 11:12 Guangbin Huang
  2022-09-27 11:12 ` [PATCH net-next 1/4] net: hns3: refine the tcam key convert handle Guangbin Huang
                   ` (3 more replies)
  0 siblings, 4 replies; 9+ messages in thread
From: Guangbin Huang @ 2022-09-27 11:12 UTC (permalink / raw)
  To: davem, kuba
  Cc: edumazet, pabeni, netdev, linux-kernel, huangguangbin2,
	shenjian15, lanhao

This serial includes some cleanup and one optimization patches for
HNS3 driver.

Guangbin Huang (1):
  net: hns3: delete unnecessary vf value judgement when get vport id

Hao Chen (2):
  net: hns3: fix hns3 driver header file not self-contained issue
  net: hns3: replace magic numbers with macro for IPv4/v6

Jian Shen (1):
  net: hns3: refine the tcam key convert handle

 drivers/net/ethernet/hisilicon/hns3/hclge_mbx.h      |  4 +++-
 .../hns3/hns3_common/hclge_comm_tqp_stats.h          |  2 ++
 drivers/net/ethernet/hisilicon/hns3/hns3_enet.c      | 12 ++++++------
 drivers/net/ethernet/hisilicon/hns3/hns3_enet.h      |  6 ++++++
 .../net/ethernet/hisilicon/hns3/hns3pf/hclge_main.c  |  4 +---
 .../net/ethernet/hisilicon/hns3/hns3pf/hclge_main.h  | 11 +++--------
 .../net/ethernet/hisilicon/hns3/hns3pf/hclge_ptp.h   |  5 ++++-
 7 files changed, 25 insertions(+), 19 deletions(-)

-- 
2.33.0


^ permalink raw reply	[flat|nested] 9+ messages in thread
* Re: [PATCH net-next 1/4] net: hns3: refine the tcam key convert handle
@ 2022-11-15 14:00 Lanhao (Lan)
  0 siblings, 0 replies; 9+ messages in thread
From: Lanhao (Lan) @ 2022-11-15 14:00 UTC (permalink / raw)
  To: Leon Romanovsky, huangguangbin (A)
  Cc: davem, kuba, edumazet, pabeni, netdev, linux-kernel, shenjian (K)

Can you please explain why do you need special define for boolean AND?
we use '&', just define a bitwise AND, not define boolean AND.

On Tue, Sep 28, 2022 at 10:28:02AM +0800, Leon Romanovsky wrote:
>On Tue, Sep 27, 2022 at 07:12:02PM +0800, Guangbin Huang wrote:
>> From: Jian Shen <shenjian15@huawei.com>
>> 
>> The expression '(k ^ ~v)' is exaclty '(k & v)', and '(k & v) & k' is 
>> exaclty 'k & v'. So simplify the expression for tcam key convert.
>> 
>> It also add necessary brackets for them.
>> 
>> Signed-off-by: Jian Shen <shenjian15@huawei.com>
>> Signed-off-by: Guangbin Huang <huangguangbin2@huawei.com>
>> ---
>>  .../net/ethernet/hisilicon/hns3/hns3pf/hclge_main.h   | 11 +++--------
>>  1 file changed, 3 insertions(+), 8 deletions(-)
>> 
>> diff --git a/drivers/net/ethernet/hisilicon/hns3/hns3pf/hclge_main.h 
>> b/drivers/net/ethernet/hisilicon/hns3/hns3pf/hclge_main.h
>> index 495b639b0dc2..59bfacc687c9 100644
>> --- a/drivers/net/ethernet/hisilicon/hns3/hns3pf/hclge_main.h
>> +++ b/drivers/net/ethernet/hisilicon/hns3/hns3pf/hclge_main.h
>> @@ -827,15 +827,10 @@ struct hclge_vf_vlan_cfg {
>>   * Then for input key(k) and mask(v), we can calculate the value by
>>   * the formulae:
>>   *	x = (~k) & v
>> - *	y = (k ^ ~v) & k
>> + *	y = k & v
>>   */
>> -#define calc_x(x, k, v) (x = ~(k) & (v)) -#define calc_y(y, k, v) \
>> -	do { \
>> -		const typeof(k) _k_ = (k); \
>> -		const typeof(v) _v_ = (v); \
>> -		(y) = (_k_ ^ ~_v_) & (_k_); \
>> -	} while (0)
>> +#define calc_x(x, k, v) ((x) = ~(k) & (v)) #define calc_y(y, k, v) 
>> +((y) = (k) & (v))
>
>Can you please explain why do you need special define for boolean AND?
>
>Thanks
we use '&', just define a bitwise AND, not define boolean AND.
>
>>  
>>  #define HCLGE_MAC_STATS_FIELD_OFF(f) (offsetof(struct 
>> hclge_mac_stats, f))  #define HCLGE_STATS_READ(p, offset) (*(u64 
>> *)((u8 *)(p) + (offset)))
>> --
>> 2.33.0
>> 
>

-----邮件原件-----
发件人: Leon Romanovsky <leon@kernel.org> 
发送时间: 2022年9月28日 18:29
收件人: huangguangbin (A) <huangguangbin2@huawei.com>
抄送: davem@davemloft.net; kuba@kernel.org; edumazet@google.com; pabeni@redhat.com; netdev@vger.kernel.org; linux-kernel@vger.kernel.org; shenjian (K) <shenjian15@huawei.com>; Lanhao (Lan) <lanhao@huawei.com>
主题: Re: [PATCH net-next 1/4] net: hns3: refine the tcam key convert handle

On Tue, Sep 27, 2022 at 07:12:02PM +0800, Guangbin Huang wrote:
> From: Jian Shen <shenjian15@huawei.com>
> 
> The expression '(k ^ ~v)' is exaclty '(k & v)', and '(k & v) & k' is 
> exaclty 'k & v'. So simplify the expression for tcam key convert.
> 
> It also add necessary brackets for them.
> 
> Signed-off-by: Jian Shen <shenjian15@huawei.com>
> Signed-off-by: Guangbin Huang <huangguangbin2@huawei.com>
> ---
>  .../net/ethernet/hisilicon/hns3/hns3pf/hclge_main.h   | 11 +++--------
>  1 file changed, 3 insertions(+), 8 deletions(-)
> 
> diff --git a/drivers/net/ethernet/hisilicon/hns3/hns3pf/hclge_main.h 
> b/drivers/net/ethernet/hisilicon/hns3/hns3pf/hclge_main.h
> index 495b639b0dc2..59bfacc687c9 100644
> --- a/drivers/net/ethernet/hisilicon/hns3/hns3pf/hclge_main.h
> +++ b/drivers/net/ethernet/hisilicon/hns3/hns3pf/hclge_main.h
> @@ -827,15 +827,10 @@ struct hclge_vf_vlan_cfg {
>   * Then for input key(k) and mask(v), we can calculate the value by
>   * the formulae:
>   *	x = (~k) & v
> - *	y = (k ^ ~v) & k
> + *	y = k & v
>   */
> -#define calc_x(x, k, v) (x = ~(k) & (v)) -#define calc_y(y, k, v) \
> -	do { \
> -		const typeof(k) _k_ = (k); \
> -		const typeof(v) _v_ = (v); \
> -		(y) = (_k_ ^ ~_v_) & (_k_); \
> -	} while (0)
> +#define calc_x(x, k, v) ((x) = ~(k) & (v)) #define calc_y(y, k, v) 
> +((y) = (k) & (v))

Can you please explain why do you need special define for boolean AND?

Thanks

>  
>  #define HCLGE_MAC_STATS_FIELD_OFF(f) (offsetof(struct 
> hclge_mac_stats, f))  #define HCLGE_STATS_READ(p, offset) (*(u64 
> *)((u8 *)(p) + (offset)))
> --
> 2.33.0
> 

^ permalink raw reply	[flat|nested] 9+ messages in thread

end of thread, other threads:[~2022-11-15 14:13 UTC | newest]

Thread overview: 9+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2022-09-27 11:12 [PATCH net-next 0/4] net: hns3: cleanup and optimization Guangbin Huang
2022-09-27 11:12 ` [PATCH net-next 1/4] net: hns3: refine the tcam key convert handle Guangbin Huang
2022-09-28 10:28   ` Leon Romanovsky
2022-11-15 14:12     ` Hao Lan
2022-09-27 11:12 ` [PATCH net-next 2/4] net: hns3: fix hns3 driver header file not self-contained issue Guangbin Huang
2022-09-27 11:12 ` [PATCH net-next 3/4] net: hns3: replace magic numbers with macro for IPv4/v6 Guangbin Huang
2022-09-28 10:34   ` Leon Romanovsky
2022-09-27 11:12 ` [PATCH net-next 4/4] net: hns3: delete unnecessary vf value judgement when get vport id Guangbin Huang
2022-11-15 14:00 [PATCH net-next 1/4] net: hns3: refine the tcam key convert handle Lanhao (Lan)

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).