linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Nicolas Pitre <nicolas.pitre@linaro.org>
To: Vincent Guittot <vincent.guittot@linaro.org>
Cc: Peter Zijlstra <peterz@infradead.org>,
	Ingo Molnar <mingo@redhat.com>,
	Daniel Lezcano <daniel.lezcano@linaro.org>,
	Morten Rasmussen <morten.rasmussen@arm.com>,
	"Rafael J. Wysocki" <rjw@rjwysocki.net>,
	linux-kernel <linux-kernel@vger.kernel.org>,
	"linaro-kernel@lists.linaro.org" <linaro-kernel@lists.linaro.org>
Subject: Re: [PATCH 3/6] sched/fair.c: disambiguate existing/remaining "capacity" usage
Date: Thu, 15 May 2014 12:06:40 -0400 (EDT)	[thread overview]
Message-ID: <alpine.LFD.2.11.1405151204090.17310@knanqh.ubzr> (raw)
In-Reply-To: <CAKfTPtDueiEzqL_1kVvScvLvGmeNTMqX5mCU-2JdZ=Uth=nd-g@mail.gmail.com>

On Thu, 15 May 2014, Vincent Guittot wrote:

> On 14 May 2014 22:57, Nicolas Pitre <nicolas.pitre@linaro.org> wrote:
> > We have "power" (which should actually become "capacity") and "capacity"
> > which is a scaled down "capacity factor" in terms of possible tasks.
> > Let's use "capa_factor" to make room for proper usage of "capacity"
> > later.
> >
> > Signed-off-by: Nicolas Pitre <nico@linaro.org>
> > ---
> >  kernel/sched/fair.c | 42 +++++++++++++++++++++---------------------
> >  1 file changed, 21 insertions(+), 21 deletions(-)
> >
> > diff --git a/kernel/sched/fair.c b/kernel/sched/fair.c
> > index 0eda4c527e..2633c42692 100644
> > --- a/kernel/sched/fair.c
> > +++ b/kernel/sched/fair.c
> > @@ -5487,7 +5487,7 @@ struct sg_lb_stats {
> >         unsigned long load_per_task;
> >         unsigned long group_power;
> >         unsigned int sum_nr_running; /* Nr tasks running in the group */
> > -       unsigned int group_capacity;
> > +       unsigned int group_capa_factor;
> 
> As it is mainly compared to sum_nr_running, you might rename it to
> group_nr_capacity instead of group_capa_factor

But what actual meaning would "group_nr_capacity" convey?  This could be 
interpreted as the total number of groups possible for example.


Nicolas

  reply	other threads:[~2014-05-15 16:06 UTC|newest]

Thread overview: 18+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2014-05-14 20:57 [PATCH 0/6] sched: expel confusing usage of the term "power" Nicolas Pitre
2014-05-14 20:57 ` [PATCH 1/6] sched/fair.c: remove "power" from struct numa_stats Nicolas Pitre
2014-05-14 20:57 ` [PATCH 2/6] sched/fair.c: change "has_capacity" to "has_free_capacity" Nicolas Pitre
2014-05-15  7:21   ` Peter Zijlstra
2014-05-15  7:28     ` Vincent Guittot
2014-05-14 20:57 ` [PATCH 3/6] sched/fair.c: disambiguate existing/remaining "capacity" usage Nicolas Pitre
2014-05-15  7:39   ` Vincent Guittot
2014-05-15 16:06     ` Nicolas Pitre [this message]
2014-05-14 20:57 ` [PATCH 4/6] sched: let struct sched_group_power care about CPU capacity Nicolas Pitre
2014-05-14 20:57 ` [PATCH 5/6] sched: remove remaining power to the CPU Nicolas Pitre
2014-05-16  9:00   ` Preeti Murthy
2014-05-16 16:34     ` Nicolas Pitre
2014-05-14 20:57 ` [PATCH 6/6] sched: final power vs capacity cleanup Nicolas Pitre
2014-05-15  7:29   ` Peter Zijlstra
2014-05-15 16:12     ` Nicolas Pitre
2014-05-20  3:05       ` Nicolas Pitre
2014-05-15  7:41 ` [PATCH 0/6] sched: expel confusing usage of the term "power" Vincent Guittot
2014-05-15 16:15   ` Nicolas Pitre

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=alpine.LFD.2.11.1405151204090.17310@knanqh.ubzr \
    --to=nicolas.pitre@linaro.org \
    --cc=daniel.lezcano@linaro.org \
    --cc=linaro-kernel@lists.linaro.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=mingo@redhat.com \
    --cc=morten.rasmussen@arm.com \
    --cc=peterz@infradead.org \
    --cc=rjw@rjwysocki.net \
    --cc=vincent.guittot@linaro.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).