linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* [PATCH] w1: w1_therm: use swap() to make code cleaner
@ 2021-11-04  1:11 davidcomponentone
  2021-11-04 11:09 ` Dan Carpenter
  0 siblings, 1 reply; 6+ messages in thread
From: davidcomponentone @ 2021-11-04  1:11 UTC (permalink / raw)
  To: zbr
  Cc: davidcomponentone, gregkh, ivan.zaentsev, yangyingliang,
	unixbhaskar, dan.carpenter, yang.guang5, linux-kernel,
	Zeal Robot

From: Yang Guang <yang.guang5@zte.com.cn>

Use the macro 'swap()' defined in 'include/linux/minmax.h' to avoid
opencoding it.

Reported-by: Zeal Robot <zealci@zte.com.cn>
Signed-off-by: Yang Guang <yang.guang5@zte.com.cn>
---
 drivers/w1/slaves/w1_therm.c | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/drivers/w1/slaves/w1_therm.c b/drivers/w1/slaves/w1_therm.c
index ca70c5f03206..c743cb3d277a 100644
--- a/drivers/w1/slaves/w1_therm.c
+++ b/drivers/w1/slaves/w1_therm.c
@@ -1785,7 +1785,7 @@ static ssize_t alarms_store(struct device *device,
 	u8 new_config_register[3];	/* array of data to be written */
 	int temp, ret;
 	char *token = NULL;
-	s8 tl, th, tt;	/* 1 byte per value + temp ring order */
+	s8 tl, th;	/* 1 byte per value + temp ring order */
 	char *p_args, *orig;
 
 	p_args = orig = kmalloc(size, GFP_KERNEL);
@@ -1837,7 +1837,7 @@ static ssize_t alarms_store(struct device *device,
 
 	/* Reorder if required th and tl */
 	if (tl > th) {
-		tt = tl; tl = th; th = tt;
+		swap(tl, th);
 	}
 
 	/*
-- 
2.30.2


^ permalink raw reply related	[flat|nested] 6+ messages in thread
* [PATCH v2] w1: w1_therm: use swap() to make code cleaner
@ 2021-12-20  7:48 davidcomponentone
  2021-12-20  8:08 ` Greg KH
  0 siblings, 1 reply; 6+ messages in thread
From: davidcomponentone @ 2021-12-20  7:48 UTC (permalink / raw)
  To: zbr
  Cc: davidcomponentone, gregkh, yangyingliang, yang.guang5,
	dan.carpenter, unixbhaskar, ivan.zaentsev, linux-kernel,
	Zeal Robot

From: Yang Guang <yang.guang5@zte.com.cn>

Use the macro 'swap()' defined in 'include/linux/minmax.h' to avoid
opencoding it.

Changes from v1->v2:
- Delete the curly {} braces.

Reported-by: Zeal Robot <zealci@zte.com.cn>
Signed-off-by: David Yang <davidcomponentone@gmail.com>
Signed-off-by: Yang Guang <yang.guang5@zte.com.cn>
---
 drivers/w1/slaves/w1_therm.c | 7 +++----
 1 file changed, 3 insertions(+), 4 deletions(-)

diff --git a/drivers/w1/slaves/w1_therm.c b/drivers/w1/slaves/w1_therm.c
index ca70c5f03206..565578002d79 100644
--- a/drivers/w1/slaves/w1_therm.c
+++ b/drivers/w1/slaves/w1_therm.c
@@ -1785,7 +1785,7 @@ static ssize_t alarms_store(struct device *device,
 	u8 new_config_register[3];	/* array of data to be written */
 	int temp, ret;
 	char *token = NULL;
-	s8 tl, th, tt;	/* 1 byte per value + temp ring order */
+	s8 tl, th;	/* 1 byte per value + temp ring order */
 	char *p_args, *orig;
 
 	p_args = orig = kmalloc(size, GFP_KERNEL);
@@ -1836,9 +1836,8 @@ static ssize_t alarms_store(struct device *device,
 	th = int_to_short(temp);
 
 	/* Reorder if required th and tl */
-	if (tl > th) {
-		tt = tl; tl = th; th = tt;
-	}
+	if (tl > th)
+		swap(tl, th);
 
 	/*
 	 * Read the scratchpad to change only the required bits
-- 
2.30.2


^ permalink raw reply related	[flat|nested] 6+ messages in thread

end of thread, other threads:[~2021-12-20  8:08 UTC | newest]

Thread overview: 6+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2021-11-04  1:11 [PATCH] w1: w1_therm: use swap() to make code cleaner davidcomponentone
2021-11-04 11:09 ` Dan Carpenter
2021-11-05  7:32   ` [PATCH v2] " davidcomponentone
2021-11-05  7:37     ` Greg KH
2021-12-20  7:48 davidcomponentone
2021-12-20  8:08 ` Greg KH

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).