linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* [PATCH] i2c: mux: demux-pinctrl: use struct_size() in devm_kzalloc()
@ 2019-01-04 17:43 Gustavo A. R. Silva
  2019-01-04 18:06 ` Wolfram Sang
  0 siblings, 1 reply; 4+ messages in thread
From: Gustavo A. R. Silva @ 2019-01-04 17:43 UTC (permalink / raw)
  To: Wolfram Sang, Peter Rosin; +Cc: linux-i2c, linux-kernel, Gustavo A. R. Silva

One of the more common cases of allocation size calculations is finding
the size of a structure that has a zero-sized array at the end, along
with memory for some number of elements for that array. For example:

struct foo {
    int stuff;
    void *entry[];
};

instance = devm_kzalloc(dev, sizeof(struct foo) + sizeof(void *) * count, GFP_KERNEL);

Instead of leaving these open-coded and prone to type mistakes, we can
now use the new struct_size() helper:

instance = devm_kzalloc(dev, struct_size(instance, entry, count), GFP_KERNEL);

This code was detected with the help of Coccinelle.

Signed-off-by: Gustavo A. R. Silva <gustavo@embeddedor.com>
---
 drivers/i2c/muxes/i2c-demux-pinctrl.c | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/drivers/i2c/muxes/i2c-demux-pinctrl.c b/drivers/i2c/muxes/i2c-demux-pinctrl.c
index 035032e20327..012b45e447c3 100644
--- a/drivers/i2c/muxes/i2c-demux-pinctrl.c
+++ b/drivers/i2c/muxes/i2c-demux-pinctrl.c
@@ -219,8 +219,8 @@ static int i2c_demux_pinctrl_probe(struct platform_device *pdev)
 		return -EINVAL;
 	}
 
-	priv = devm_kzalloc(&pdev->dev, sizeof(*priv)
-			   + num_chan * sizeof(struct i2c_demux_pinctrl_chan), GFP_KERNEL);
+	priv = devm_kzalloc(&pdev->dev, struct_size(priv, chan, num_chan),
+			    GFP_KERNEL);
 
 	props = devm_kcalloc(&pdev->dev, num_chan, sizeof(*props), GFP_KERNEL);
 
-- 
2.20.1


^ permalink raw reply related	[flat|nested] 4+ messages in thread

* Re: [PATCH] i2c: mux: demux-pinctrl: use struct_size() in devm_kzalloc()
  2019-01-04 17:43 [PATCH] i2c: mux: demux-pinctrl: use struct_size() in devm_kzalloc() Gustavo A. R. Silva
@ 2019-01-04 18:06 ` Wolfram Sang
  2019-04-21 18:15   ` Peter Rosin
  0 siblings, 1 reply; 4+ messages in thread
From: Wolfram Sang @ 2019-01-04 18:06 UTC (permalink / raw)
  To: Gustavo A. R. Silva; +Cc: Wolfram Sang, Peter Rosin, linux-i2c, linux-kernel

[-- Attachment #1: Type: text/plain, Size: 433 bytes --]


> Instead of leaving these open-coded and prone to type mistakes, we can
> now use the new struct_size() helper:

I am okay with this patch in general. However, I think the name of the
helper 'struct_size' is a bit unfortunate. I really wondered on the
first read why it needs 3 arguments to find out a struct size. I only
understood on the second read. I think 'trailing_array_struct_size'
would be way more clearer what it does.


[-- Attachment #2: signature.asc --]
[-- Type: application/pgp-signature, Size: 833 bytes --]

^ permalink raw reply	[flat|nested] 4+ messages in thread

* Re: [PATCH] i2c: mux: demux-pinctrl: use struct_size() in devm_kzalloc()
  2019-01-04 18:06 ` Wolfram Sang
@ 2019-04-21 18:15   ` Peter Rosin
  2019-04-22  7:20     ` Wolfram Sang
  0 siblings, 1 reply; 4+ messages in thread
From: Peter Rosin @ 2019-04-21 18:15 UTC (permalink / raw)
  To: Wolfram Sang, Gustavo A. R. Silva; +Cc: Wolfram Sang, linux-i2c, linux-kernel

On 2019-01-04 19:06, Wolfram Sang wrote:
> 
>> Instead of leaving these open-coded and prone to type mistakes, we can
>> now use the new struct_size() helper:
> 
> I am okay with this patch in general. However, I think the name of the
> helper 'struct_size' is a bit unfortunate. I really wondered on the
> first read why it needs 3 arguments to find out a struct size. I only
> understood on the second read. I think 'trailing_array_struct_size'
> would be way more clearer what it does.

I read that as an Acked-by... :-)

Cheers,
Peter


^ permalink raw reply	[flat|nested] 4+ messages in thread

* Re: [PATCH] i2c: mux: demux-pinctrl: use struct_size() in devm_kzalloc()
  2019-04-21 18:15   ` Peter Rosin
@ 2019-04-22  7:20     ` Wolfram Sang
  0 siblings, 0 replies; 4+ messages in thread
From: Wolfram Sang @ 2019-04-22  7:20 UTC (permalink / raw)
  To: Peter Rosin; +Cc: Gustavo A. R. Silva, Wolfram Sang, linux-i2c, linux-kernel

[-- Attachment #1: Type: text/plain, Size: 656 bytes --]

On Sun, Apr 21, 2019 at 06:15:21PM +0000, Peter Rosin wrote:
> On 2019-01-04 19:06, Wolfram Sang wrote:
> > 
> >> Instead of leaving these open-coded and prone to type mistakes, we can
> >> now use the new struct_size() helper:
> > 
> > I am okay with this patch in general. However, I think the name of the
> > helper 'struct_size' is a bit unfortunate. I really wondered on the
> > first read why it needs 3 arguments to find out a struct size. I only
> > understood on the second read. I think 'trailing_array_struct_size'
> > would be way more clearer what it does.
> 
> I read that as an Acked-by... :-)

For this patch, yes. Thanks!


[-- Attachment #2: signature.asc --]
[-- Type: application/pgp-signature, Size: 833 bytes --]

^ permalink raw reply	[flat|nested] 4+ messages in thread

end of thread, other threads:[~2019-04-22  7:20 UTC | newest]

Thread overview: 4+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2019-01-04 17:43 [PATCH] i2c: mux: demux-pinctrl: use struct_size() in devm_kzalloc() Gustavo A. R. Silva
2019-01-04 18:06 ` Wolfram Sang
2019-04-21 18:15   ` Peter Rosin
2019-04-22  7:20     ` Wolfram Sang

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).