linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Alexei Starovoitov <ast@fb.com>
To: Roman Gushchin <guro@fb.com>, <netdev@vger.kernel.org>
Cc: Tejun Heo <tj@kernel.org>, Alexei Starovoitov <ast@kernel.org>,
	Daniel Borkmann <daniel@iogearbox.net>,
	<linux-kernel@vger.kernel.org>, <kernel-team@fb.com>
Subject: Re: [PATCH v2 net-next 3/5] bpf, cgroup: implement eBPF-based device controller for cgroup v2
Date: Thu, 2 Nov 2017 08:11:07 -0700	[thread overview]
Message-ID: <f7b8f70d-481a-673d-8d52-a84b97b0c492@fb.com> (raw)
In-Reply-To: <20171102145440.12986-4-guro@fb.com>

On 11/2/17 7:54 AM, Roman Gushchin wrote:
> +#define DEV_BPF_ACC_MKNOD	(1ULL << 0)
> +#define DEV_BPF_ACC_READ	(1ULL << 1)
> +#define DEV_BPF_ACC_WRITE	(1ULL << 2)
> +
> +#define DEV_BPF_DEV_BLOCK	(1ULL << 0)
> +#define DEV_BPF_DEV_CHAR	(1ULL << 1)
> +

all macros in bpf.h start with BPF_
To be consistent with the rest can you rename above to BPF_DEVCG_.. ?

  reply	other threads:[~2017-11-02 15:11 UTC|newest]

Thread overview: 8+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2017-11-02 14:54 [PATCH v2 net-next 0/5] eBPF-based device cgroup controller Roman Gushchin
2017-11-02 14:54 ` [PATCH v2 net-next 1/5] device_cgroup: add DEVCG_ prefix to ACC_* and DEV_* constants Roman Gushchin
2017-11-02 14:54 ` [PATCH v2 net-next 2/5] device_cgroup: prepare code for bpf-based device controller Roman Gushchin
2017-11-02 14:54 ` [PATCH v2 net-next 3/5] bpf, cgroup: implement eBPF-based device controller for cgroup v2 Roman Gushchin
2017-11-02 15:11   ` Alexei Starovoitov [this message]
2017-11-02 16:51     ` Roman Gushchin
2017-11-02 14:54 ` [PATCH v2 net-next 4/5] bpf: move cgroup_helpers from samples/bpf/ to tools/testing/selftesting/bpf/ Roman Gushchin
2017-11-02 14:54 ` [PATCH v2 net-next 5/5] selftests/bpf: add a test for device cgroup controller Roman Gushchin

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=f7b8f70d-481a-673d-8d52-a84b97b0c492@fb.com \
    --to=ast@fb.com \
    --cc=ast@kernel.org \
    --cc=daniel@iogearbox.net \
    --cc=guro@fb.com \
    --cc=kernel-team@fb.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=netdev@vger.kernel.org \
    --cc=tj@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).