linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Takashi Iwai <tiwai@suse.de>
To: Muhammad Usama Anjum <musamaanjum@gmail.com>
Cc: Jaroslav Kysela <perex@perex.cz>, Takashi Iwai <tiwai@suse.com>,
	alsa-devel@alsa-project.org, linux-kernel@vger.kernel.org,
	kernel-janitors@vger.kernel.org, colin.king@canonical.com,
	dan.carpenter@oracle.com
Subject: Re: [PATCH] ALSA: usb-audio: Don't store returned value and check for errors
Date: Fri, 26 Mar 2021 09:00:37 +0100	[thread overview]
Message-ID: <s5hpmzml4yi.wl-tiwai@suse.de> (raw)
In-Reply-To: <20210325083641.GA644957@LEGION>

On Thu, 25 Mar 2021 09:36:41 +0100,
Muhammad Usama Anjum wrote:
> 
> The returned value by create_autodetect_quirk isn't being used other
> than in the success check on next line. Remove the return value
> assignement. Check for error values instead of success check.
> 
> Signed-off-by: Muhammad Usama Anjum <musamaanjum@gmail.com>
> ---
>  sound/usb/quirks.c | 6 +++---
>  1 file changed, 3 insertions(+), 3 deletions(-)
> 
> diff --git a/sound/usb/quirks.c b/sound/usb/quirks.c
> index 9e5e37eff10e..5ce5f4ecb9d0 100644
> --- a/sound/usb/quirks.c
> +++ b/sound/usb/quirks.c
> @@ -425,9 +425,9 @@ static int create_autodetect_quirks(struct snd_usb_audio *chip,
>  							USB_CLASS_VENDOR_SPEC)
>  			continue;
>  
> -		err = create_autodetect_quirk(chip, iface, driver);
> -		if (err >= 0)
> -			usb_driver_claim_interface(driver, iface, (void *)-1L);
> +		if (create_autodetect_quirk(chip, iface, driver) < 0)
> +			continue;
> +		usb_driver_claim_interface(driver, iface, (void *)-1L);

Hm, basically this change is only for readability (the code
optimization makes almost no sense), and the readability itself isn't
improved significantly by this change, either.

That is, I'm fine to take this, but OTOH, I see no compelling reason
to do so...


thanks,

Takashi

      reply	other threads:[~2021-03-26  8:01 UTC|newest]

Thread overview: 2+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2021-03-25  8:36 [PATCH] ALSA: usb-audio: Don't store returned value and check for errors Muhammad Usama Anjum
2021-03-26  8:00 ` Takashi Iwai [this message]

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=s5hpmzml4yi.wl-tiwai@suse.de \
    --to=tiwai@suse.de \
    --cc=alsa-devel@alsa-project.org \
    --cc=colin.king@canonical.com \
    --cc=dan.carpenter@oracle.com \
    --cc=kernel-janitors@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=musamaanjum@gmail.com \
    --cc=perex@perex.cz \
    --cc=tiwai@suse.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).