netdev.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* [PATCH] net: fsl/fman: rename IF_MODE_XGMII to IF_MODE_10G
@ 2020-01-22 14:15 Madalin Bucur
  2020-01-23 20:19 ` David Miller
  0 siblings, 1 reply; 2+ messages in thread
From: Madalin Bucur @ 2020-01-22 14:15 UTC (permalink / raw)
  To: davem; +Cc: netdev, Madalin Bucur

As the only 10G PHY interface type defined at the moment the code
was developed was XGMII, although the PHY interface mode used was
not XGMII, XGMII was used in the code to denote 10G. This patch
renames the 10G interface mode to remove the ambiguity.

Signed-off-by: Madalin Bucur <madalin.bucur@oss.nxp.com>
---
 drivers/net/ethernet/freescale/fman/fman_memac.c | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/drivers/net/ethernet/freescale/fman/fman_memac.c b/drivers/net/ethernet/freescale/fman/fman_memac.c
index 41c6fa200e74..e1901874c19f 100644
--- a/drivers/net/ethernet/freescale/fman/fman_memac.c
+++ b/drivers/net/ethernet/freescale/fman/fman_memac.c
@@ -110,7 +110,7 @@ do {									\
 /* Interface Mode Register (IF_MODE) */
 
 #define IF_MODE_MASK		0x00000003 /* 30-31 Mask on i/f mode bits */
-#define IF_MODE_XGMII		0x00000000 /* 30-31 XGMII (10G) interface */
+#define IF_MODE_10G		0x00000000 /* 30-31 10G interface */
 #define IF_MODE_GMII		0x00000002 /* 30-31 GMII (1G) interface */
 #define IF_MODE_RGMII		0x00000004
 #define IF_MODE_RGMII_AUTO	0x00008000
@@ -440,7 +440,7 @@ static int init(struct memac_regs __iomem *regs, struct memac_cfg *cfg,
 	tmp = 0;
 	switch (phy_if) {
 	case PHY_INTERFACE_MODE_XGMII:
-		tmp |= IF_MODE_XGMII;
+		tmp |= IF_MODE_10G;
 		break;
 	default:
 		tmp |= IF_MODE_GMII;
-- 
2.1.0


^ permalink raw reply related	[flat|nested] 2+ messages in thread

* Re: [PATCH] net: fsl/fman: rename IF_MODE_XGMII to IF_MODE_10G
  2020-01-22 14:15 [PATCH] net: fsl/fman: rename IF_MODE_XGMII to IF_MODE_10G Madalin Bucur
@ 2020-01-23 20:19 ` David Miller
  0 siblings, 0 replies; 2+ messages in thread
From: David Miller @ 2020-01-23 20:19 UTC (permalink / raw)
  To: madalin.bucur; +Cc: netdev

From: Madalin Bucur <madalin.bucur@oss.nxp.com>
Date: Wed, 22 Jan 2020 16:15:14 +0200

> As the only 10G PHY interface type defined at the moment the code
> was developed was XGMII, although the PHY interface mode used was
> not XGMII, XGMII was used in the code to denote 10G. This patch
> renames the 10G interface mode to remove the ambiguity.
> 
> Signed-off-by: Madalin Bucur <madalin.bucur@oss.nxp.com>

Applied, thanks.

^ permalink raw reply	[flat|nested] 2+ messages in thread

end of thread, other threads:[~2020-01-23 20:19 UTC | newest]

Thread overview: 2+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2020-01-22 14:15 [PATCH] net: fsl/fman: rename IF_MODE_XGMII to IF_MODE_10G Madalin Bucur
2020-01-23 20:19 ` David Miller

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).