netdev.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* [PATCH net-next] tcp: tcp_v4_err() icmp skb is named icmp_skb
@ 2020-05-26  3:15 Eric Dumazet
  2020-05-26 22:13 ` David Miller
  0 siblings, 1 reply; 2+ messages in thread
From: Eric Dumazet @ 2020-05-26  3:15 UTC (permalink / raw)
  To: David S . Miller
  Cc: netdev, Eric Dumazet, Eric Dumazet, Maciej Żenczykowski

I missed the fact that tcp_v4_err() differs from tcp_v6_err().

After commit 4d1a2d9ec1c1 ("Rename skb to icmp_skb in tcp_v4_err()")
the skb argument has been renamed to icmp_skb only in one function.

I will in a future patch reconciliate these functions to avoid
this kind of confusion.

Fixes: 45af29ca761c ("tcp: allow traceroute -Mtcp for unpriv users")
Signed-off-by: Eric Dumazet <edumazet@google.com>
---
 net/ipv4/tcp_ipv4.c | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/net/ipv4/tcp_ipv4.c b/net/ipv4/tcp_ipv4.c
index 900c6d154cbcf04fb09d71f1445d0723bcf3c409..6789671f0f5a02aa760e12d7b4282b620b4e928f 100644
--- a/net/ipv4/tcp_ipv4.c
+++ b/net/ipv4/tcp_ipv4.c
@@ -573,7 +573,7 @@ int tcp_v4_err(struct sk_buff *icmp_skb, u32 info)
 		if (fastopen && !fastopen->sk)
 			break;
 
-		ip_icmp_error(sk, skb, err, th->dest, info, (u8 *)th);
+		ip_icmp_error(sk, icmp_skb, err, th->dest, info, (u8 *)th);
 
 		if (!sock_owned_by_user(sk)) {
 			sk->sk_err = err;
-- 
2.27.0.rc0.183.gde8f92d652-goog


^ permalink raw reply related	[flat|nested] 2+ messages in thread

* Re: [PATCH net-next] tcp: tcp_v4_err() icmp skb is named icmp_skb
  2020-05-26  3:15 [PATCH net-next] tcp: tcp_v4_err() icmp skb is named icmp_skb Eric Dumazet
@ 2020-05-26 22:13 ` David Miller
  0 siblings, 0 replies; 2+ messages in thread
From: David Miller @ 2020-05-26 22:13 UTC (permalink / raw)
  To: edumazet; +Cc: netdev, eric.dumazet, maze

From: Eric Dumazet <edumazet@google.com>
Date: Mon, 25 May 2020 20:15:24 -0700

> I missed the fact that tcp_v4_err() differs from tcp_v6_err().
> 
> After commit 4d1a2d9ec1c1 ("Rename skb to icmp_skb in tcp_v4_err()")
> the skb argument has been renamed to icmp_skb only in one function.
> 
> I will in a future patch reconciliate these functions to avoid
> this kind of confusion.
> 
> Fixes: 45af29ca761c ("tcp: allow traceroute -Mtcp for unpriv users")
> Signed-off-by: Eric Dumazet <edumazet@google.com>

Applied.

^ permalink raw reply	[flat|nested] 2+ messages in thread

end of thread, other threads:[~2020-05-26 22:13 UTC | newest]

Thread overview: 2+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2020-05-26  3:15 [PATCH net-next] tcp: tcp_v4_err() icmp skb is named icmp_skb Eric Dumazet
2020-05-26 22:13 ` David Miller

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).