netdev.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* [PATCH] net: hisilicon: rename CACHE_LINE_MASK to avoid redefinition
@ 2021-07-18 20:38 Randy Dunlap
  2021-07-19 17:10 ` patchwork-bot+netdevbpf
  0 siblings, 1 reply; 2+ messages in thread
From: Randy Dunlap @ 2021-07-18 20:38 UTC (permalink / raw)
  To: netdev
  Cc: Randy Dunlap, Vineet Gupta, Jiangfeng Xiao, David S. Miller,
	Jakub Kicinski

Building on ARCH=arc causes a "redefined" warning, so rename this
driver's CACHE_LINE_MASK to avoid the warning.

../drivers/net/ethernet/hisilicon/hip04_eth.c:134: warning: "CACHE_LINE_MASK" redefined
  134 | #define CACHE_LINE_MASK   0x3F
In file included from ../include/linux/cache.h:6,
                 from ../include/linux/printk.h:9,
                 from ../include/linux/kernel.h:19,
                 from ../include/linux/list.h:9,
                 from ../include/linux/module.h:12,
                 from ../drivers/net/ethernet/hisilicon/hip04_eth.c:7:
../arch/arc/include/asm/cache.h:17: note: this is the location of the previous definition
   17 | #define CACHE_LINE_MASK  (~(L1_CACHE_BYTES - 1))

Fixes: d413779cdd93 ("net: hisilicon: Add an tx_desc to adapt HI13X1_GMAC")
Signed-off-by: Randy Dunlap <rdunlap@infradead.org>
Cc: Vineet Gupta <vgupta@synopsys.com>
Cc: Jiangfeng Xiao <xiaojiangfeng@huawei.com>
Cc: "David S. Miller" <davem@davemloft.net>
Cc: Jakub Kicinski <kuba@kernel.org>
---
 drivers/net/ethernet/hisilicon/hip04_eth.c |    6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

--- linux-next-20210716.orig/drivers/net/ethernet/hisilicon/hip04_eth.c
+++ linux-next-20210716/drivers/net/ethernet/hisilicon/hip04_eth.c
@@ -131,7 +131,7 @@
 /* buf unit size is cache_line_size, which is 64, so the shift is 6 */
 #define PPE_BUF_SIZE_SHIFT		6
 #define PPE_TX_BUF_HOLD			BIT(31)
-#define CACHE_LINE_MASK			0x3F
+#define SOC_CACHE_LINE_MASK		0x3F
 #else
 #define PPE_CFG_QOS_VMID_GRP_SHIFT	8
 #define PPE_CFG_RX_CTRL_ALIGN_SHIFT	11
@@ -531,8 +531,8 @@ hip04_mac_start_xmit(struct sk_buff *skb
 #if defined(CONFIG_HI13X1_GMAC)
 	desc->cfg = (__force u32)cpu_to_be32(TX_CLEAR_WB | TX_FINISH_CACHE_INV
 		| TX_RELEASE_TO_PPE | priv->port << TX_POOL_SHIFT);
-	desc->data_offset = (__force u32)cpu_to_be32(phys & CACHE_LINE_MASK);
-	desc->send_addr =  (__force u32)cpu_to_be32(phys & ~CACHE_LINE_MASK);
+	desc->data_offset = (__force u32)cpu_to_be32(phys & SOC_CACHE_LINE_MASK);
+	desc->send_addr =  (__force u32)cpu_to_be32(phys & ~SOC_CACHE_LINE_MASK);
 #else
 	desc->cfg = (__force u32)cpu_to_be32(TX_CLEAR_WB | TX_FINISH_CACHE_INV);
 	desc->send_addr = (__force u32)cpu_to_be32(phys);

^ permalink raw reply	[flat|nested] 2+ messages in thread

* Re: [PATCH] net: hisilicon: rename CACHE_LINE_MASK to avoid redefinition
  2021-07-18 20:38 [PATCH] net: hisilicon: rename CACHE_LINE_MASK to avoid redefinition Randy Dunlap
@ 2021-07-19 17:10 ` patchwork-bot+netdevbpf
  0 siblings, 0 replies; 2+ messages in thread
From: patchwork-bot+netdevbpf @ 2021-07-19 17:10 UTC (permalink / raw)
  To: Randy Dunlap; +Cc: netdev, vgupta, xiaojiangfeng, davem, kuba

Hello:

This patch was applied to netdev/net.git (refs/heads/master):

On Sun, 18 Jul 2021 13:38:34 -0700 you wrote:
> Building on ARCH=arc causes a "redefined" warning, so rename this
> driver's CACHE_LINE_MASK to avoid the warning.
> 
> ../drivers/net/ethernet/hisilicon/hip04_eth.c:134: warning: "CACHE_LINE_MASK" redefined
>   134 | #define CACHE_LINE_MASK   0x3F
> In file included from ../include/linux/cache.h:6,
>                  from ../include/linux/printk.h:9,
>                  from ../include/linux/kernel.h:19,
>                  from ../include/linux/list.h:9,
>                  from ../include/linux/module.h:12,
>                  from ../drivers/net/ethernet/hisilicon/hip04_eth.c:7:
> ../arch/arc/include/asm/cache.h:17: note: this is the location of the previous definition
>    17 | #define CACHE_LINE_MASK  (~(L1_CACHE_BYTES - 1))
> 
> [...]

Here is the summary with links:
  - net: hisilicon: rename CACHE_LINE_MASK to avoid redefinition
    https://git.kernel.org/netdev/net/c/b16f3299ae1a

You are awesome, thank you!
--
Deet-doot-dot, I am a bot.
https://korg.docs.kernel.org/patchwork/pwbot.html



^ permalink raw reply	[flat|nested] 2+ messages in thread

end of thread, other threads:[~2021-07-19 17:11 UTC | newest]

Thread overview: 2+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2021-07-18 20:38 [PATCH] net: hisilicon: rename CACHE_LINE_MASK to avoid redefinition Randy Dunlap
2021-07-19 17:10 ` patchwork-bot+netdevbpf

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).