netdev.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* [PATCH net-next 0/5] sfc: refactor of efx_set_channels
@ 2022-05-10  8:44 Íñigo Huguet
  2022-05-10  8:44 ` [PATCH net-next 1/5] sfc: add new helper macros to iterate channels by type Íñigo Huguet
                   ` (4 more replies)
  0 siblings, 5 replies; 11+ messages in thread
From: Íñigo Huguet @ 2022-05-10  8:44 UTC (permalink / raw)
  To: ecree.xilinx, habetsm.xilinx, ap420073
  Cc: davem, edumazet, kuba, pabeni, netdev, Íñigo Huguet

The code configuring RX, TX and XDP_TX queues in efx_set_channels was a
bit messy and difficult to follow. Some of my recent changes to add
support for sharing TX queues for XDP when not enough channels are
available contributed even more to this.

This patch series contains no functional changes, but only a refactor to
make that part of the driver's code clearer and easier to maintain.

Since these changes partially undo commit 059a47f1da93 ("net: sfc: add
missing xdp queue reinitialization"), I've specifically tested against
regression of this change.

Tested: receiving packets with iperf3 and with samples/bpf/xdp_rxq_info.
Then increased ring sizes to force their reallocation and repeated the
tests.

Íñigo Huguet (5):
  sfc: add new helper macros to iterate channels by type
  sfc: separate channel->tx_queue and efx->xdp_tx_queue mappings
  sfc: rename set_channels to set_queues and document it
  sfc: refactor efx_set_xdp_tx_queues
  sfc: move tx_channel_offset calculation to interrupts probe

 drivers/net/ethernet/sfc/ef100_netdev.c |   2 +-
 drivers/net/ethernet/sfc/efx.c          |   2 +-
 drivers/net/ethernet/sfc/efx_channels.c | 155 ++++++++++++------------
 drivers/net/ethernet/sfc/efx_channels.h |   2 +-
 drivers/net/ethernet/sfc/net_driver.h   |  21 ++++
 5 files changed, 99 insertions(+), 83 deletions(-)

-- 
2.34.1


^ permalink raw reply	[flat|nested] 11+ messages in thread

end of thread, other threads:[~2022-05-11  8:55 UTC | newest]

Thread overview: 11+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2022-05-10  8:44 [PATCH net-next 0/5] sfc: refactor of efx_set_channels Íñigo Huguet
2022-05-10  8:44 ` [PATCH net-next 1/5] sfc: add new helper macros to iterate channels by type Íñigo Huguet
2022-05-11  7:19   ` Martin Habets
2022-05-11  8:41     ` Íñigo Huguet
2022-05-10  8:44 ` [PATCH net-next 2/5] sfc: separate channel->tx_queue and efx->xdp_tx_queue mappings Íñigo Huguet
2022-05-11  7:52   ` Martin Habets
2022-05-11  8:55     ` Íñigo Huguet
2022-05-10  8:44 ` [PATCH net-next 3/5] sfc: rename set_channels to set_queues and document it Íñigo Huguet
2022-05-10  8:44 ` [PATCH net-next 4/5] sfc: refactor efx_set_xdp_tx_queues Íñigo Huguet
2022-05-10  8:44 ` [PATCH net-next 5/5] sfc: move tx_channel_offset calculation to interrupts probe Íñigo Huguet
2022-05-11  8:02   ` Martin Habets

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).