openrisc.lists.librecores.org archive mirror
 help / color / mirror / Atom feed
* [PATCH] openrisc: Use common of_get_cpu_node() instead of open-coding
@ 2023-03-27 18:28 Rob Herring
  2023-03-31 17:41 ` Stafford Horne
  0 siblings, 1 reply; 2+ messages in thread
From: Rob Herring @ 2023-03-27 18:28 UTC (permalink / raw)
  To: Jonas Bonn, Stefan Kristiansson, Stafford Horne
  Cc: linux-openrisc, linux-kernel

The common of_get_cpu_node() is equivalent to setup_find_cpu_node(), so
use it instead.

Signed-off-by: Rob Herring <robh@kernel.org>
---
 arch/openrisc/kernel/setup.c | 19 ++-----------------
 1 file changed, 2 insertions(+), 17 deletions(-)

diff --git a/arch/openrisc/kernel/setup.c b/arch/openrisc/kernel/setup.c
index 0cd04d936a7a..9cf7fb60441f 100644
--- a/arch/openrisc/kernel/setup.c
+++ b/arch/openrisc/kernel/setup.c
@@ -152,21 +152,6 @@ static void print_cpuinfo(void)
 		printk(KERN_INFO "-- custom unit(s)\n");
 }
 
-static struct device_node *setup_find_cpu_node(int cpu)
-{
-	u32 hwid;
-	struct device_node *cpun;
-
-	for_each_of_cpu_node(cpun) {
-		if (of_property_read_u32(cpun, "reg", &hwid))
-			continue;
-		if (hwid == cpu)
-			return cpun;
-	}
-
-	return NULL;
-}
-
 void __init setup_cpuinfo(void)
 {
 	struct device_node *cpu;
@@ -175,7 +160,7 @@ void __init setup_cpuinfo(void)
 	int cpu_id = smp_processor_id();
 	struct cpuinfo_or1k *cpuinfo = &cpuinfo_or1k[cpu_id];
 
-	cpu = setup_find_cpu_node(cpu_id);
+	cpu = of_get_cpu_node(cpu_id, NULL);
 	if (!cpu)
 		panic("Couldn't find CPU%d in device tree...\n", cpu_id);
 
@@ -255,7 +240,7 @@ static inline unsigned long extract_value(unsigned long reg, unsigned long mask)
 void calibrate_delay(void)
 {
 	const int *val;
-	struct device_node *cpu = setup_find_cpu_node(smp_processor_id());
+	struct device_node *cpu = of_get_cpu_node(smp_processor_id(), NULL);
 
 	val = of_get_property(cpu, "clock-frequency", NULL);
 	if (!val)
-- 
2.39.2


^ permalink raw reply related	[flat|nested] 2+ messages in thread

* Re: [PATCH] openrisc: Use common of_get_cpu_node() instead of open-coding
  2023-03-27 18:28 [PATCH] openrisc: Use common of_get_cpu_node() instead of open-coding Rob Herring
@ 2023-03-31 17:41 ` Stafford Horne
  0 siblings, 0 replies; 2+ messages in thread
From: Stafford Horne @ 2023-03-31 17:41 UTC (permalink / raw)
  To: Rob Herring; +Cc: Jonas Bonn, Stefan Kristiansson, linux-openrisc, linux-kernel

On Mon, Mar 27, 2023 at 01:28:16PM -0500, Rob Herring wrote:
> The common of_get_cpu_node() is equivalent to setup_find_cpu_node(), so
> use it instead.
> 
> Signed-off-by: Rob Herring <robh@kernel.org>

Thanks,

I will queue this.

-Stafford

^ permalink raw reply	[flat|nested] 2+ messages in thread

end of thread, other threads:[~2023-03-31 17:41 UTC | newest]

Thread overview: 2+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2023-03-27 18:28 [PATCH] openrisc: Use common of_get_cpu_node() instead of open-coding Rob Herring
2023-03-31 17:41 ` Stafford Horne

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).