QEMU-Devel Archive on lore.kernel.org
 help / color / Atom feed
From: Stefan Hajnoczi <stefanha@gmail.com>
To: Bug 1404278 <1404278@bugs.launchpad.net>
Cc: qemu-devel@nongnu.org
Subject: Re: [Qemu-devel] [Bug 1404278] [NEW] tap connections not working on windows host
Date: Fri, 2 Jan 2015 13:38:28 +0000
Message-ID: <20150102133828.GJ10823@stefanha-thinkpad.redhat.com> (raw)
In-Reply-To: <20141219153639.25009.84583.malonedeb@wampee.canonical.com>


[-- Attachment #1: Type: text/plain, Size: 1067 bytes --]

On Fri, Dec 19, 2014 at 03:36:39PM -0000, timsoft wrote:
> using latest qemu 2.2.0 64bit for windows host (installed from
> qemu-w64-setup-20141210.exe obtained from http://qemu.weilnetz.de/w64/
> ),OpenVPN 2.6.3-I601 64bit tap adapter named tap01 and calling qemu
> using the following.
> 
> qemu-system-x86_64.exe -m 512 -net nic -net tap,ifname=tap01 -hda
> "c:\\data\\images\\test.img"
> 
> where the image contains a slackware 14.0 64bit install.
> The tap is bridged with the real network adapter and the bridge is given an ip of 10.1.1.41 (which works as the ip for the windows host). The tap adapter (in network connections) shows connected when the qemu vm is running. inside the vm, the network is given an ip of 10.1.1.143 (the netmask and default gateway are the same for the virtual and real pc).
> fault.
> The vm cannot see the rest of the local network or visa-versa. This used to work in early (0.9 32bit) versions of qemu.

Please try tcpdump or Wireshark on guest and host to check whether ping
works in either direction.

Stefan

[-- Attachment #2: Type: application/pgp-signature, Size: 473 bytes --]

  parent reply index

Thread overview: 26+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2014-12-19 15:36 timsoft
2014-12-19 21:09 ` [Qemu-devel] [Bug 1404278] " timsoft
2015-01-02 13:38 ` Stefan Hajnoczi [this message]
2015-01-05 17:11 ` timsoft
2015-01-06 11:47   ` Stefan Hajnoczi
2015-01-06 21:12 ` timsoft
2015-01-07  9:06   ` Stefan Hajnoczi
2015-01-06 21:30 ` timsoft
2015-01-07 12:51   ` Stefan Hajnoczi
2015-01-07 16:09 ` timsoft
2015-03-24 11:10   ` Stefan Hajnoczi
2015-01-12  3:02 ` Tommy
2015-01-21 21:16 ` neil prideaux
2015-02-07 23:48 ` James J Myers
2018-05-22 13:33 ` Thomas Huth
2018-05-29 14:38   ` timsoft
2018-05-31  7:44 ` timsoft
2018-05-31  7:49 ` timsoft
2018-05-31 11:41 ` Thomas Huth
2018-05-31 11:42 ` Thomas Huth
2018-09-10 15:59 ` Jan Marti
2018-09-10 16:07 ` Jan Marti
2018-09-10 16:54 ` Jan Marti
2018-09-10 17:57 ` Jan Marti
2018-09-11  8:48 ` timsoft
2020-08-02 15:59 ` hakan

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20150102133828.GJ10823@stefanha-thinkpad.redhat.com \
    --to=stefanha@gmail.com \
    --cc=1404278@bugs.launchpad.net \
    --cc=qemu-devel@nongnu.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link

QEMU-Devel Archive on lore.kernel.org

Archives are clonable:
	git clone --mirror https://lore.kernel.org/qemu-devel/0 qemu-devel/git/0.git
	git clone --mirror https://lore.kernel.org/qemu-devel/1 qemu-devel/git/1.git

	# If you have public-inbox 1.1+ installed, you may
	# initialize and index your mirror using the following commands:
	public-inbox-init -V2 qemu-devel qemu-devel/ https://lore.kernel.org/qemu-devel \
		qemu-devel@nongnu.org
	public-inbox-index qemu-devel

Example config snippet for mirrors

Newsgroup available over NNTP:
	nntp://nntp.lore.kernel.org/org.nongnu.qemu-devel


AGPL code for this site: git clone https://public-inbox.org/public-inbox.git