QEMU-Devel Archive on lore.kernel.org
 help / color / Atom feed
From: timsoft <tim@tree-of-life.co.uk>
To: qemu-devel@nongnu.org
Subject: [Qemu-devel] [Bug 1404278] Re: tap connections not working on windows host
Date: Mon, 05 Jan 2015 17:11:50 -0000
Message-ID: <20150105171150.24809.83960.malone@wampee.canonical.com> (raw)
In-Reply-To: <20141219153639.25009.84583.malonedeb@wampee.canonical.com>

have used wireshark on host and nothing is coming through when I try to ping the host from the client. (bare with me as I haven't used wireshark before).
  I'm just upgrading the client to slack64 14.1 so I can get wireshark running on it. (process is a little slow, especially with no functioning network on the client). If all goes well, I'll be able to test that by tomorrow (it took about 5hours to install last time). I'll then post back here. 
If there are any specific tests or methods I could follow that would help please let me know.

-- 
You received this bug notification because you are a member of qemu-
devel-ml, which is subscribed to QEMU.
https://bugs.launchpad.net/bugs/1404278

Title:
  tap connections not working on windows host

Status in QEMU:
  New

Bug description:
  using latest qemu 2.2.0 64bit for windows host (installed from
  qemu-w64-setup-20141210.exe obtained from http://qemu.weilnetz.de/w64/
  ),OpenVPN 2.6.3-I601 64bit tap adapter named tap01 and calling qemu
  using the following.

  qemu-system-x86_64.exe -m 512 -net nic -net tap,ifname=tap01 -hda
  "c:\\data\\images\\test.img"

  where the image contains a slackware 14.0 64bit install.
  The tap is bridged with the real network adapter and the bridge is given an ip of 10.1.1.41 (which works as the ip for the windows host). The tap adapter (in network connections) shows connected when the qemu vm is running. inside the vm, the network is given an ip of 10.1.1.143 (the netmask and default gateway are the same for the virtual and real pc).
  fault.
  The vm cannot see the rest of the local network or visa-versa. This used to work in early (0.9 32bit) versions of qemu.

To manage notifications about this bug go to:
https://bugs.launchpad.net/qemu/+bug/1404278/+subscriptions

  parent reply index

Thread overview: 26+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2014-12-19 15:36 [Qemu-devel] [Bug 1404278] [NEW] " timsoft
2014-12-19 21:09 ` [Qemu-devel] [Bug 1404278] " timsoft
2015-01-02 13:38 ` [Qemu-devel] [Bug 1404278] [NEW] " Stefan Hajnoczi
2015-01-05 17:11 ` timsoft [this message]
2015-01-06 11:47   ` [Qemu-devel] [Bug 1404278] " Stefan Hajnoczi
2015-01-06 21:12 ` timsoft
2015-01-07  9:06   ` Stefan Hajnoczi
2015-01-06 21:30 ` timsoft
2015-01-07 12:51   ` Stefan Hajnoczi
2015-01-07 16:09 ` timsoft
2015-03-24 11:10   ` Stefan Hajnoczi
2015-01-12  3:02 ` Tommy
2015-01-21 21:16 ` neil prideaux
2015-02-07 23:48 ` James J Myers
2018-05-22 13:33 ` Thomas Huth
2018-05-29 14:38   ` timsoft
2018-05-31  7:44 ` timsoft
2018-05-31  7:49 ` timsoft
2018-05-31 11:41 ` Thomas Huth
2018-05-31 11:42 ` Thomas Huth
2018-09-10 15:59 ` Jan Marti
2018-09-10 16:07 ` Jan Marti
2018-09-10 16:54 ` Jan Marti
2018-09-10 17:57 ` Jan Marti
2018-09-11  8:48 ` timsoft
2020-08-02 15:59 ` hakan

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20150105171150.24809.83960.malone@wampee.canonical.com \
    --to=tim@tree-of-life.co.uk \
    --cc=1404278@bugs.launchpad.net \
    --cc=qemu-devel@nongnu.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link

QEMU-Devel Archive on lore.kernel.org

Archives are clonable:
	git clone --mirror https://lore.kernel.org/qemu-devel/0 qemu-devel/git/0.git
	git clone --mirror https://lore.kernel.org/qemu-devel/1 qemu-devel/git/1.git

	# If you have public-inbox 1.1+ installed, you may
	# initialize and index your mirror using the following commands:
	public-inbox-init -V2 qemu-devel qemu-devel/ https://lore.kernel.org/qemu-devel \
		qemu-devel@nongnu.org
	public-inbox-index qemu-devel

Example config snippet for mirrors

Newsgroup available over NNTP:
	nntp://nntp.lore.kernel.org/org.nongnu.qemu-devel


AGPL code for this site: git clone https://public-inbox.org/public-inbox.git