qemu-devel.nongnu.org archive mirror
 help / color / mirror / Atom feed
From: "Philippe Mathieu-Daudé" <f4bug@amsat.org>
To: qemu-devel@nongnu.org
Cc: "Peter Maydell" <peter.maydell@linaro.org>,
	"Philippe Mathieu-Daudé" <philmd@redhat.com>,
	"Philippe Mathieu-Daudé" <f4bug@amsat.org>,
	qemu-block@nongnu.org
Subject: [PATCH v7 08/17] hw/sd/sdcard: Call sd_addr_to_wpnum where it is used, consider zero size
Date: Tue, 30 Jun 2020 15:39:02 +0200	[thread overview]
Message-ID: <20200630133912.9428-9-f4bug@amsat.org> (raw)
In-Reply-To: <20200630133912.9428-1-f4bug@amsat.org>

Avoid setting 'sect' variable just once (its name is confuse
anyway). Directly set 'sd->wpgrps_size'. Special case when
size is zero.

Signed-off-by: Philippe Mathieu-Daudé <f4bug@amsat.org>
---
 hw/sd/sd.c | 8 +++++---
 1 file changed, 5 insertions(+), 3 deletions(-)

diff --git a/hw/sd/sd.c b/hw/sd/sd.c
index 078b0e81ee..e5adcc8055 100644
--- a/hw/sd/sd.c
+++ b/hw/sd/sd.c
@@ -556,8 +556,6 @@ static void sd_reset(DeviceState *dev)
     }
     size = sect << 9;
 
-    sect = sd_addr_to_wpnum(size) + 1;
-
     sd->size = size;
     sd->state = sd_idle_state;
     sd->rca = 0x0000;
@@ -570,7 +568,11 @@ static void sd_reset(DeviceState *dev)
 
     g_free(sd->wp_groups);
     sd->wp_switch = sd->blk ? blk_is_read_only(sd->blk) : false;
-    sd->wpgrps_size = sect;
+    if (sd->size) {
+        sd->wpgrps_size = sd_addr_to_wpnum(sd, sd->size) + 1;
+    } else {
+        sd->wpgrps_size = 1;
+    }
     sd->wp_groups = bitmap_new(sd->wpgrps_size);
     memset(sd->function_group, 0, sizeof(sd->function_group));
     sd->erase_start = 0;
-- 
2.21.3



  parent reply	other threads:[~2020-06-30 13:48 UTC|newest]

Thread overview: 49+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-06-30 13:38 [PATCH v7 00/17] hw/sd/sdcard: Fix CVE-2020-13253 & cleanups Philippe Mathieu-Daudé
2020-06-30 13:38 ` [PATCH v7 01/17] MAINTAINERS: Cc qemu-block mailing list Philippe Mathieu-Daudé
2020-07-03 13:29   ` Peter Maydell
2020-06-30 13:38 ` [PATCH v7 02/17] hw/sd/sdcard: Update coding style to make checkpatch.pl happy Philippe Mathieu-Daudé
2020-07-06 16:24   ` Alistair Francis
2020-06-30 13:38 ` [PATCH v7 03/17] hw/sd/sdcard: Move some definitions to use them earlier Philippe Mathieu-Daudé
2020-07-03 13:08   ` Peter Maydell
2020-06-30 13:38 ` [PATCH v7 04/17] hw/sd/sdcard: Use the HWBLOCK_SIZE definition Philippe Mathieu-Daudé
2020-07-03 13:11   ` Peter Maydell
2020-06-30 13:38 ` [PATCH v7 05/17] hw/sd/sdcard: Do not switch to ReceivingData if address is invalid Philippe Mathieu-Daudé
2020-07-03 13:12   ` Peter Maydell
2020-07-06 16:26   ` Alistair Francis
2020-07-07  8:30   ` Philippe Mathieu-Daudé
2020-07-07 10:24     ` Philippe Mathieu-Daudé
2020-07-07 10:34       ` Philippe Mathieu-Daudé
2020-06-30 13:39 ` [PATCH v7 06/17] hw/sd/sdcard: Restrict Class 6 commands to SCSD cards Philippe Mathieu-Daudé
2020-07-06 16:27   ` Alistair Francis
2020-06-30 13:39 ` [PATCH v7 07/17] hw/sd/sdcard: Move sd->size initialization Philippe Mathieu-Daudé
2020-07-03 13:13   ` Peter Maydell
2020-06-30 13:39 ` Philippe Mathieu-Daudé [this message]
2020-07-03 13:15   ` [PATCH v7 08/17] hw/sd/sdcard: Call sd_addr_to_wpnum where it is used, consider zero size Peter Maydell
2020-06-30 13:39 ` [PATCH v7 09/17] hw/sd/sdcard: Special case the -ENOMEDIUM error Philippe Mathieu-Daudé
2020-07-03 13:23   ` Peter Maydell
2020-07-03 15:16     ` Philippe Mathieu-Daudé
2020-07-03 23:42       ` Philippe Mathieu-Daudé
2020-07-04 22:10         ` Philippe Mathieu-Daudé
2020-07-04 22:18           ` Philippe Mathieu-Daudé
2020-07-04 22:26             ` Philippe Mathieu-Daudé
2020-07-05 17:33               ` Philippe Mathieu-Daudé
2020-07-06  5:52     ` Markus Armbruster
2020-07-06  9:15       ` Peter Maydell
2020-06-30 13:39 ` [PATCH v7 10/17] hw/sd/sdcard: Check address is in range Philippe Mathieu-Daudé
2020-07-03 13:23   ` Peter Maydell
2020-06-30 13:39 ` [PATCH v7 11/17] hw/sd/sdcard: Update the SDState documentation Philippe Mathieu-Daudé
2020-07-06 16:28   ` Alistair Francis
2020-06-30 13:39 ` [PATCH v7 12/17] hw/sd/sdcard: Simplify cmd_valid_while_locked() Philippe Mathieu-Daudé
2020-07-06 16:30   ` Alistair Francis
2020-06-30 13:39 ` [PATCH v7 13/17] hw/sd/sdcard: Constify sd_crc*()'s message argument Philippe Mathieu-Daudé
2020-07-03 13:24   ` Peter Maydell
2020-06-30 13:39 ` [PATCH v7 14/17] hw/sd/sdcard: Make iolen unsigned Philippe Mathieu-Daudé
2020-07-03 13:25   ` Peter Maydell
2020-07-06 16:32   ` Alistair Francis
2020-06-30 13:39 ` [PATCH v7 15/17] hw/sd/sdcard: Correctly display the command name in trace events Philippe Mathieu-Daudé
2020-07-03 13:28   ` Peter Maydell
2020-07-03 15:09     ` Philippe Mathieu-Daudé
2020-06-30 13:39 ` [PATCH v7 16/17] hw/sd/sdcard: Display offset in read/write_data() " Philippe Mathieu-Daudé
2020-07-06 16:33   ` Alistair Francis
2020-06-30 13:39 ` [PATCH v7 17/17] hw/sd/sdcard: Simplify realize() a bit Philippe Mathieu-Daudé
2020-07-06 16:34   ` Alistair Francis

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20200630133912.9428-9-f4bug@amsat.org \
    --to=f4bug@amsat.org \
    --cc=peter.maydell@linaro.org \
    --cc=philmd@redhat.com \
    --cc=qemu-block@nongnu.org \
    --cc=qemu-devel@nongnu.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).