qemu-devel.nongnu.org archive mirror
 help / color / mirror / Atom feed
* [PATCH] target/arm: Replace magic value by MMU_DATA_LOAD definition
@ 2021-01-27 23:28 Philippe Mathieu-Daudé
  2021-01-28 12:13 ` Peter Maydell
  0 siblings, 1 reply; 2+ messages in thread
From: Philippe Mathieu-Daudé @ 2021-01-27 23:28 UTC (permalink / raw)
  To: qemu-devel
  Cc: Peter Maydell, qemu-arm, Richard Henderson,
	Philippe Mathieu-Daudé,
	Joe Komlodi

cpu_get_phys_page_debug() uses 'DATA LOAD' MMU access type.

Signed-off-by: Philippe Mathieu-Daudé <f4bug@amsat.org>
---
 target/arm/helper.c | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/target/arm/helper.c b/target/arm/helper.c
index d2ead3fcbdb..766ca8b5c78 100644
--- a/target/arm/helper.c
+++ b/target/arm/helper.c
@@ -12409,7 +12409,7 @@ hwaddr arm_cpu_get_phys_page_attrs_debug(CPUState *cs, vaddr addr,
 
     *attrs = (MemTxAttrs) {};
 
-    ret = get_phys_addr(env, addr, 0, mmu_idx, &phys_addr,
+    ret = get_phys_addr(env, addr, MMU_DATA_LOAD, mmu_idx, &phys_addr,
                         attrs, &prot, &page_size, &fi, &cacheattrs);
 
     if (ret) {
-- 
2.26.2



^ permalink raw reply related	[flat|nested] 2+ messages in thread

* Re: [PATCH] target/arm: Replace magic value by MMU_DATA_LOAD definition
  2021-01-27 23:28 [PATCH] target/arm: Replace magic value by MMU_DATA_LOAD definition Philippe Mathieu-Daudé
@ 2021-01-28 12:13 ` Peter Maydell
  0 siblings, 0 replies; 2+ messages in thread
From: Peter Maydell @ 2021-01-28 12:13 UTC (permalink / raw)
  To: Philippe Mathieu-Daudé
  Cc: qemu-arm, Richard Henderson, QEMU Developers, Joe Komlodi

On Wed, 27 Jan 2021 at 23:28, Philippe Mathieu-Daudé <f4bug@amsat.org> wrote:
>
> cpu_get_phys_page_debug() uses 'DATA LOAD' MMU access type.
>
> Signed-off-by: Philippe Mathieu-Daudé <f4bug@amsat.org>
> ---
>  target/arm/helper.c | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)



Applied to target-arm.next, thanks.

-- PMM


^ permalink raw reply	[flat|nested] 2+ messages in thread

end of thread, other threads:[~2021-01-28 12:20 UTC | newest]

Thread overview: 2+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2021-01-27 23:28 [PATCH] target/arm: Replace magic value by MMU_DATA_LOAD definition Philippe Mathieu-Daudé
2021-01-28 12:13 ` Peter Maydell

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).