qemu-devel.nongnu.org archive mirror
 help / color / mirror / Atom feed
* [Qemu-devel] [PATCH] qapi: Make visit_next_list()'s comment less confusing
@ 2019-08-02 12:23 Markus Armbruster
  2019-08-02 13:06 ` Eric Blake
  2019-08-12 14:11 ` Markus Armbruster
  0 siblings, 2 replies; 3+ messages in thread
From: Markus Armbruster @ 2019-08-02 12:23 UTC (permalink / raw)
  To: qemu-devel

visit_next_list() returns non-null on success, null on failure.  The
comment's phrasing "until NULL return or error occurs" is needlessly
confusing.  Scratch the "or error occurs" part.

Signed-off-by: Markus Armbruster <armbru@redhat.com>
---
 include/qapi/visitor.h | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)

diff --git a/include/qapi/visitor.h b/include/qapi/visitor.h
index 5b2ed3f202..c5b23851a1 100644
--- a/include/qapi/visitor.h
+++ b/include/qapi/visitor.h
@@ -364,10 +364,10 @@ void visit_start_list(Visitor *v, const char *name, GenericList **list,
  * @tail must not be NULL; on the first call, @tail is the value of
  * *list after visit_start_list(), and on subsequent calls @tail must
  * be the previously returned value.  Should be called in a loop until
- * a NULL return or error occurs; for each non-NULL return, the caller
- * then calls the appropriate visit_type_*() for the element type of
- * the list, with that function's name parameter set to NULL and obj
- * set to the address of @tail->value.
+ * a NULL return; for each non-NULL return, the caller then calls the
+ * appropriate visit_type_*() for the element type of the list, with
+ * that function's name parameter set to NULL and obj set to the
+ * address of @tail->value.
  */
 GenericList *visit_next_list(Visitor *v, GenericList *tail, size_t size);
 
-- 
2.21.0



^ permalink raw reply related	[flat|nested] 3+ messages in thread

* Re: [Qemu-devel] [PATCH] qapi: Make visit_next_list()'s comment less confusing
  2019-08-02 12:23 [Qemu-devel] [PATCH] qapi: Make visit_next_list()'s comment less confusing Markus Armbruster
@ 2019-08-02 13:06 ` Eric Blake
  2019-08-12 14:11 ` Markus Armbruster
  1 sibling, 0 replies; 3+ messages in thread
From: Eric Blake @ 2019-08-02 13:06 UTC (permalink / raw)
  To: Markus Armbruster, qemu-devel


[-- Attachment #1.1: Type: text/plain, Size: 1676 bytes --]

On 8/2/19 7:23 AM, Markus Armbruster wrote:
> visit_next_list() returns non-null on success, null on failure.  The
> comment's phrasing "until NULL return or error occurs" is needlessly
> confusing.  Scratch the "or error occurs" part.
> 
> Signed-off-by: Markus Armbruster <armbru@redhat.com>
> ---
>  include/qapi/visitor.h | 8 ++++----
>  1 file changed, 4 insertions(+), 4 deletions(-)

Reviewed-by: Eric Blake <eblake@redhat.com>

> 
> diff --git a/include/qapi/visitor.h b/include/qapi/visitor.h
> index 5b2ed3f202..c5b23851a1 100644
> --- a/include/qapi/visitor.h
> +++ b/include/qapi/visitor.h
> @@ -364,10 +364,10 @@ void visit_start_list(Visitor *v, const char *name, GenericList **list,
>   * @tail must not be NULL; on the first call, @tail is the value of
>   * *list after visit_start_list(), and on subsequent calls @tail must
>   * be the previously returned value.  Should be called in a loop until
> - * a NULL return or error occurs; for each non-NULL return, the caller
> - * then calls the appropriate visit_type_*() for the element type of
> - * the list, with that function's name parameter set to NULL and obj
> - * set to the address of @tail->value.
> + * a NULL return; for each non-NULL return, the caller then calls the
> + * appropriate visit_type_*() for the element type of the list, with
> + * that function's name parameter set to NULL and obj set to the
> + * address of @tail->value.
>   */
>  GenericList *visit_next_list(Visitor *v, GenericList *tail, size_t size);
>  
> 

-- 
Eric Blake, Principal Software Engineer
Red Hat, Inc.           +1-919-301-3226
Virtualization:  qemu.org | libvirt.org


[-- Attachment #2: OpenPGP digital signature --]
[-- Type: application/pgp-signature, Size: 488 bytes --]

^ permalink raw reply	[flat|nested] 3+ messages in thread

* Re: [Qemu-devel] [PATCH] qapi: Make visit_next_list()'s comment less confusing
  2019-08-02 12:23 [Qemu-devel] [PATCH] qapi: Make visit_next_list()'s comment less confusing Markus Armbruster
  2019-08-02 13:06 ` Eric Blake
@ 2019-08-12 14:11 ` Markus Armbruster
  1 sibling, 0 replies; 3+ messages in thread
From: Markus Armbruster @ 2019-08-12 14:11 UTC (permalink / raw)
  To: qemu-devel

Markus Armbruster <armbru@redhat.com> writes:

> visit_next_list() returns non-null on success, null on failure.  The
> comment's phrasing "until NULL return or error occurs" is needlessly
> confusing.  Scratch the "or error occurs" part.
>
> Signed-off-by: Markus Armbruster <armbru@redhat.com>

Queued for 4.2.


^ permalink raw reply	[flat|nested] 3+ messages in thread

end of thread, other threads:[~2019-08-12 14:12 UTC | newest]

Thread overview: 3+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2019-08-02 12:23 [Qemu-devel] [PATCH] qapi: Make visit_next_list()'s comment less confusing Markus Armbruster
2019-08-02 13:06 ` Eric Blake
2019-08-12 14:11 ` Markus Armbruster

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).