qemu-devel.nongnu.org archive mirror
 help / color / mirror / Atom feed
From: Peter Maydell <peter.maydell@linaro.org>
To: Dongjiu Geng <gengdongjiu@huawei.com>
Cc: Fam Zheng <fam@euphon.net>,
	Xiao Guangrong <xiaoguangrong.eric@gmail.com>,
	kvm-devel <kvm@vger.kernel.org>,
	"Michael S. Tsirkin" <mst@redhat.com>,
	Marcelo Tosatti <mtosatti@redhat.com>,
	QEMU Developers <qemu-devel@nongnu.org>,
	Eduardo Habkost <ehabkost@redhat.com>,
	Shannon Zhao <shannon.zhaosl@gmail.com>,
	Zheng Xiang <zhengxiang9@huawei.com>,
	qemu-arm <qemu-arm@nongnu.org>, James Morse <james.morse@arm.com>,
	Shameerali Kolothum Thodi <shameerali.kolothum.thodi@huawei.com>,
	Jonathan Cameron <jonathan.cameron@huawei.com>,
	Paolo Bonzini <pbonzini@redhat.com>,
	Igor Mammedov <imammedo@redhat.com>,
	Laszlo Ersek <lersek@redhat.com>,
	Richard Henderson <rth@twiddle.net>
Subject: Re: [PATCH v24 01/10] acpi: nvdimm: change NVDIMM_UUID_LE to a common macro
Date: Fri, 21 Feb 2020 14:07:34 +0000	[thread overview]
Message-ID: <CAFEAcA_smgw3cg=jqh_xRU1N+mYB1B6qR75EP14SNgZ4aa0zxg@mail.gmail.com> (raw)
In-Reply-To: <20200217131248.28273-2-gengdongjiu@huawei.com>

On Mon, 17 Feb 2020 at 13:10, Dongjiu Geng <gengdongjiu@huawei.com> wrote:
>
> The little end UUID is used in many places, so make
> NVDIMM_UUID_LE to a common macro to convert the UUID
> to a little end array.
>
> Signed-off-by: Dongjiu Geng <gengdongjiu@huawei.com>
> Reviewed-by: Xiang Zheng <zhengxiang9@huawei.com>
> ---
>  hw/acpi/nvdimm.c    | 8 ++------
>  include/qemu/uuid.h | 5 +++++
>  2 files changed, 7 insertions(+), 6 deletions(-)
>
> diff --git a/hw/acpi/nvdimm.c b/hw/acpi/nvdimm.c
> index 9fdad6d..232b701 100644
> --- a/hw/acpi/nvdimm.c
> +++ b/hw/acpi/nvdimm.c
> @@ -27,6 +27,7 @@
>   */
>
>  #include "qemu/osdep.h"
> +#include "qemu/uuid.h"
>  #include "hw/acpi/acpi.h"
>  #include "hw/acpi/aml-build.h"
>  #include "hw/acpi/bios-linker-loader.h"
> @@ -60,17 +61,12 @@ static GSList *nvdimm_get_device_list(void)
>      return list;
>  }
>
> -#define NVDIMM_UUID_LE(a, b, c, d0, d1, d2, d3, d4, d5, d6, d7)             \
> -   { (a) & 0xff, ((a) >> 8) & 0xff, ((a) >> 16) & 0xff, ((a) >> 24) & 0xff, \
> -     (b) & 0xff, ((b) >> 8) & 0xff, (c) & 0xff, ((c) >> 8) & 0xff,          \
> -     (d0), (d1), (d2), (d3), (d4), (d5), (d6), (d7) }
> -
>  /*
>   * define Byte Addressable Persistent Memory (PM) Region according to
>   * ACPI 6.0: 5.2.25.1 System Physical Address Range Structure.
>   */
>  static const uint8_t nvdimm_nfit_spa_uuid[] =
> -      NVDIMM_UUID_LE(0x66f0d379, 0xb4f3, 0x4074, 0xac, 0x43, 0x0d, 0x33,
> +      UUID_LE(0x66f0d379, 0xb4f3, 0x4074, 0xac, 0x43, 0x0d, 0x33,
>                       0x18, 0xb7, 0x8c, 0xdb);

You need to fix up the indentation on this following line.

>
>  /*
> diff --git a/include/qemu/uuid.h b/include/qemu/uuid.h
> index 129c45f..bd38af5 100644
> --- a/include/qemu/uuid.h
> +++ b/include/qemu/uuid.h
> @@ -34,6 +34,11 @@ typedef struct {
>      };
>  } QemuUUID;
>
> +#define UUID_LE(a, b, c, d0, d1, d2, d3, d4, d5, d6, d7)             \
> +  { (a) & 0xff, ((a) >> 8) & 0xff, ((a) >> 16) & 0xff, ((a) >> 24) & 0xff, \
> +     (b) & 0xff, ((b) >> 8) & 0xff, (c) & 0xff, ((c) >> 8) & 0xff,          \
> +     (d0), (d1), (d2), (d3), (d4), (d5), (d6), (d7) }
> +

If you want to make this a macro in a visible-to-the-rest-of-QEMU
header file, can you provide a documentation comment please that
describes what the macro is for? It would also be useful to
give the arguments (which should be documented in the doc comment)
more descriptive names than a, b, c...

>  #define UUID_FMT "%02hhx%02hhx%02hhx%02hhx-" \
>                   "%02hhx%02hhx-%02hhx%02hhx-" \
>                   "%02hhx%02hhx-" \
> --
> 1.8.3.1


thanks
-- PMM


  reply	other threads:[~2020-02-21 14:08 UTC|newest]

Thread overview: 25+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-02-17 13:12 [PATCH v24 00/10] Add ARMv8 RAS virtualization support in QEMU Dongjiu Geng
2020-02-17 13:12 ` [PATCH v24 01/10] acpi: nvdimm: change NVDIMM_UUID_LE to a common macro Dongjiu Geng
2020-02-21 14:07   ` Peter Maydell [this message]
2020-02-17 13:12 ` [PATCH v24 02/10] hw/arm/virt: Introduce a RAS machine option Dongjiu Geng
2020-02-25  8:34   ` Igor Mammedov
2020-02-25  8:54     ` Peter Maydell
2020-02-25 10:53       ` Igor Mammedov
2020-02-17 13:12 ` [PATCH v24 03/10] docs: APEI GHES generation and CPER record description Dongjiu Geng
2020-02-17 13:12 ` [PATCH v24 04/10] ACPI: Build related register address fields via hardware error fw_cfg blob Dongjiu Geng
2020-02-25  8:48   ` Igor Mammedov
2020-02-25 13:57     ` Igor Mammedov
2020-02-17 13:12 ` [PATCH v24 05/10] ACPI: Build Hardware Error Source Table Dongjiu Geng
2020-02-25 13:23   ` Igor Mammedov
2020-02-17 13:12 ` [PATCH v24 06/10] ACPI: Record the Generic Error Status Block address Dongjiu Geng
2020-02-25 14:11   ` Igor Mammedov
2020-02-17 13:12 ` [PATCH v24 07/10] KVM: Move hwpoison page related functions into kvm-all.c Dongjiu Geng
2020-02-17 13:12 ` [PATCH v24 08/10] ACPI: Record Generic Error Status Block(GESB) table Dongjiu Geng
2020-02-25 16:58   ` Igor Mammedov
2020-02-17 13:12 ` [PATCH v24 09/10] target-arm: kvm64: handle SIGBUS signal from kernel or KVM Dongjiu Geng
2020-02-21 14:02   ` Peter Maydell
2020-02-17 13:12 ` [PATCH v24 10/10] MAINTAINERS: Add ACPI/HEST/GHES entries Dongjiu Geng
2020-02-21 14:09 ` [PATCH v24 00/10] Add ARMv8 RAS virtualization support in QEMU Peter Maydell
2020-02-24  8:37   ` gengdongjiu
2020-02-25 16:59     ` Igor Mammedov
2020-02-26 16:34       ` gengdongjiu

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to='CAFEAcA_smgw3cg=jqh_xRU1N+mYB1B6qR75EP14SNgZ4aa0zxg@mail.gmail.com' \
    --to=peter.maydell@linaro.org \
    --cc=ehabkost@redhat.com \
    --cc=fam@euphon.net \
    --cc=gengdongjiu@huawei.com \
    --cc=imammedo@redhat.com \
    --cc=james.morse@arm.com \
    --cc=jonathan.cameron@huawei.com \
    --cc=kvm@vger.kernel.org \
    --cc=lersek@redhat.com \
    --cc=mst@redhat.com \
    --cc=mtosatti@redhat.com \
    --cc=pbonzini@redhat.com \
    --cc=qemu-arm@nongnu.org \
    --cc=qemu-devel@nongnu.org \
    --cc=rth@twiddle.net \
    --cc=shameerali.kolothum.thodi@huawei.com \
    --cc=shannon.zhaosl@gmail.com \
    --cc=xiaoguangrong.eric@gmail.com \
    --cc=zhengxiang9@huawei.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).