QEMU-Devel Archive on lore.kernel.org
 help / color / Atom feed
* Fwd: simple qemu command not working
       [not found] <CAE_WKMwmOtR_zqUR-40Lv6Wrrm-ZBqTganHT_zF_m3tf2is7xA@mail.gmail.com>
@ 2020-05-22  8:32 ` haris iqbal
  2020-05-22 20:39   ` John Snow
  0 siblings, 1 reply; 2+ messages in thread
From: haris iqbal @ 2020-05-22  8:32 UTC (permalink / raw)
  To: QEMU Developers; +Cc: Danil Kipnis

Hi,

I am having some trouble with spinning up a VM using qemu. The
description is below. Can someone please point me in the right
direction?

--

Regards
-Haris


---------- Forwarded message ---------
From: haris iqbal <haris.phnx@gmail.com>
Date: Wed, May 20, 2020 at 5:10 PM
Subject: simple qemu command not working
To: <qemu-discuss@nongnu.org>
Cc: Danil Kipnis <danil.kipnis@cloud.ionos.com>


Hi,

I am trying to install ubuntu in one of the qcow2 images I have
created, using the below command

    sudo qemu-system-x86_64 -enable-kvm -nographic -smp 8 -m 8G -cpu
qemu64 -cdrom ubuntu-19.10-live-server-amd64.iso -boot d
ubuntu-19.10-live-server-amd64.qcow2

First it spits out a warning, and then just hangs at "Initializing gfx code...".

    qemu-system-x86_64: warning: host doesn't support requested
feature: CPUID.80000001H:ECX.svm [bit 2]
    qemu-system-x86_64: warning: host doesn't support requested
feature: CPUID.80000001H:ECX.svm [bit 2]
    qemu-system-x86_64: warning: host doesn't support requested
feature: CPUID.80000001H:ECX.svm [bit 2]
    qemu-system-x86_64: warning: host doesn't support requested
feature: CPUID.80000001H:ECX.svm [bit 2]
    qemu-system-x86_64: warning: host doesn't support requested
feature: CPUID.80000001H:ECX.svm [bit 2]
    qemu-system-x86_64: warning: host doesn't support requested
feature: CPUID.80000001H:ECX.svm [bit 2]
    qemu-system-x86_64: warning: host doesn't support requested
feature: CPUID.80000001H:ECX.svm [bit 2]
    qemu-system-x86_64: warning: host doesn't support requested
feature: CPUID.80000001H:ECX.svm [bit 2]
    SeaBIOS (version 1.13.0-1ubuntu1)


    iPXE (http://ipxe.org) 00:03.0 CA00 PCI2.10 PnP PMM+BFF8C9F0+BFECC9F0 CA00



    Booting from DVD/CD...

    ISOLINUX 6.04 20190226 ETCD Copyright (C) 1994-2015 H. Peter Anvin et al
    Loading bootlogo...

    Initializing gfx code...

I have searched a lot and got a number of solutions and possible
problems but none worked.

1) Have tried with Ubuntu 20 also, but same error.

2) VT-x not enabled.

It is enabled, `lscpu` shows

    Virtualization:                  VT-x
    Hypervisor vendor:               KVM
    Flags: .. vmx ..

3) Tried with `-cpu qemu64`. Did not work

4) used `qemu-system-i386` instead of `qemu-system-x86_64`. But that
fails with a different error

    This kernel requires an x86-64 CPU, but only detected an i686 CPU.
    Unable to boot - please use a kernel appropriate for your CPU.

5) I have asked the same question online, but no answers.
https://stackoverflow.com/questions/61864520/qemu-installating-ubuntu-through-iso-gets-stuck-shows-svm-cpu-bit-warning

6) Have tried without the -nographics option, same story.

7) I did find out that the "SVM" CPU bit corresponds to "AMD Secure
Virtual Machine", which confused me since my CPU is Haswell.

The host system on which I am running this command is an ubuntu.
I have tried this on 2 separate ubuntu machines, one running on
virtualbox as a VM with host OS windows 10.
The other also running on a virtualized hypervisor (not sure which
one), as a VM.

Can someone point out what the problem is, and what is the solution.

--

Regards
-Haris


^ permalink raw reply	[flat|nested] 2+ messages in thread

* Re: Fwd: simple qemu command not working
  2020-05-22  8:32 ` Fwd: simple qemu command not working haris iqbal
@ 2020-05-22 20:39   ` John Snow
  0 siblings, 0 replies; 2+ messages in thread
From: John Snow @ 2020-05-22 20:39 UTC (permalink / raw)
  To: haris iqbal, QEMU Developers; +Cc: Danil Kipnis



On 5/22/20 4:32 AM, haris iqbal wrote:
> Hi,
> 
> I am having some trouble with spinning up a VM using qemu. The
> description is below. Can someone please point me in the right
> direction?
> 
> --
> 
> Regards
> -Haris
> 
> 
> ---------- Forwarded message ---------
> From: haris iqbal <haris.phnx@gmail.com>
> Date: Wed, May 20, 2020 at 5:10 PM
> Subject: simple qemu command not working
> To: <qemu-discuss@nongnu.org>
> Cc: Danil Kipnis <danil.kipnis@cloud.ionos.com>
> 
> 
> Hi,
> 
> I am trying to install ubuntu in one of the qcow2 images I have
> created, using the below command
> 
>     sudo qemu-system-x86_64 -enable-kvm -nographic -smp 8 -m 8G -cpu
> qemu64 -cdrom ubuntu-19.10-live-server-amd64.iso -boot d
> ubuntu-19.10-live-server-amd64.qcow2
> 
> First it spits out a warning, and then just hangs at "Initializing gfx code...".
> 
>     qemu-system-x86_64: warning: host doesn't support requested
> feature: CPUID.80000001H:ECX.svm [bit 2]
>     qemu-system-x86_64: warning: host doesn't support requested
> feature: CPUID.80000001H:ECX.svm [bit 2]
>     qemu-system-x86_64: warning: host doesn't support requested
> feature: CPUID.80000001H:ECX.svm [bit 2]
>     qemu-system-x86_64: warning: host doesn't support requested
> feature: CPUID.80000001H:ECX.svm [bit 2]
>     qemu-system-x86_64: warning: host doesn't support requested
> feature: CPUID.80000001H:ECX.svm [bit 2]
>     qemu-system-x86_64: warning: host doesn't support requested
> feature: CPUID.80000001H:ECX.svm [bit 2]
>     qemu-system-x86_64: warning: host doesn't support requested
> feature: CPUID.80000001H:ECX.svm [bit 2]
>     qemu-system-x86_64: warning: host doesn't support requested
> feature: CPUID.80000001H:ECX.svm [bit 2]
>     SeaBIOS (version 1.13.0-1ubuntu1)
> 
> 
>     iPXE (http://ipxe.org) 00:03.0 CA00 PCI2.10 PnP PMM+BFF8C9F0+BFECC9F0 CA00
> 
> 
> 
>     Booting from DVD/CD...
> 
>     ISOLINUX 6.04 20190226 ETCD Copyright (C) 1994-2015 H. Peter Anvin et al
>     Loading bootlogo...
> 
>     Initializing gfx code...
> 
> I have searched a lot and got a number of solutions and possible
> problems but none worked.
> 
> 1) Have tried with Ubuntu 20 also, but same error.
> 
> 2) VT-x not enabled.
> 
> It is enabled, `lscpu` shows
> 
>     Virtualization:                  VT-x
>     Hypervisor vendor:               KVM
>     Flags: .. vmx ..
> 
> 3) Tried with `-cpu qemu64`. Did not work
> 
> 4) used `qemu-system-i386` instead of `qemu-system-x86_64`. But that
> fails with a different error
> 
>     This kernel requires an x86-64 CPU, but only detected an i686 CPU.
>     Unable to boot - please use a kernel appropriate for your CPU.
> 
> 5) I have asked the same question online, but no answers.
> https://stackoverflow.com/questions/61864520/qemu-installating-ubuntu-through-iso-gets-stuck-shows-svm-cpu-bit-warning
> 
> 6) Have tried without the -nographics option, same story.
> 
> 7) I did find out that the "SVM" CPU bit corresponds to "AMD Secure
> Virtual Machine", which confused me since my CPU is Haswell.
> 
> The host system on which I am running this command is an ubuntu.
> I have tried this on 2 separate ubuntu machines, one running on
> virtualbox as a VM with host OS windows 10.
> The other also running on a virtualized hypervisor (not sure which
> one), as a VM.
> 

So *both* the Ubuntu machines you've tried to run QEMU on are themselves
virtual machines?

You'll need to go all the way down to the baremetal level and enable
nested KVM if that's your goal.

For a HyperV root, I think there are similar steps you need to take to
enable KVM inside a guest.

For VirtualBox, I have no idea.



^ permalink raw reply	[flat|nested] 2+ messages in thread

end of thread, back to index

Thread overview: 2+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
     [not found] <CAE_WKMwmOtR_zqUR-40Lv6Wrrm-ZBqTganHT_zF_m3tf2is7xA@mail.gmail.com>
2020-05-22  8:32 ` Fwd: simple qemu command not working haris iqbal
2020-05-22 20:39   ` John Snow

QEMU-Devel Archive on lore.kernel.org

Archives are clonable:
	git clone --mirror https://lore.kernel.org/qemu-devel/0 qemu-devel/git/0.git
	git clone --mirror https://lore.kernel.org/qemu-devel/1 qemu-devel/git/1.git

	# If you have public-inbox 1.1+ installed, you may
	# initialize and index your mirror using the following commands:
	public-inbox-init -V2 qemu-devel qemu-devel/ https://lore.kernel.org/qemu-devel \
		qemu-devel@nongnu.org
	public-inbox-index qemu-devel

Example config snippet for mirrors

Newsgroup available over NNTP:
	nntp://nntp.lore.kernel.org/org.nongnu.qemu-devel


AGPL code for this site: git clone https://public-inbox.org/public-inbox.git