All of lore.kernel.org
 help / color / mirror / Atom feed
From: Bart Van Assche <bvanassche@acm.org>
To: "Martin K . Petersen" <martin.petersen@oracle.com>
Cc: "James E . J . Bottomley" <jejb@linux.vnet.ibm.com>,
	Jaegeuk Kim <jaegeuk@kernel.org>,
	linux-scsi@vger.kernel.org, Bart Van Assche <bvanassche@acm.org>,
	Benjamin Block <bblock@linux.ibm.com>
Subject: [PATCH v3 3/8] zfcp: Use scsi_get_sector() instead of scsi_get_lba()
Date: Thu, 13 May 2021 15:37:52 -0700	[thread overview]
Message-ID: <20210513223757.3938-4-bvanassche@acm.org> (raw)
In-Reply-To: <20210513223757.3938-1-bvanassche@acm.org>

Use scsi_get_sector() instead of scsi_get_lba() since the name of the
latter is confusing. Additionally, use lower_32_bits() instead of
open-coding it. This patch does not change any functionality.

Cc: Benjamin Block <bblock@linux.ibm.com>
Signed-off-by: Bart Van Assche <bvanassche@acm.org>
---
 drivers/s390/scsi/zfcp_fsf.c | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/drivers/s390/scsi/zfcp_fsf.c b/drivers/s390/scsi/zfcp_fsf.c
index 2e4804ef2fb9..3d9a3dc4975b 100644
--- a/drivers/s390/scsi/zfcp_fsf.c
+++ b/drivers/s390/scsi/zfcp_fsf.c
@@ -2600,7 +2600,7 @@ int zfcp_fsf_fcp_cmnd(struct scsi_cmnd *scsi_cmnd)
 
 	if (scsi_get_prot_op(scsi_cmnd) != SCSI_PROT_NORMAL) {
 		io->data_block_length = scsi_cmnd->device->sector_size;
-		io->ref_tag_value = scsi_get_lba(scsi_cmnd) & 0xFFFFFFFF;
+		io->ref_tag_value = lower_32_bits(scsi_get_sector(scsi_cmnd));
 	}
 
 	if (zfcp_fsf_set_data_dir(scsi_cmnd, &io->data_direction))

  parent reply	other threads:[~2021-05-13 22:38 UTC|newest]

Thread overview: 23+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2021-05-13 22:37 [PATCH v3 0/8] Rename scsi_get_lba() into scsi_get_sector() Bart Van Assche
2021-05-13 22:37 ` [PATCH v3 1/8] core: Introduce scsi_get_sector() Bart Van Assche
2021-05-14  1:57   ` Damien Le Moal
2021-05-14  6:20   ` Christoph Hellwig
2021-05-14 16:06     ` Bart Van Assche
2021-05-14 17:10       ` Martin K. Petersen
2021-05-13 22:37 ` [PATCH v3 2/8] iser: Use scsi_get_sector() instead of scsi_get_lba() Bart Van Assche
2021-05-14  1:57   ` Damien Le Moal
2021-05-13 22:37 ` Bart Van Assche [this message]
2021-05-14  1:58   ` [PATCH v3 3/8] zfcp: " Damien Le Moal
2021-05-17 17:23   ` Benjamin Block
2021-05-13 22:37 ` [PATCH v3 4/8] isci: " Bart Van Assche
2021-05-14  1:58   ` Damien Le Moal
2021-05-13 22:37 ` [PATCH v3 5/8] lpfc: " Bart Van Assche
2021-05-14  2:00   ` Damien Le Moal
2021-05-14  2:58     ` Bart Van Assche
2021-05-13 22:37 ` [PATCH v3 6/8] qla2xxx: " Bart Van Assche
2021-05-14  2:02   ` Damien Le Moal
2021-05-14  3:01     ` Bart Van Assche
2021-05-13 22:37 ` [PATCH v3 7/8] ufs: Fix the tracing code Bart Van Assche
2021-05-14  2:05   ` Damien Le Moal
2021-05-13 22:37 ` [PATCH v3 8/8] core: Remove scsi_get_lba() Bart Van Assche
2021-05-14  2:06   ` Damien Le Moal

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20210513223757.3938-4-bvanassche@acm.org \
    --to=bvanassche@acm.org \
    --cc=bblock@linux.ibm.com \
    --cc=jaegeuk@kernel.org \
    --cc=jejb@linux.vnet.ibm.com \
    --cc=linux-scsi@vger.kernel.org \
    --cc=martin.petersen@oracle.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.