All of lore.kernel.org
 help / color / mirror / Atom feed
From: Mike Rapoport <rppt@kernel.org>
To: Andrew Morton <akpm@linux-foundation.org>
Cc: Arnd Bergmann <arnd@arndb.de>, Dinh Nguyen <dinguyen@kernel.org>,
	Guo Ren <guoren@kernel.org>, Helge Deller <deller@gmx.de>,
	Huacai Chen <chenhuacai@kernel.org>,
	"James E.J. Bottomley" <James.Bottomley@HansenPartnership.com>,
	Matthew Wilcox <willy@infradead.org>,
	Max Filippov <jcmvbkbc@gmail.com>,
	Mike Rapoport <rppt@kernel.org>,
	Mike Rapoport <rppt@linux.ibm.com>,
	"Russell King (Oracle)" <linux@armlinux.org.uk>,
	Thomas Bogendoerfer <tsbogend@alpha.franken.de>,
	WANG Xuerui <kernel@xen0n.name>,
	linux-arch@vger.kernel.org, linux-csky@vger.kernel.org,
	linux-kernel@vger.kernel.org, linux-mips@vger.kernel.org,
	linux-mm@kvack.org, linux-parisc@vger.kernel.org,
	linux-xtensa@linux-xtensa.org, loongarch@lists.linux.dev
Subject: [PATCH v2 00/15] arch: make PxD_ORDER generically available
Date: Tue,  5 Jul 2022 18:46:53 +0300	[thread overview]
Message-ID: <20220705154708.181258-1-rppt@kernel.org> (raw)

From: Mike Rapoport <rppt@linux.ibm.com>

v2 changes:
* Drop extra blank line in arch/loongarch/kernel/asm-offsets.c (patch 12)
* Add patch 15 that renames PMD_ORDER to PMD_ENTRY_ORDER in
  arch/arm/kernel/head.S
v1: https://lore.kernel.org/all/20220703141203.147893-1-rppt@kernel.org 

v1 cover letter:

The question what does PxD_ORDER define raises from time to time and
there is still a conflict between MIPS and DAX definitions.

Some time ago Matthew Wilcox suggested to use PMD_TABLE_ORDER to define
the order of page table allocation: 

[1] https://lore.kernel.org/linux-arch/YPCJftSTUBEnq2lI@casper.infradead.org/

The parisc patch made it in, but mips didn't. 
Now mips defines from asm/include/pgtable.h were copied to loongarch which
made it worse.

Let's deal with it once and for all and rename PxD_ORDER defines to
PxD_TABLE_ORDER or just drop them when the only possible order of page
table is 0.

I think the best way to merge this via mm tree with acks from arch
maintainers.

Matthew Wilcox (Oracle) (1):
  mips: Rename PMD_ORDER to PMD_TABLE_ORDER

Mike Rapoport (14):
  csky: drop definition of PTE_ORDER
  csky: drop definition of PGD_ORDER
  mips: Rename PUD_ORDER to PUD_TABLE_ORDER
  mips: drop definitions of PTE_ORDER
  mips: Rename PGD_ORDER to PGD_TABLE_ORDER
  nios2: drop definition of PTE_ORDER
  nios2: drop definition of PGD_ORDER
  loongarch: drop definition of PTE_ORDER
  loongarch: drop definition of PMD_ORDER
  loongarch: drop definition of PUD_ORDER
  loongarch: drop definition of PGD_ORDER
  parisc: Rename PGD_ORDER to PGD_TABLE_ORDER
  xtensa: drop definition of PGD_ORDER
  ARM: head.S: rename PMD_ORDER to PMD_ENTRY_ORDER

 arch/arm/kernel/head.S               | 34 ++++++++--------
 arch/csky/include/asm/pgalloc.h      |  2 +-
 arch/csky/include/asm/pgtable.h      |  6 +--
 arch/loongarch/include/asm/pgalloc.h |  6 +--
 arch/loongarch/include/asm/pgtable.h | 27 +++++-------
 arch/loongarch/kernel/asm-offsets.c  |  6 ---
 arch/loongarch/mm/pgtable.c          |  2 +-
 arch/loongarch/mm/tlbex.S            |  6 +--
 arch/mips/include/asm/pgalloc.h      |  8 ++--
 arch/mips/include/asm/pgtable-32.h   | 19 ++++-----
 arch/mips/include/asm/pgtable-64.h   | 61 +++++++++++++---------------
 arch/mips/kernel/asm-offsets.c       |  5 ---
 arch/mips/kvm/mmu.c                  |  2 +-
 arch/mips/mm/pgtable.c               |  2 +-
 arch/mips/mm/tlbex.c                 | 14 +++----
 arch/nios2/include/asm/pgtable.h     |  7 +---
 arch/nios2/mm/init.c                 |  5 +--
 arch/nios2/mm/pgtable.c              |  2 +-
 arch/parisc/include/asm/pgalloc.h    |  6 +--
 arch/parisc/include/asm/pgtable.h    |  8 ++--
 arch/xtensa/include/asm/pgalloc.h    |  2 +-
 arch/xtensa/include/asm/pgtable.h    |  1 -
 22 files changed, 101 insertions(+), 130 deletions(-)


base-commit: 03c765b0e3b4cb5063276b086c76f7a612856a9a
-- 
2.34.1


             reply	other threads:[~2022-07-05 15:47 UTC|newest]

Thread overview: 19+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2022-07-05 15:46 Mike Rapoport [this message]
2022-07-05 15:46 ` [PATCH v2 01/15] csky: drop definition of PTE_ORDER Mike Rapoport
2022-07-05 15:46 ` [PATCH v2 02/15] csky: drop definition of PGD_ORDER Mike Rapoport
2022-07-05 15:46 ` [PATCH v2 03/15] mips: Rename PMD_ORDER to PMD_TABLE_ORDER Mike Rapoport
2022-07-05 15:46 ` [PATCH v2 04/15] mips: Rename PUD_ORDER to PUD_TABLE_ORDER Mike Rapoport
2022-07-05 15:46 ` [PATCH v2 05/15] mips: drop definitions of PTE_ORDER Mike Rapoport
2022-07-05 15:46 ` [PATCH v2 06/15] mips: Rename PGD_ORDER to PGD_TABLE_ORDER Mike Rapoport
2022-07-05 15:47 ` [PATCH v2 07/15] nios2: drop definition of PTE_ORDER Mike Rapoport
2022-07-11 22:55   ` Dinh Nguyen
2022-07-05 15:47 ` [PATCH v2 08/15] nios2: drop definition of PGD_ORDER Mike Rapoport
2022-07-11 22:55   ` Dinh Nguyen
2022-07-05 15:47 ` [PATCH v2 09/15] loongarch: drop definition of PTE_ORDER Mike Rapoport
2022-07-05 15:47 ` [PATCH v2 10/15] loongarch: drop definition of PMD_ORDER Mike Rapoport
2022-07-05 15:47 ` [PATCH v2 11/15] loongarch: drop definition of PUD_ORDER Mike Rapoport
2022-07-05 15:47 ` [PATCH v2 12/15] loongarch: drop definition of PGD_ORDER Mike Rapoport
2022-07-05 15:47 ` [PATCH v2 13/15] parisc: Rename PGD_ORDER to PGD_TABLE_ORDER Mike Rapoport
2022-07-05 15:47 ` [PATCH v2 14/15] xtensa: drop definition of PGD_ORDER Mike Rapoport
2022-07-05 16:03   ` Max Filippov
2022-07-05 15:47 ` [PATCH v2 15/15] ARM: head.S: rename PMD_ORDER to PMD_ENTRY_ORDER Mike Rapoport

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20220705154708.181258-1-rppt@kernel.org \
    --to=rppt@kernel.org \
    --cc=James.Bottomley@HansenPartnership.com \
    --cc=akpm@linux-foundation.org \
    --cc=arnd@arndb.de \
    --cc=chenhuacai@kernel.org \
    --cc=deller@gmx.de \
    --cc=dinguyen@kernel.org \
    --cc=guoren@kernel.org \
    --cc=jcmvbkbc@gmail.com \
    --cc=kernel@xen0n.name \
    --cc=linux-arch@vger.kernel.org \
    --cc=linux-csky@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-mips@vger.kernel.org \
    --cc=linux-mm@kvack.org \
    --cc=linux-parisc@vger.kernel.org \
    --cc=linux-xtensa@linux-xtensa.org \
    --cc=linux@armlinux.org.uk \
    --cc=loongarch@lists.linux.dev \
    --cc=rppt@linux.ibm.com \
    --cc=tsbogend@alpha.franken.de \
    --cc=willy@infradead.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.