All of lore.kernel.org
 help / color / mirror / Atom feed
From: Stephen Boyd <swboyd@chromium.org>
To: Markus Elfring <Markus.Elfring@web.de>,
	Masahiro Yamada <yamada.masahiro@socionext.com>,
	Michal Marek <michal.lkml@markovi.net>,
	Nicolas Palix <nicolas.palix@imag.fr>,
	cocci@systeme.lip6.fr, kernel-janitors@vger.kernel.org
Cc: Gilles Muller <Gilles.Muller@lip6.fr>,
	Julia Lawall <Julia.Lawall@lip6.fr>,
	linux-kernel@vger.kernel.org, Andrzej Hajda <a.hajda@samsung.com>,
	Andy Shevchenko <andy.shevchenko@gmail.com>,
	Bartlomiej Zolnierkiewicz <b.zolnierkie@samsung.com>,
	Greg Kroah-Hartman <gregkh@linuxfoundation.org>,
	Javier Martinez Canillas <javierm@redhat.com>,
	Marek Szyprowski <m.szyprowski@samsung.com>,
	Mark Brown <broonie@kernel.org>, Rob Herring <robh@kernel.org>,
	Russell King <linux@armlinux.org.uk>
Subject: Re: [PATCH v4 3/3] coccinelle: Add script to check for platform_get_irq() excessive prints
Date: Wed, 24 Jul 2019 11:21:54 -0700	[thread overview]
Message-ID: <5d38a1c3.1c69fb81.2b26a.b585@mx.google.com> (raw)
In-Reply-To: <c98b8f50-1adf-ea95-a91c-ec451e9fefe2@web.de>

Quoting Markus Elfring (2019-07-24 02:30:16)
> I would prefer to concentrate the usage of SmPL disjunctions on changing
> implementation details so that the specification of duplicate code
> can be avoided.
> 
> 
> > +(
> > +platform_get_irq(E, ...)
> > +|
> > +platform_get_irq_byname(E, ...)
> > +);
> 
> Function names:
> 
> +(platform_get_irq
> +|platform_get_irq_byname
> +)(E, ...);
> 
> 
> > +if ( \( ret < 0 \| ret <= 0 \) )
> 
> Comparison operators:
> 
> +if (ret \( < \| <= \) 0)
> 

Thanks. Will fold the above two in.

> 
> > +if (ret != -EPROBE_DEFER)
> 
> Is it appropriate to treat this error code check as optional
> by the shown transformation approach?
> Can this case distinction be omitted?

I don't know what you mean here. Do you want me to drop this part so
that EPROBE_DEFER checks don't get removed?


WARNING: multiple messages have this Message-ID (diff)
From: Stephen Boyd <swboyd@chromium.org>
To: Markus Elfring <Markus.Elfring@web.de>,
	Masahiro Yamada <yamada.masahiro@socionext.com>,
	Michal Marek <michal.lkml@markovi.net>,
	Nicolas Palix <nicolas.palix@imag.fr>,
	cocci@systeme.lip6.fr, kernel-janitors@vger.kernel.org
Cc: Rob Herring <robh@kernel.org>,
	Greg Kroah-Hartman <gregkh@linuxfoundation.org>,
	Bartlomiej Zolnierkiewicz <b.zolnierkie@samsung.com>,
	linux-kernel@vger.kernel.org,
	Javier Martinez Canillas <javierm@redhat.com>,
	Andrzej Hajda <a.hajda@samsung.com>,
	Andy Shevchenko <andy.shevchenko@gmail.com>,
	Mark Brown <broonie@kernel.org>,
	Russell King <linux@armlinux.org.uk>,
	Marek Szyprowski <m.szyprowski@samsung.com>
Subject: Re: [PATCH v4 3/3] coccinelle: Add script to check for platform_get_irq() excessive prints
Date: Wed, 24 Jul 2019 18:21:54 +0000	[thread overview]
Message-ID: <5d38a1c3.1c69fb81.2b26a.b585@mx.google.com> (raw)
In-Reply-To: <c98b8f50-1adf-ea95-a91c-ec451e9fefe2@web.de>

Quoting Markus Elfring (2019-07-24 02:30:16)
> I would prefer to concentrate the usage of SmPL disjunctions on changing
> implementation details so that the specification of duplicate code
> can be avoided.
> 
> 
> > +(
> > +platform_get_irq(E, ...)
> > +|
> > +platform_get_irq_byname(E, ...)
> > +);
> 
> Function names:
> 
> +(platform_get_irq
> +|platform_get_irq_byname
> +)(E, ...);
> 
> 
> > +if ( \( ret < 0 \| ret <= 0 \) )
> 
> Comparison operators:
> 
> +if (ret \( < \| <= \) 0)
> 

Thanks. Will fold the above two in.

> 
> > +if (ret != -EPROBE_DEFER)
> 
> Is it appropriate to treat this error code check as optional
> by the shown transformation approach?
> Can this case distinction be omitted?

I don't know what you mean here. Do you want me to drop this part so
that EPROBE_DEFER checks don't get removed?

WARNING: multiple messages have this Message-ID (diff)
From: Stephen Boyd <swboyd@chromium.org>
To: Markus Elfring <Markus.Elfring@web.de>,
	Masahiro Yamada <yamada.masahiro@socionext.com>,
	Michal Marek <michal.lkml@markovi.net>,
	Nicolas Palix <nicolas.palix@imag.fr>,
	cocci@systeme.lip6.fr, kernel-janitors@vger.kernel.org
Cc: Rob Herring <robh@kernel.org>,
	Greg Kroah-Hartman <gregkh@linuxfoundation.org>,
	Bartlomiej Zolnierkiewicz <b.zolnierkie@samsung.com>,
	linux-kernel@vger.kernel.org,
	Javier Martinez Canillas <javierm@redhat.com>,
	Andrzej Hajda <a.hajda@samsung.com>,
	Andy Shevchenko <andy.shevchenko@gmail.com>,
	Mark Brown <broonie@kernel.org>,
	Russell King <linux@armlinux.org.uk>,
	Marek Szyprowski <m.szyprowski@samsung.com>
Subject: Re: [Cocci] [PATCH v4 3/3] coccinelle: Add script to check for platform_get_irq() excessive prints
Date: Wed, 24 Jul 2019 11:21:54 -0700	[thread overview]
Message-ID: <5d38a1c3.1c69fb81.2b26a.b585@mx.google.com> (raw)
In-Reply-To: <c98b8f50-1adf-ea95-a91c-ec451e9fefe2@web.de>

Quoting Markus Elfring (2019-07-24 02:30:16)
> I would prefer to concentrate the usage of SmPL disjunctions on changing
> implementation details so that the specification of duplicate code
> can be avoided.
> 
> 
> > +(
> > +platform_get_irq(E, ...)
> > +|
> > +platform_get_irq_byname(E, ...)
> > +);
> 
> Function names:
> 
> +(platform_get_irq
> +|platform_get_irq_byname
> +)(E, ...);
> 
> 
> > +if ( \( ret < 0 \| ret <= 0 \) )
> 
> Comparison operators:
> 
> +if (ret \( < \| <= \) 0)
> 

Thanks. Will fold the above two in.

> 
> > +if (ret != -EPROBE_DEFER)
> 
> Is it appropriate to treat this error code check as optional
> by the shown transformation approach?
> Can this case distinction be omitted?

I don't know what you mean here. Do you want me to drop this part so
that EPROBE_DEFER checks don't get removed?

_______________________________________________
Cocci mailing list
Cocci@systeme.lip6.fr
https://systeme.lip6.fr/mailman/listinfo/cocci

  reply	other threads:[~2019-07-24 18:21 UTC|newest]

Thread overview: 40+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2019-07-23 18:16 [PATCH v4 0/3] Add error message to platform_get_irq*() Stephen Boyd
2019-07-23 18:16 ` [Cocci] " Stephen Boyd
2019-07-23 18:16 ` [PATCH v4 1/3] driver core: platform: Add an " Stephen Boyd
2019-07-24 15:00   ` Markus Elfring
2019-07-24 15:00     ` Markus Elfring
2019-07-24 18:17     ` Stephen Boyd
2019-07-24 18:17       ` Stephen Boyd
2019-07-25  5:55   ` Markus Elfring
2019-07-25  5:55     ` Markus Elfring
2019-07-23 18:16 ` [PATCH v4 2/3] treewide: Remove dev_err() usage after platform_get_irq() Stephen Boyd
2019-07-23 18:31   ` Andy Shevchenko
2019-07-23 22:23     ` Stephen Boyd
2019-07-24 11:17       ` [v4 " Markus Elfring
2019-07-24 11:17         ` [Cocci] " Markus Elfring
2019-07-24 11:17         ` Markus Elfring
2019-07-23 19:30   ` [PATCH v4 " Rob Herring
2019-07-23 22:24     ` Stephen Boyd
2019-07-24 17:08       ` Mark Brown
2019-07-24  6:35   ` Greg Kroah-Hartman
2019-07-24 17:06   ` Mark Brown
2019-07-23 18:16 ` [PATCH v4 3/3] coccinelle: Add script to check for platform_get_irq() excessive prints Stephen Boyd
2019-07-23 18:16   ` [Cocci] " Stephen Boyd
2019-07-24  9:30   ` Markus Elfring
2019-07-24  9:30     ` [Cocci] " Markus Elfring
2019-07-24  9:30     ` Markus Elfring
2019-07-24 18:21     ` Stephen Boyd [this message]
2019-07-24 18:21       ` [Cocci] " Stephen Boyd
2019-07-24 18:21       ` Stephen Boyd
2019-07-24 18:38       ` [v4 " Markus Elfring
2019-07-24 18:38         ` [Cocci] " Markus Elfring
2019-07-24 18:38         ` Markus Elfring
2019-07-24 13:18   ` [PATCH v4 " Markus Elfring
2019-07-24 13:18     ` [Cocci] " Markus Elfring
2019-07-24 13:18     ` Markus Elfring
2019-07-24 18:23     ` Stephen Boyd
2019-07-24 18:23       ` [Cocci] " Stephen Boyd
2019-07-24 18:23       ` Stephen Boyd
2019-07-24 18:45       ` [v4 " Markus Elfring
2019-07-24 18:45         ` [Cocci] " Markus Elfring
2019-07-24 18:45         ` Markus Elfring

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=5d38a1c3.1c69fb81.2b26a.b585@mx.google.com \
    --to=swboyd@chromium.org \
    --cc=Gilles.Muller@lip6.fr \
    --cc=Julia.Lawall@lip6.fr \
    --cc=Markus.Elfring@web.de \
    --cc=a.hajda@samsung.com \
    --cc=andy.shevchenko@gmail.com \
    --cc=b.zolnierkie@samsung.com \
    --cc=broonie@kernel.org \
    --cc=cocci@systeme.lip6.fr \
    --cc=gregkh@linuxfoundation.org \
    --cc=javierm@redhat.com \
    --cc=kernel-janitors@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux@armlinux.org.uk \
    --cc=m.szyprowski@samsung.com \
    --cc=michal.lkml@markovi.net \
    --cc=nicolas.palix@imag.fr \
    --cc=robh@kernel.org \
    --cc=yamada.masahiro@socionext.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.