All of lore.kernel.org
 help / color / mirror / Atom feed
From: Markus Elfring <Markus.Elfring@web.de>
To: Julia Lawall <julia.lawall@lip6.fr>, Wen Yang <wen.yang99@zte.com.cn>
Cc: Gilles Muller <Gilles.Muller@lip6.fr>,
	Nicolas Palix <nicolas.palix@imag.fr>,
	Michal Marek <michal.lkml@markovi.net>,
	Yi Wang <wang.yi59@zte.com.cn>,
	Masahiro Yamada <yamada.masahiro@socionext.com>,
	Wen Yang <yellowriver2010@hotmail.com>,
	Cheng Shengyu <cheng.shengyu@zte.com.cn>,
	cocci@systeme.lip6.fr, linux-kernel@vger.kernel.org,
	kernel-janitors@vger.kernel.org
Subject: Re: [v5] Coccinelle: semantic code search for missing put_device()
Date: Sat, 16 Feb 2019 09:44:04 +0100	[thread overview]
Message-ID: <6c114d10-0d17-6f43-4c33-0f57c230306f@web.de> (raw)
In-Reply-To: <alpine.DEB.2.21.1902160931540.3212@hadrien>

>> Thus I do not see a need (or requirement) for a duplicate search attempt.
>
> Why don't you actually try it and see what the difference is rather than
> repeatedly giving false information?

I suggest to clarify this software development disagreement by the following
SmPL code.


 ... when != put_stuff(my_pointer)
     when != if (...) { ... put_stuff(my_pointer) ... }


Is this a specification for a bit of duplicate code?


Or:
Do you insist to find such a function call only within a branch of an if statement?

Regards,
Markus

WARNING: multiple messages have this Message-ID (diff)
From: Markus Elfring <Markus.Elfring@web.de>
To: Julia Lawall <julia.lawall@lip6.fr>, Wen Yang <wen.yang99@zte.com.cn>
Cc: Yi Wang <wang.yi59@zte.com.cn>,
	kernel-janitors@vger.kernel.org,
	Michal Marek <michal.lkml@markovi.net>,
	Wen Yang <yellowriver2010@hotmail.com>,
	Nicolas Palix <nicolas.palix@imag.fr>,
	linux-kernel@vger.kernel.org,
	Cheng Shengyu <cheng.shengyu@zte.com.cn>,
	cocci@systeme.lip6.fr
Subject: Re: [v5] Coccinelle: semantic code search for missing put_device()
Date: Sat, 16 Feb 2019 08:44:04 +0000	[thread overview]
Message-ID: <6c114d10-0d17-6f43-4c33-0f57c230306f@web.de> (raw)
In-Reply-To: <alpine.DEB.2.21.1902160931540.3212@hadrien>

>> Thus I do not see a need (or requirement) for a duplicate search attempt.
>
> Why don't you actually try it and see what the difference is rather than
> repeatedly giving false information?

I suggest to clarify this software development disagreement by the following
SmPL code.


 ... when != put_stuff(my_pointer)
     when != if (...) { ... put_stuff(my_pointer) ... }


Is this a specification for a bit of duplicate code?


Or:
Do you insist to find such a function call only within a branch of an if statement?

Regards,
Markus

WARNING: multiple messages have this Message-ID (diff)
From: Markus Elfring <Markus.Elfring@web.de>
To: Julia Lawall <julia.lawall@lip6.fr>, Wen Yang <wen.yang99@zte.com.cn>
Cc: Yi Wang <wang.yi59@zte.com.cn>,
	kernel-janitors@vger.kernel.org,
	Michal Marek <michal.lkml@markovi.net>,
	Wen Yang <yellowriver2010@hotmail.com>,
	Nicolas Palix <nicolas.palix@imag.fr>,
	linux-kernel@vger.kernel.org,
	Cheng Shengyu <cheng.shengyu@zte.com.cn>,
	cocci@systeme.lip6.fr
Subject: Re: [Cocci] [v5] Coccinelle: semantic code search for missing put_device()
Date: Sat, 16 Feb 2019 09:44:04 +0100	[thread overview]
Message-ID: <6c114d10-0d17-6f43-4c33-0f57c230306f@web.de> (raw)
In-Reply-To: <alpine.DEB.2.21.1902160931540.3212@hadrien>

>> Thus I do not see a need (or requirement) for a duplicate search attempt.
>
> Why don't you actually try it and see what the difference is rather than
> repeatedly giving false information?

I suggest to clarify this software development disagreement by the following
SmPL code.


 ... when != put_stuff(my_pointer)
     when != if (...) { ... put_stuff(my_pointer) ... }


Is this a specification for a bit of duplicate code?


Or:
Do you insist to find such a function call only within a branch of an if statement?

Regards,
Markus
_______________________________________________
Cocci mailing list
Cocci@systeme.lip6.fr
https://systeme.lip6.fr/mailman/listinfo/cocci

  reply	other threads:[~2019-02-16  8:44 UTC|newest]

Thread overview: 36+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
     [not found] <201902161529041506841@zte.com.cn>
2019-02-16  8:09 ` [v5] Coccinelle: semantic code search for missing put_device() Julia Lawall
2019-02-16  8:09   ` [Cocci] " Julia Lawall
2019-02-16  8:09   ` Julia Lawall
2019-02-16  8:29   ` Markus Elfring
2019-02-16  8:29     ` [Cocci] " Markus Elfring
2019-02-16  8:29     ` Markus Elfring
2019-02-16  8:32     ` Julia Lawall
2019-02-16  8:32       ` [Cocci] " Julia Lawall
2019-02-16  8:32       ` Julia Lawall
2019-02-16  8:44       ` Markus Elfring [this message]
2019-02-16  8:44         ` [Cocci] " Markus Elfring
2019-02-16  8:44         ` Markus Elfring
2019-02-15  7:55 [PATCH v5] coccinelle: " Wen Yang
2019-02-15 12:52 ` [PATCH v5] Coccinelle: " Markus Elfring
2019-02-15 13:02   ` Julia Lawall
2019-02-15 13:15     ` [v5] " Markus Elfring
2019-02-15 13:15       ` Markus Elfring
2019-02-15 13:15     ` Markus Elfring
2019-02-15 13:15       ` Markus Elfring
2019-02-15 13:24       ` Julia Lawall
2019-02-15 13:24         ` Julia Lawall
2019-02-15 13:54         ` Markus Elfring
2019-02-15 13:54           ` Markus Elfring
2019-03-17  3:54 ` [PATCH v5] coccinelle: " Masahiro Yamada
2019-03-17  9:05   ` [v5] " Markus Elfring
2019-03-17  9:05     ` Markus Elfring
2019-03-23 16:17   ` Markus Elfring
2019-03-23 16:17     ` Markus Elfring
2019-03-26  6:54     ` Masahiro Yamada
2019-03-26  6:54       ` Masahiro Yamada
2019-03-26  7:19       ` Julia Lawall
2019-03-26  7:19         ` Julia Lawall
2019-03-26  9:14         ` Markus Elfring
2019-03-26  9:14           ` Markus Elfring
2019-03-26  9:04       ` Markus Elfring
2019-03-26  9:04         ` Markus Elfring
2019-03-26  9:52         ` Masahiro Yamada
2019-03-26  9:52           ` Masahiro Yamada
2019-03-26  9:58           ` Julia Lawall
2019-03-26  9:58             ` Julia Lawall

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=6c114d10-0d17-6f43-4c33-0f57c230306f@web.de \
    --to=markus.elfring@web.de \
    --cc=Gilles.Muller@lip6.fr \
    --cc=cheng.shengyu@zte.com.cn \
    --cc=cocci@systeme.lip6.fr \
    --cc=julia.lawall@lip6.fr \
    --cc=kernel-janitors@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=michal.lkml@markovi.net \
    --cc=nicolas.palix@imag.fr \
    --cc=wang.yi59@zte.com.cn \
    --cc=wen.yang99@zte.com.cn \
    --cc=yamada.masahiro@socionext.com \
    --cc=yellowriver2010@hotmail.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.