RadioTap Archive on lore.kernel.org
 help / color / Atom feed
* Help needed with malformed radiotap headers
@ 2012-06-18 16:03 anand
  0 siblings, 0 replies; only message in thread
From: anand @ 2012-06-18 16:03 UTC (permalink / raw)
  To: radiotap-sUITvd46vNxg9hUCZPvPmw

[-- Attachment #1.1: Type: text/plain, Size: 995 bytes --]

Hi,
        I have set up an experiment to measure Wireless communication
parameters using two laptops. I am injecting custom packets into the
network on a monitor interface using one laptop programmed as a
transmitter(Macbook Pro using Broadcom BCM 4331 interface card) and another
laptop ( Dell Latitude E6410 using the Intel Corporation Centrino
Ultimate-N 6300 interface card) programmed as a receiver sniffs the network
for the custom injected packets and reports parameters such as Received
signal strength, propagation delay etc... The transmission is working fine
and i am able to get the injected packets on the receiving side.

However , When i use Wireshark to analyze the incoming packets using the
monitor interface created using airmon-ng, the radio tap header seems to be
malformed. This is the same for all packets . The attached screen-shows the
problem.

Also why is the Noise parameter now shown in the radio tap details?

Could anyone help me out with this?

Regards,
Anand.

[-- Attachment #1.2: Type: text/html, Size: 1053 bytes --]

<br clear="all">Hi,<br>        I have set up an experiment to measure Wireless communication parameters using two laptops. I am injecting custom packets into the network on a monitor interface using one laptop programmed as a transmitter(Macbook Pro using Broadcom BCM 4331 interface card) and another laptop ( Dell Latitude E6410 using the Intel Corporation Centrino Ultimate-N 6300 interface card) programmed as a receiver sniffs the network for the custom injected packets and reports parameters such as Received signal strength, propagation delay etc... The transmission is working fine and i am able to get the injected packets on the receiving side. <br>
<br>However , When i use Wireshark to analyze the incoming packets using the monitor interface created using airmon-ng, the radio tap header seems to be malformed. This is the same for all packets . The attached screen-shows the problem. <br>
<br>Also why is the Noise parameter now shown in the radio tap details? <br><br>Could anyone help me out with this?<br><br>Regards,<br>Anand.<br>

[-- Attachment #2: Screenshot from 2012-06-18 11:36:04.png --]
[-- Type: image/png, Size: 286222 bytes --]

^ permalink raw reply	[flat|nested] only message in thread

only message in thread, back to index

Thread overview: (only message) (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2012-06-18 16:03 Help needed with malformed radiotap headers anand

RadioTap Archive on lore.kernel.org

Archives are clonable:
	git clone --mirror https://lore.kernel.org/radiotap/0 radiotap/git/0.git

	# If you have public-inbox 1.1+ installed, you may
	# initialize and index your mirror using the following commands:
	public-inbox-init -V2 radiotap radiotap/ https://lore.kernel.org/radiotap \
		radiotap@radiotap.org
	public-inbox-index radiotap

Example config snippet for mirrors

Newsgroup available over NNTP:
	nntp://nntp.lore.kernel.org/org.netbsd.radiotap


AGPL code for this site: git clone https://public-inbox.org/public-inbox.git