rcu.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* [PATCH tip/core/rcu 0/8] RCU list-traversal lockdep updates for v5.4
@ 2019-08-01 22:42 Paul E. McKenney
  2019-08-01 22:42 ` [PATCH tip/core/rcu 1/8] treewide: Rename rcu_dereference_raw_notrace() to _check() Paul E. McKenney
                   ` (7 more replies)
  0 siblings, 8 replies; 9+ messages in thread
From: Paul E. McKenney @ 2019-08-01 22:42 UTC (permalink / raw)
  To: rcu
  Cc: linux-kernel, mingo, jiangshanlai, dipankar, akpm,
	mathieu.desnoyers, josh, tglx, peterz, rostedt, dhowells,
	edumazet, fweisbec, oleg, joel

Hello!

This series provides enhancements to RCU pointer and list macros, all
courtesy of Joel Fernandes:

1.	Rename rcu_dereference_raw_notrace() to _check().

2.	Remove redundant debug_locks check in rcu_read_lock_sched_held().

3.	Add support for consolidated-RCU reader checking.

4.	Remove custom check for RCU readers.

5.	Add lockdep condition to fix for_each_entry().

6.	Convert to use built-in RCU list checking.

7.	Pass lockdep condition to pcm_mmcfg_list iterator.

8.	Use built-in RCU list checking for acpi_ioremaps list.

							Thanx, Paul

------------------------------------------------------------------------

 Documentation/RCU/Design/Requirements/Requirements.html |    2 
 arch/powerpc/include/asm/kvm_book3s_64.h                |    2 
 arch/x86/pci/mmconfig-shared.c                          |    5 -
 drivers/acpi/osl.c                                      |    6 -
 drivers/base/base.h                                     |    1 
 drivers/base/core.c                                     |   10 ++
 drivers/base/power/runtime.c                            |   15 ++-
 include/linux/rcu_sync.h                                |    4 
 include/linux/rculist.h                                 |   38 +++++++--
 include/linux/rcupdate.h                                |    9 +-
 kernel/rcu/Kconfig.debug                                |   11 ++
 kernel/rcu/update.c                                     |   67 ++++++++++------
 kernel/trace/ftrace_internal.h                          |    8 -
 kernel/trace/trace.c                                    |    4 
 net/ipv4/fib_frontend.c                                 |    3 
 15 files changed, 132 insertions(+), 53 deletions(-)

^ permalink raw reply	[flat|nested] 9+ messages in thread

end of thread, other threads:[~2019-08-01 22:43 UTC | newest]

Thread overview: 9+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2019-08-01 22:42 [PATCH tip/core/rcu 0/8] RCU list-traversal lockdep updates for v5.4 Paul E. McKenney
2019-08-01 22:42 ` [PATCH tip/core/rcu 1/8] treewide: Rename rcu_dereference_raw_notrace() to _check() Paul E. McKenney
2019-08-01 22:42 ` [PATCH tip/core/rcu 2/8] rcu: Remove redundant debug_locks check in rcu_read_lock_sched_held() Paul E. McKenney
2019-08-01 22:42 ` [PATCH tip/core/rcu 3/8] rcu: Add support for consolidated-RCU reader checking Paul E. McKenney
2019-08-01 22:42 ` [PATCH tip/core/rcu 4/8] rcu/sync: Remove custom check for RCU readers Paul E. McKenney
2019-08-01 22:42 ` [PATCH tip/core/rcu 5/8] ipv4: Add lockdep condition to fix for_each_entry() Paul E. McKenney
2019-08-01 22:42 ` [PATCH tip/core/rcu 6/8] driver/core: Convert to use built-in RCU list checking Paul E. McKenney
2019-08-01 22:42 ` [PATCH tip/core/rcu 7/8] x86/pci: Pass lockdep condition to pcm_mmcfg_list iterator Paul E. McKenney
2019-08-01 22:42 ` [PATCH tip/core/rcu 8/8] acpi: Use built-in RCU list checking for acpi_ioremaps list Paul E. McKenney

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).