rcu.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
 messages from 2020-03-27 22:26:33 to 2020-04-15 18:20:14 UTC [more...]

[PATCH RFC tip/core/rcu 0/16] Prototype RCU usable from idle, exception, offline
 2020-04-15 18:19 UTC  (25+ messages)
` [PATCH RFC v2 tip/core/rcu 0/22] "
  ` [PATCH RFC v2 tip/core/rcu 14/22] rcu-tasks: Add an RCU Tasks Trace to simplify protection of tracing hooks
  ` [PATCH RFC v3 tip/core/rcu 0/34] Prototype RCU usable from idle, exception, offline
    ` [PATCH v3 tip/core/rcu 01/34] sched/core: Add function to sample state of locked-down task
    ` [PATCH v3 tip/core/rcu 03/34] rcutorture: Add flag to produce non-busy-wait task stalls
    ` [PATCH v3 tip/core/rcu 04/34] rcu-tasks: Move Tasks RCU to its own file
    ` [PATCH v3 tip/core/rcu 05/34] rcu-tasks: Create struct to hold state information
    ` [PATCH v3 tip/core/rcu 06/34] rcu: Reinstate synchronize_rcu_mult()
    ` [PATCH v3 tip/core/rcu 08/34] rcu-tasks: Refactor RCU-tasks to allow variants to be added
    ` [PATCH v3 tip/core/rcu 10/34] rcutorture: Add torture tests for RCU Tasks Rude
    ` [PATCH v4 tip/core/rcu 0/38] Prototype RCU usable from idle, exception, offline
      ` [PATCH v4 tip/core/rcu 02/38] rcu-tasks: Use context-switch hook for PREEMPT=y kernels
      ` [PATCH v4 tip/core/rcu 06/38] rcu-tasks: Create struct to hold state information
      ` [PATCH v4 tip/core/rcu 10/38] rcu-tasks: Add an RCU-tasks rude variant
      ` [PATCH v4 tip/core/rcu 19/38] rcu-tasks: Add RCU tasks to rcutorture writer stall output
      ` [PATCH v4 tip/core/rcu 36/38] rcu-tasks: Allow standalone use of TASKS_{TRACE_,}RCU
      ` [PATCH v4 tip/core/rcu 37/38] ftrace: Use synchronize_rcu_tasks_rude() instead of ftrace_sync()
      ` [PATCH v4 tip/core/rcu 38/38] rcu: Don't acquire lock in NMI handler in rcu_nmi_enter_common()

[PATCH tip/core/rcu 0/6] Remove scheduler restriction, update for v5.8
 2020-04-15 17:56 UTC  (7+ messages)
` [PATCH tip/core/rcu 1/6] rcu: Add KCSAN stubs to update.c
` [PATCH tip/core/rcu 2/6] rcu: Make rcu_read_unlock_special() safe for rq/pi locks
` [PATCH tip/core/rcu 3/6] rcu: Don't set nesting depth negative in rcu_preempt_deferred_qs()
` [PATCH tip/core/rcu 4/6] rcu: Remove unused ->rcu_read_unlock_special.b.deferred_qs field
` [PATCH tip/core/rcu 5/6] rcu: Don't use negative nesting depth in __rcu_read_unlock()
` [PATCH tip/core/rcu 6/6] rcutorture: Add test of holding scheduler locks across rcu_read_unlock()

[PATCH tip/core/rcu 0/18] Torture-test updates for v5.8
 2020-04-15 17:31 UTC  (19+ messages)
` [PATCH tip/core/rcu 01/18] rcutorture: Add KCSAN stubs
` [PATCH tip/core/rcu 02/18] rcutorture: Make kvm-recheck-rcu.sh handle truncated lines
` [PATCH tip/core/rcu 03/18] rcutorture: Mark data-race potential for rcu_barrier() test statistics
` [PATCH tip/core/rcu 04/18] locktorture.c: Fix if-statement empty body warnings
` [PATCH tip/core/rcu 05/18] Default enable RCU list lockdep debugging with PROVE_RCU
` [PATCH tip/core/rcu 06/18] rcutorture: Add flag to produce non-busy-wait task stalls
` [PATCH tip/core/rcu 07/18] rcutorture: Right-size TREE10 CPU consumption
` [PATCH tip/core/rcu 08/18] rcu: Allow rcutorture to starve grace-period kthread
` [PATCH tip/core/rcu 09/18] torture: Add --kcsan argument to top-level kvm.sh script
` [PATCH tip/core/rcu 10/18] torture: Make --kcsan argument also create a summary
` [PATCH tip/core/rcu 11/18] rcutorture: Make rcu_fwds and rcu_fwd_emergency_stop static
` [PATCH tip/core/rcu 12/18] torture: Eliminate duplicate #CHECK# from ConfigFragment
` [PATCH tip/core/rcu 13/18] torture: Abstract application of additional Kconfig options
` [PATCH tip/core/rcu 14/18] torture: Allow --kconfig options to override --kcsan defaults
` [PATCH tip/core/rcu 15/18] torture: Allow scenario-specific Kconfig options to override CFcommon
` [PATCH tip/core/rcu 16/18] torture: Save a few lines by using config_override_param initially
` [PATCH tip/core/rcu 17/18] torture: Add a --kasan argument
` [PATCH tip/core/rcu 18/18] rcutorture: Convert ULONG_CMP_LT() to time_before()

[PATCH tip/core/rcu 0/19] Miscellaneous fixes for v5.8
 2020-04-15 17:32 UTC  (22+ messages)
` [PATCH tip/core/rcu 01/19] rcu: Add KCSAN stubs
` [PATCH tip/core/rcu 02/19] srcu: "
` [PATCH tip/core/rcu 03/19] rcu: Mark rcu_state.ncpus to detect concurrent writes
` [PATCH tip/core/rcu 04/19] rcu: Add *_ONCE() and data_race() to rcu_node ->exp_tasks plus locking
` [PATCH tip/core/rcu 05/19] rcu: Add READ_ONCE and data_race() to rcu_node ->boost_tasks
` [PATCH tip/core/rcu 06/19] srcu: Add data_race() to ->srcu_lock_count and ->srcu_unlock_count arrays
` [PATCH tip/core/rcu 07/19] rcu: Add WRITE_ONCE() to rcu_node ->boost_tasks
` [PATCH tip/core/rcu 08/19] rcu: Use data_race() for RCU CPU stall-warning prints
` [PATCH tip/core/rcu 09/19] drm: Make drm_dp_mst_dsc_aux_for_port() safe for old compilers
` [PATCH tip/core/rcu 10/19] rcu: Expedite first two FQS scans under callback-overload conditions
` [PATCH tip/core/rcu 11/19] rcu: Fix the (t=0 jiffies) false positive
` [PATCH tip/core/rcu 12/19] Revert "rculist: Describe variadic macro argument in a Sphinx-compatible way"
` [PATCH tip/core/rcu 13/19] rcu: Get rid of some doc warnings in update.c
` [PATCH tip/core/rcu 14/19] rcu: Mark rcu_state.gp_seq to detect more concurrent writes
` [PATCH tip/core/rcu 15/19] rcu: Replace assigned pointer ret value by corresponding boolean value
` [PATCH tip/core/rcu 16/19] rcu: Replace 1 by true
` [PATCH tip/core/rcu 17/19] rcu: Convert ULONG_CMP_GE() to time_after() for jiffy comparison
` [PATCH tip/core/rcu 18/19] rcu: Convert rcu_initiate_boost() ULONG_CMP_GE() to time_after()
` [PATCH tip/core/rcu 19/19] rcu: Convert rcu_nohz_full_cpu() ULONG_CMP_LT() to time_before()

[PATCH tip/core/rcu 0/3] RCU stall-warning updates for v5.8
 2020-04-15 17:24 UTC  (4+ messages)
` [PATCH tip/core/rcu 1/3] rcu: Use data_race() for RCU expedited CPU stall-warning prints
` [PATCH tip/core/rcu 2/3] rcu: When GP kthread is starved, tag idle threads as false positives
` [PATCH tip/core/rcu 3/3] rcu: Remove self-stack-trace when all quiescent states seen

[PATCH tip/core/rcu 0/4] kfree_rcu() updates for v5.8
 2020-04-15 17:19 UTC  (5+ messages)
` [PATCH tip/core/rcu 1/4] rcuperf: Add ability to increase object allocation size
` [PATCH tip/core/rcu 2/4] rcu/tree: Add a shrinker to prevent OOM due to kfree_rcu() batching
` [PATCH tip/core/rcu 3/4] rcu/tree: Count number of batched kfree_rcu() locklessly
` [PATCH tip/core/rcu 4/4] rcu: Add rcu_gp_might_be_stalled()

[PATCH 0/3] rcu: Static initializer + misc
 2020-04-15 16:00 UTC  (4+ messages)
` [PATCH 1/3] rcu: Use static initializer for krc.lock
` [PATCH 2/3] rcu: Use consistent locking around kfree_rcu_drain_unlock()
` [PATCH 3/3] rcu: Avoid using xchg() in kfree_call_rcu_add_ptr_to_bulk()

[PATCH RFC] rcu/tree: Refactor object allocation and try harder for array allocation
 2020-04-14 19:43 UTC  (2+ messages)

[GIT PULL rcu/urgent] Don't acquire lock in NMI handler (v5.7)
 2020-04-14  6:37 UTC  (2+ messages)

[PATCH] Documentation/rcu: fix a typo in RTFP
 2020-04-10 23:54 UTC  (5+ messages)

[PATCH] rcutorture: make rcu_fwds and rcu_fwd_emergency_stop static
 2020-04-09 20:59 UTC  (2+ messages)

WARNING: events/ipi.h:36 suspicious rcu_dereference_check() usage!
 2020-04-08  9:31 UTC 

[PATCH 1/3] rcu/tree: use more permissive parameters when attaching a head
 2020-04-07  2:11 UTC  (5+ messages)
` [PATCH 2/3] rcu/tree: move locking/unlocking to separate functions
` [PATCH 3/3] lib/test_vmalloc.c: introduce two new test cases

[PATCH 1/1] rcu/tree: add emergency pool for headless case
 2020-04-07  1:47 UTC  (14+ messages)

de8f5e4f2d ("lockdep: Introduce wait-type checks"): [ 17.344674] EIP: default_idle
 2020-04-03  6:52 UTC  (3+ messages)
  ` [LKP] "

What should we be doing to stress-test kfree_rcu()?
 2020-04-01 21:24 UTC  (4+ messages)

[PATCH RFC] rcu/tree: Use GFP_MEMALLOC for alloc memory to free memory pattern
 2020-04-01 19:35 UTC  (38+ messages)

[PATCH v2 2/4] rcu: Replace 1 by true
 2020-03-30 21:16 UTC  (2+ messages)

[PATCH 03/10] cpu: Remove Comparison to bool
 2020-03-30 21:12 UTC  (4+ messages)
  ` [PATCH 06/10] rcu: Replace assigned pointer ret value by corresponding boolean value

[PATCH 00/18] kfree_rcu() improvements for -rcu dev
 2020-03-30 18:21 UTC  (27+ messages)
` [PATCH 01/18] mm/list_lru.c: Rename kvfree_rcu() to local variant
` [PATCH 02/18] rcu: Introduce kvfree_rcu() interface
` [PATCH 03/18] rcu: Rename rcu_invoke_kfree_callback/rcu_kfree_callback
` [PATCH 04/18] rcu: Rename __is_kfree_rcu_offset() macro
` [PATCH 05/18] rcu: Rename kfree_call_rcu() to the kvfree_call_rcu()
` [PATCH 06/18] mm/list_lru.c: Remove kvfree_rcu_local() function
` [PATCH 07/18] rcu/tree: Simplify debug_objects handling
` [PATCH 08/18] rcu/tree: Clarify emergency path comment better
` [PATCH 09/18] rcu/tree: Simplify KFREE_BULK_MAX_ENTR macro
` [PATCH 10/18] rcu/tree: Maintain separate array for vmalloc ptrs
` [PATCH 11/18] rcu/tree: Introduce expedited_drain flag
` [PATCH 12/18] rcu/tree: Support reclaim for head-less object
` [PATCH 13/18] rcu/tiny: Move kvfree_call_rcu() out of header
` [PATCH 14/18] rcu/tiny: Support reclaim for head-less object
` [PATCH 15/18] rcu: Support headless variant in the kvfree_rcu()
` [PATCH 16/18] rcu/tree: Remove extra next variable in kfree worker function
` [PATCH 17/18] rcu/tree: Simplify is_vmalloc_addr expression
` [PATCH 18/18] rcu/tree: Make kvfree_rcu() tolerate any alignment

[PATCH] rcu/tree: include mm.h where kvfree() is defined
 2020-03-30 15:26 UTC 

[PATCH 0/7] Headless support in the kvfree_rcu()
 2020-03-30 14:42 UTC  (7+ messages)
` [PATCH 4/7] rcu/tree: support reclaim for head-less object
` [PATCH 6/7] rcu/tiny: "

rcu_barrier() no longer allowed within mmap_sem?
 2020-03-30 13:58 UTC  (3+ messages)

[PATCH v2 0/4] RCU dyntick nesting counter cleanups
 2020-03-28 23:56 UTC  (7+ messages)
` [PATCH v2 1/4] Revert b8c17e6664c4 ("rcu: Maintain special bits at bottom of ->dynticks counter")
` [PATCH v2 2/4] rcu/tree: Add better tracing for dyntick-idle
` [PATCH v2 3/4] rcu/tree: Clean up dynticks counter usage
` [PATCH v2 4/4] rcu/tree: Remove dynticks_nmi_nesting counter


This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).