Linux kernel regressions
 help / color / Atom feed
From: Greg KH <greg@kroah.com>
To: "Anatoli N.Chechelnickiy" <Anatoli.Chechelnickiy@m.interpipe.biz>
Cc: "stable@vger.kernel.org" <stable@vger.kernel.org>,
	"regressions@lists.linux.dev" <regressions@lists.linux.dev>,
	"baolu.lu@linux.intel.com" <baolu.lu@linux.intel.com>,
	"sashal@kernel.org" <sashal@kernel.org>
Subject: Re: regressions in iommu system with 5.10.37
Date: Wed, 19 May 2021 10:23:58 +0200
Message-ID: <YKTLHuWCdIhEIObv@kroah.com> (raw)
In-Reply-To: <8893cfb2-d4e8-f3e9-e0b9-bbacf1220dca@m.interpipe.biz>

On Wed, May 19, 2021 at 08:01:29AM +0000, Anatoli N.Chechelnickiy wrote:
> Hi
> 
> I'm sorry to report about regression in 5.10.37
> 
> with
> 
> CONFIG_IOMMU_IOVA=y
> CONFIG_IOMMU_API=y
> CONFIG_IOMMU_SUPPORT=y
> CONFIG_OF_IOMMU=y
> CONFIG_INTEL_IOMMU=y
> CONFIG_INTEL_IOMMU_SVM=y
> CONFIG_INTEL_IOMMU_DEFAULT_ON=y
> CONFIG_INTEL_IOMMU_FLOPPY_WA=y
> 
> and iommu=on in grub.cfg
> 
> 
> All my dell r340 and all lenovo servers won't boot any more. Just black
> screen at once.
> 
> 
> with intel_iommu=on iommu=pt DELL R240 and Lenovo SR350 cat boot
> 
> Older Lenovo cannot boot even with "intel_iommu=on iommu=pt" only with
> iommu=off in grub
> 
> With iommu=off in grub all servers are booting well
> 
> With 5.4.36 do not have this problem
> 
> 
> tested last 4 days with 10+ different servers(

Should be fixed with 5.10.38.  If not, please let us know.

thanks,

greg k-h

      reply index

Thread overview: 2+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2021-05-19  8:01 Anatoli N.Chechelnickiy
2021-05-19  8:23 ` Greg KH [this message]

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=YKTLHuWCdIhEIObv@kroah.com \
    --to=greg@kroah.com \
    --cc=Anatoli.Chechelnickiy@m.interpipe.biz \
    --cc=baolu.lu@linux.intel.com \
    --cc=regressions@lists.linux.dev \
    --cc=sashal@kernel.org \
    --cc=stable@vger.kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link

Linux kernel regressions

Archives are clonable:
	git clone --mirror https://lore.kernel.org/regressions/0 regressions/git/0.git

	# If you have public-inbox 1.1+ installed, you may
	# initialize and index your mirror using the following commands:
	public-inbox-init -V2 regressions regressions/ https://lore.kernel.org/regressions \
		regressions@lists.linux.dev
	public-inbox-index regressions

Example config snippet for mirrors

Newsgroup available over NNTP:
	nntp://nntp.lore.kernel.org/dev.linux.lists.regressions


AGPL code for this site: git clone https://public-inbox.org/public-inbox.git