stable.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* [PATCH v2] uapi/if_ether.h: prevent redefinition of struct ethhdr
@ 2019-02-14 13:18 Linus Walleij
  2019-02-17 18:21 ` Sasha Levin
  0 siblings, 1 reply; 2+ messages in thread
From: Linus Walleij @ 2019-02-14 13:18 UTC (permalink / raw)
  To: Greg Kroah-Hartman, stable, openwrt-devel
  Cc: David S . Miller, Hauke Mehrtens, Linus Walleij

From: Hauke Mehrtens <hauke@hauke-m.de>

commit 6926e041a8920c8ec27e4e155efa760aa01551fd upstream.

Musl provides its own ethhdr struct definition. Add a guard to prevent
its definition of the appropriate musl header has already been included.

glibc does not implement this header, but when glibc will implement this
they can just define __UAPI_DEF_ETHHDR 0 to make it work with the
kernel.

Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
Signed-off-by: David S. Miller <davem@davemloft.net>
Signed-off-by: Linus Walleij <linus.walleij@linaro.org>
---
ChangeLog v1->v2:
- Add SoB line

- This is upstream in v4.15
- This should be applied for stable v4.14.y and v4.9.y
---
 include/uapi/linux/if_ether.h    | 3 +++
 include/uapi/linux/libc-compat.h | 6 ++++++
 2 files changed, 9 insertions(+)

diff --git a/include/uapi/linux/if_ether.h b/include/uapi/linux/if_ether.h
index 244e3213ecb0..60ec9114e28f 100644
--- a/include/uapi/linux/if_ether.h
+++ b/include/uapi/linux/if_ether.h
@@ -23,6 +23,7 @@
 #define _UAPI_LINUX_IF_ETHER_H
 
 #include <linux/types.h>
+#include <linux/libc-compat.h>
 
 /*
  *	IEEE 802.3 Ethernet magic constants.  The frame sizes omit the preamble
@@ -150,11 +151,13 @@
  *	This is an Ethernet frame header.
  */
 
+#if __UAPI_DEF_ETHHDR
 struct ethhdr {
 	unsigned char	h_dest[ETH_ALEN];	/* destination eth addr	*/
 	unsigned char	h_source[ETH_ALEN];	/* source ether addr	*/
 	__be16		h_proto;		/* packet type ID field	*/
 } __attribute__((packed));
+#endif
 
 
 #endif /* _UAPI_LINUX_IF_ETHER_H */
diff --git a/include/uapi/linux/libc-compat.h b/include/uapi/linux/libc-compat.h
index 8254c937c9f4..fc29efaa918c 100644
--- a/include/uapi/linux/libc-compat.h
+++ b/include/uapi/linux/libc-compat.h
@@ -264,4 +264,10 @@
 
 #endif /* __GLIBC__ */
 
+/* Definitions for if_ether.h */
+/* allow libcs like musl to deactivate this, glibc does not implement this. */
+#ifndef __UAPI_DEF_ETHHDR
+#define __UAPI_DEF_ETHHDR		1
+#endif
+
 #endif /* _UAPI_LIBC_COMPAT_H */
-- 
2.20.1


^ permalink raw reply related	[flat|nested] 2+ messages in thread

* Re: [PATCH v2] uapi/if_ether.h: prevent redefinition of struct ethhdr
  2019-02-14 13:18 [PATCH v2] uapi/if_ether.h: prevent redefinition of struct ethhdr Linus Walleij
@ 2019-02-17 18:21 ` Sasha Levin
  0 siblings, 0 replies; 2+ messages in thread
From: Sasha Levin @ 2019-02-17 18:21 UTC (permalink / raw)
  To: Linus Walleij
  Cc: Greg Kroah-Hartman, stable, openwrt-devel, David S . Miller,
	Hauke Mehrtens

On Thu, Feb 14, 2019 at 02:18:00PM +0100, Linus Walleij wrote:
>From: Hauke Mehrtens <hauke@hauke-m.de>
>
>commit 6926e041a8920c8ec27e4e155efa760aa01551fd upstream.
>
>Musl provides its own ethhdr struct definition. Add a guard to prevent
>its definition of the appropriate musl header has already been included.
>
>glibc does not implement this header, but when glibc will implement this
>they can just define __UAPI_DEF_ETHHDR 0 to make it work with the
>kernel.
>
>Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
>Signed-off-by: David S. Miller <davem@davemloft.net>
>Signed-off-by: Linus Walleij <linus.walleij@linaro.org>

Queued up, thank you.

--
Thanks,
Sasha

^ permalink raw reply	[flat|nested] 2+ messages in thread

end of thread, other threads:[~2019-02-17 18:21 UTC | newest]

Thread overview: 2+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2019-02-14 13:18 [PATCH v2] uapi/if_ether.h: prevent redefinition of struct ethhdr Linus Walleij
2019-02-17 18:21 ` Sasha Levin

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).