WireGuard Archive on lore.kernel.org
 help / Atom feed
* Problems on MacOS (Mojave)
@ 2018-12-25 11:54 Shankar Ramamoorthy
  2019-01-02 23:07 ` Jaseem Abid
  0 siblings, 1 reply; 2+ messages in thread
From: Shankar Ramamoorthy @ 2018-12-25 11:54 UTC (permalink / raw)
  To: wireguard

Installed Wireguard via MacPorts on machine running macOS Mojave 10.14.2.

It worked the very first time, but haven't been able to get it to work
since.

Any help or suggestions appreciated. Gory details below.

Machines: 192.168.11.44 (macos, 192.168.1.2) and 192.168.11.15 (Debian,
192.168.1.1)

I know that Wireguard on the Debian box is working properly because I
can connect to it from a different peer.

macos config:
[Interface]
Address = 192.168.1.2/24
PrivateKey = kJbWLVX6tj+PxV9eKTZ0g4akHiPFOreUwsqsDrRXJmo=
ListenPort = 2200

[Peer]
PublicKey = H+RLiowROj143Xjn/P87R4qcSmt+X7ROaPVzXYrYb1U=
AllowedIPs = 0.0.0.0/0, ::/0
Endpoint = 192.168.11.15:2200
# This is for if you’re behind a NAT and want the connection to be kept
alive.
PersistentKeepalive = 25

Debian config:
[Interface]
PrivateKey = uMZzy458hweehyFfD4PenKwsH1/bKHSn0ayOWLknl2U=
ListenPort = 2200

[Peer]
PublicKey = uM3OykF94Ior3CnRudN6AwH4zNqN8Vh7CwcuwQaCt3E=
AllowedIPs = 0.0.0.0/0
Endpoint = 192.168.11.44:2200
# This is for if you’re behind a NAT and want the connection to be kept
alive.
PersistentKeepalive = 25

Output of "sudo wg-quick up ~/.config/wireguard/wg0.conf":
INFO: (utun1) 2018/12/25 03:47:35 Starting wireguard-go version 0.0.20181222
[+] Interface for wg0 is utun1
[#] wg setconf utun1 /dev/fd/63
[#] ifconfig utun1 inet 192.168.1.2/24 192.168.1.2 alias
[#] ifconfig utun1 up
[#] route -q -n add -inet6 ::/1 -interface utun1
route: writing to routing socket: Network is unreachable
[#] route -q -n add -inet6 8000::/1 -interface utun1
route: writing to routing socket: Network is unreachable
[#] route -q -n add -inet 0.0.0.0/1 -interface utun1
[#] route -q -n add -inet 128.0.0.0/1 -interface utun1
[#] route -q -n add -inet 192.168.11.15 -gateway 192.168.11.1
[+] Backgrounding route monitor

ifconfig for utun0 and utun1:
utun0: flags=8050<POINTOPOINT,RUNNING,MULTICAST> mtu 2000
    inet6 fe80::6431:138d:3530:c696%utun0 prefixlen 64 scopeid 0xb
    inet 192.168.1.2 --> 192.168.1.1 netmask 0xffffff00
    nd6 options=201<PERFORMNUD,DAD>
utun1: flags=8051<UP,POINTOPOINT,RUNNING,MULTICAST> mtu 1420
    inet 192.168.1.2 --> 192.168.1.2 netmask 0xffffff00

Output of "netstat -an | grep utun":
netstat -rn | grep utun
0/1                utun1              USc            67        0  
utun1      
128.0/1            utun1              USc             2        0  
utun1      
192.168.1.2        192.168.1.2        UH              0        0  
utun1      
default                                 fe80::%utun0                   
UGcI          utun0      
fe80::%utun0/64                         fe80::6431:138d:3530:c696%utun0
UcI           utun0      
fe80::6431:138d:3530:c696%utun0         link#11                        
UHLI            lo0      
ff01::%utun0/32                         fe80::6431:138d:3530:c696%utun0
UmCI          utun0      
ff02::%utun0/32                         fe80::6431:138d:3530:c696%utun0
UmCI          utun0    

Both "ping 192.168.1.1" and "ping 192.168.1.2" report Request timeout.

I'm also not able to get rid of the utun0 interface, which did not exist
before Wireguard I think.
Shankar
_______________________________________________
WireGuard mailing list
WireGuard@lists.zx2c4.com
https://lists.zx2c4.com/mailman/listinfo/wireguard

^ permalink raw reply	[flat|nested] 2+ messages in thread

* Re: Problems on MacOS (Mojave)
  2018-12-25 11:54 Problems on MacOS (Mojave) Shankar Ramamoorthy
@ 2019-01-02 23:07 ` Jaseem Abid
  0 siblings, 0 replies; 2+ messages in thread
From: Jaseem Abid @ 2019-01-02 23:07 UTC (permalink / raw)
  To: Shankar Ramamoorthy; +Cc: wireguard

[-- Attachment #1.1: Type: text/plain, Size: 3903 bytes --]

On Wed, 2 Jan 2019 at 19:28, Shankar Ramamoorthy <shankar@me.com> wrote:

> Installed Wireguard via MacPorts on machine running macOS Mojave 10.14.2.
>
> It worked the very first time, but haven't been able to get it to work
> since.
>
> Any help or suggestions appreciated. Gory details below.
>
> Machines: 192.168.11.44 (macos, 192.168.1.2) and 192.168.11.15 (Debian,
> 192.168.1.1)
>
> I know that Wireguard on the Debian box is working properly because I
> can connect to it from a different peer.
>
> macos config:
> [Interface]
> Address = 192.168.1.2/24
> PrivateKey = kJbWLVX6tj+PxV9eKTZ0g4akHiPFOreUwsqsDrRXJmo=
> ListenPort = 2200
>
> [Peer]
> PublicKey = H+RLiowROj143Xjn/P87R4qcSmt+X7ROaPVzXYrYb1U=
> AllowedIPs = 0.0.0.0/0, ::/0
> Endpoint = 192.168.11.15:2200
> # This is for if you’re behind a NAT and want the connection to be kept
> alive.
> PersistentKeepalive = 25
>
> Debian config:
> [Interface]
> PrivateKey = uMZzy458hweehyFfD4PenKwsH1/bKHSn0ayOWLknl2U=
> ListenPort = 2200
>
> [Peer]
> PublicKey = uM3OykF94Ior3CnRudN6AwH4zNqN8Vh7CwcuwQaCt3E=
> AllowedIPs = 0.0.0.0/0
> Endpoint = 192.168.11.44:2200
> # This is for if you’re behind a NAT and want the connection to be kept
> alive.
> PersistentKeepalive = 25
>
> Output of "sudo wg-quick up ~/.config/wireguard/wg0.conf":
> INFO: (utun1) 2018/12/25 03:47:35 Starting wireguard-go version
> 0.0.20181222
> [+] Interface for wg0 is utun1
> [#] wg setconf utun1 /dev/fd/63
> [#] ifconfig utun1 inet 192.168.1.2/24 192.168.1.2 alias
> [#] ifconfig utun1 up
> [#] route -q -n add -inet6 ::/1 -interface utun1
> route: writing to routing socket: Network is unreachable
> [#] route -q -n add -inet6 8000::/1 -interface utun1
> route: writing to routing socket: Network is unreachable
> [#] route -q -n add -inet 0.0.0.0/1 -interface utun1
> [#] route -q -n add -inet 128.0.0.0/1 -interface utun1
> [#] route -q -n add -inet 192.168.11.15 -gateway 192.168.11.1
> [+] Backgrounding route monitor
>
> ifconfig for utun0 and utun1:
> utun0: flags=8050<POINTOPOINT,RUNNING,MULTICAST> mtu 2000
>     inet6 fe80::6431:138d:3530:c696%utun0 prefixlen 64 scopeid 0xb
>     inet 192.168.1.2 --> 192.168.1.1 netmask 0xffffff00
>     nd6 options=201<PERFORMNUD,DAD>
> utun1: flags=8051<UP,POINTOPOINT,RUNNING,MULTICAST> mtu 1420
>     inet 192.168.1.2 --> 192.168.1.2 netmask 0xffffff00
>
> Output of "netstat -an | grep utun":
> netstat -rn | grep utun
> 0/1                utun1              USc            67        0
> utun1
> 128.0/1            utun1              USc             2        0
> utun1
> 192.168.1.2        192.168.1.2        UH              0        0
> utun1
> default                                 fe80::%utun0
> UGcI          utun0
> fe80::%utun0/64                         fe80::6431:138d:3530:c696%utun0
> UcI           utun0
> fe80::6431:138d:3530:c696%utun0         link#11
> UHLI            lo0
> ff01::%utun0/32                         fe80::6431:138d:3530:c696%utun0
> UmCI          utun0
> ff02::%utun0/32                         fe80::6431:138d:3530:c696%utun0
> UmCI          utun0
>
> Both "ping 192.168.1.1" and "ping 192.168.1.2" report Request timeout.
>
> I'm also not able to get rid of the utun0 interface, which did not exist
> before Wireguard I think.
> Shankar
> _______________________________________________
> WireGuard mailing list
> WireGuard@lists.zx2c4.com
> https://lists.zx2c4.com/mailman/listinfo/wireguard
>

The Debian config seems to be missing an `Address`.  I'm not sure if that's
really the issue here, but I cannot see anything else wrong with the
config. I run a very similar config to tunnel b/w a mac and ubuntu.

Regarding the utun0, I seem to have the same interface on my laptop and
it's not managed by wg.


-- 
Regards,

Jaseem Abid
https://twitter.com/jaseemabid

[-- Attachment #1.2: Type: text/html, Size: 5816 bytes --]

<div dir="ltr"><div dir="ltr"><br></div><br><div class="gmail_quote"><div dir="ltr">On Wed, 2 Jan 2019 at 19:28, Shankar Ramamoorthy &lt;<a href="mailto:shankar@me.com">shankar@me.com</a>&gt; wrote:<br></div><blockquote class="gmail_quote" style="margin:0px 0px 0px 0.8ex;border-left:1px solid rgb(204,204,204);padding-left:1ex">Installed Wireguard via MacPorts on machine running macOS Mojave 10.14.2.<br>
<br>
It worked the very first time, but haven&#39;t been able to get it to work<br>
since.<br>
<br>
Any help or suggestions appreciated. Gory details below.<br>
<br>
Machines: 192.168.11.44 (macos, 192.168.1.2) and 192.168.11.15 (Debian,<br>
192.168.1.1)<br>
<br>
I know that Wireguard on the Debian box is working properly because I<br>
can connect to it from a different peer.<br>
<br>
macos config:<br>
[Interface]<br>
Address = <a href="http://192.168.1.2/24" rel="noreferrer" target="_blank">192.168.1.2/24</a><br>
PrivateKey = kJbWLVX6tj+PxV9eKTZ0g4akHiPFOreUwsqsDrRXJmo=<br>
ListenPort = 2200<br>
<br>
[Peer]<br>
PublicKey = H+RLiowROj143Xjn/P87R4qcSmt+X7ROaPVzXYrYb1U=<br>
AllowedIPs = <a href="http://0.0.0.0/0" rel="noreferrer" target="_blank">0.0.0.0/0</a>, ::/0<br>
Endpoint = <a href="http://192.168.11.15:2200" rel="noreferrer" target="_blank">192.168.11.15:2200</a><br>
# This is for if you’re behind a NAT and want the connection to be kept<br>
alive.<br>
PersistentKeepalive = 25<br>
<br>
Debian config:<br>
[Interface]<br>
PrivateKey = uMZzy458hweehyFfD4PenKwsH1/bKHSn0ayOWLknl2U=<br>
ListenPort = 2200<br>
<br>
[Peer]<br>
PublicKey = uM3OykF94Ior3CnRudN6AwH4zNqN8Vh7CwcuwQaCt3E=<br>
AllowedIPs = <a href="http://0.0.0.0/0" rel="noreferrer" target="_blank">0.0.0.0/0</a><br>
Endpoint = <a href="http://192.168.11.44:2200" rel="noreferrer" target="_blank">192.168.11.44:2200</a><br>
# This is for if you’re behind a NAT and want the connection to be kept<br>
alive.<br>
PersistentKeepalive = 25<br>
<br>
Output of &quot;sudo wg-quick up ~/.config/wireguard/wg0.conf&quot;:<br>
INFO: (utun1) 2018/12/25 03:47:35 Starting wireguard-go version 0.0.20181222<br>
[+] Interface for wg0 is utun1<br>
[#] wg setconf utun1 /dev/fd/63<br>
[#] ifconfig utun1 inet <a href="http://192.168.1.2/24" rel="noreferrer" target="_blank">192.168.1.2/24</a> 192.168.1.2 alias<br>
[#] ifconfig utun1 up<br>
[#] route -q -n add -inet6 ::/1 -interface utun1<br>
route: writing to routing socket: Network is unreachable<br>
[#] route -q -n add -inet6 8000::/1 -interface utun1<br>
route: writing to routing socket: Network is unreachable<br>
[#] route -q -n add -inet <a href="http://0.0.0.0/1" rel="noreferrer" target="_blank">0.0.0.0/1</a> -interface utun1<br>
[#] route -q -n add -inet <a href="http://128.0.0.0/1" rel="noreferrer" target="_blank">128.0.0.0/1</a> -interface utun1<br>
[#] route -q -n add -inet 192.168.11.15 -gateway 192.168.11.1<br>
[+] Backgrounding route monitor<br>
<br>
ifconfig for utun0 and utun1:<br>
utun0: flags=8050&lt;POINTOPOINT,RUNNING,MULTICAST&gt; mtu 2000<br>
    inet6 fe80::6431:138d:3530:c696%utun0 prefixlen 64 scopeid 0xb<br>
    inet 192.168.1.2 --&gt; 192.168.1.1 netmask 0xffffff00<br>
    nd6 options=201&lt;PERFORMNUD,DAD&gt;<br>
utun1: flags=8051&lt;UP,POINTOPOINT,RUNNING,MULTICAST&gt; mtu 1420<br>
    inet 192.168.1.2 --&gt; 192.168.1.2 netmask 0xffffff00<br>
<br>
Output of &quot;netstat -an | grep utun&quot;:<br>
netstat -rn | grep utun<br>
0/1                utun1              USc            67        0  <br>
utun1      <br>
128.0/1            utun1              USc             2        0  <br>
utun1      <br>
192.168.1.2        192.168.1.2        UH              0        0  <br>
utun1      <br>
default                                 fe80::%utun0                   <br>
UGcI          utun0      <br>
fe80::%utun0/64                         fe80::6431:138d:3530:c696%utun0<br>
UcI           utun0      <br>
fe80::6431:138d:3530:c696%utun0         link#11                        <br>
UHLI            lo0      <br>
ff01::%utun0/32                         fe80::6431:138d:3530:c696%utun0<br>
UmCI          utun0      <br>
ff02::%utun0/32                         fe80::6431:138d:3530:c696%utun0<br>
UmCI          utun0    <br>
<br>
Both &quot;ping 192.168.1.1&quot; and &quot;ping 192.168.1.2&quot; report Request timeout.<br>
<br>
I&#39;m also not able to get rid of the utun0 interface, which did not exist<br>
before Wireguard I think.<br>
Shankar<br>
_______________________________________________<br>
WireGuard mailing list<br>
<a href="mailto:WireGuard@lists.zx2c4.com" target="_blank">WireGuard@lists.zx2c4.com</a><br>
<a href="https://lists.zx2c4.com/mailman/listinfo/wireguard" rel="noreferrer" target="_blank">https://lists.zx2c4.com/mailman/listinfo/wireguard</a><br>
</blockquote></div><br clear="all"><div>The Debian config seems to be missing an `Address`.  I&#39;m not sure if that&#39;s really the issue here, but I cannot see anything else wrong with the config. I run a very similar config to tunnel b/w a mac and ubuntu. <br><br>Regarding the utun0, I seem to have the same interface on my laptop and it&#39;s not managed by wg. </div><div><br></div><div><br></div>-- <br><div dir="ltr" class="gmail_signature">Regards, <br><br>Jaseem Abid<br><a href="https://twitter.com/jaseemabid" target="_blank">https://twitter.com/jaseemabid</a><br></div></div>

[-- Attachment #2: Type: text/plain, Size: 148 bytes --]

_______________________________________________
WireGuard mailing list
WireGuard@lists.zx2c4.com
https://lists.zx2c4.com/mailman/listinfo/wireguard

^ permalink raw reply	[flat|nested] 2+ messages in thread

end of thread, back to index

Thread overview: 2+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2018-12-25 11:54 Problems on MacOS (Mojave) Shankar Ramamoorthy
2019-01-02 23:07 ` Jaseem Abid

WireGuard Archive on lore.kernel.org

Archives are clonable:
	git clone --mirror https://lore.kernel.org/wireguard/0 wireguard/git/0.git

	# If you have public-inbox 1.1+ installed, you may
	# initialize and index your mirror using the following commands:
	public-inbox-init -V2 wireguard wireguard/ https://lore.kernel.org/wireguard \
		wireguard@lists.zx2c4.com zx2c4-wireguard@archiver.kernel.org
	public-inbox-index wireguard


Newsgroup available over NNTP:
	nntp://nntp.lore.kernel.org/com.zx2c4.lists.wireguard


AGPL code for this site: git clone https://public-inbox.org/ public-inbox