xen-devel.lists.xenproject.org archive mirror
 help / color / mirror / Atom feed
* [PATCH v2 1/2] libxc: move migration_stream's definition to xenguest.h
@ 2016-03-09  8:46 Wen Congyang
  2016-03-09  8:46 ` [PATCH v2 2/2] tools: change checkpointed_stream's type from int to xc_migration_stream_t Wen Congyang
  2016-03-10 17:28 ` [PATCH v2 1/2] libxc: move migration_stream's definition to xenguest.h Wei Liu
  0 siblings, 2 replies; 5+ messages in thread
From: Wen Congyang @ 2016-03-09  8:46 UTC (permalink / raw)
  To: xen devel, Andrew Cooper, Wei Liu; +Cc: Ian Jackson, Ian Campbell, Wen Congyang

xc_domain_save() and xc_domain_restore's parameter will use this type,
so it should be public.

Signed-off-by: Wen Congyang <wency@cn.fujitsu.com>
---
 tools/libxc/include/xenguest.h |  5 +++++
 tools/libxc/xc_sr_common.h     | 10 ----------
 2 files changed, 5 insertions(+), 10 deletions(-)

diff --git a/tools/libxc/include/xenguest.h b/tools/libxc/include/xenguest.h
index affc42b..973e5a6 100644
--- a/tools/libxc/include/xenguest.h
+++ b/tools/libxc/include/xenguest.h
@@ -75,6 +75,11 @@ struct save_callbacks {
     void* data;
 };
 
+typedef enum {
+    MIG_STREAM_NONE, /* plain stream */
+    MIG_STREAM_REMUS,
+} xc_migration_stream_t;
+
 /**
  * This function will save a running domain.
  *
diff --git a/tools/libxc/xc_sr_common.h b/tools/libxc/xc_sr_common.h
index 66f595f..e7568b5 100644
--- a/tools/libxc/xc_sr_common.h
+++ b/tools/libxc/xc_sr_common.h
@@ -180,16 +180,6 @@ struct xc_sr_context
 
     xc_dominfo_t dominfo;
 
-    /*
-     * migration stream
-     * 0: Plain VM
-     * 1: Remus
-     */
-    enum {
-        MIG_STREAM_NONE, /* plain stream */
-        MIG_STREAM_REMUS,
-    } migration_stream;
-
     union /* Common save or restore data. */
     {
         struct /* Save data. */
-- 
2.5.0




_______________________________________________
Xen-devel mailing list
Xen-devel@lists.xen.org
http://lists.xen.org/xen-devel

^ permalink raw reply related	[flat|nested] 5+ messages in thread

* [PATCH v2 2/2] tools: change checkpointed_stream's type from int to xc_migration_stream_t
  2016-03-09  8:46 [PATCH v2 1/2] libxc: move migration_stream's definition to xenguest.h Wen Congyang
@ 2016-03-09  8:46 ` Wen Congyang
  2016-03-10 17:28   ` Wei Liu
  2016-03-10 17:46   ` Andrew Cooper
  2016-03-10 17:28 ` [PATCH v2 1/2] libxc: move migration_stream's definition to xenguest.h Wei Liu
  1 sibling, 2 replies; 5+ messages in thread
From: Wen Congyang @ 2016-03-09  8:46 UTC (permalink / raw)
  To: xen devel, Andrew Cooper, Wei Liu; +Cc: Ian Jackson, Ian Campbell, Wen Congyang

Signed-off-by: Wen Congyang <wency@cn.fujitsu.com>
---
 tools/libxc/include/xenguest.h  |  4 ++--
 tools/libxc/xc_nomigrate.c      |  4 ++--
 tools/libxc/xc_sr_restore.c     |  2 +-
 tools/libxc/xc_sr_save.c        |  2 +-
 tools/libxl/libxl_save_helper.c | 38 +++++++++++++++++++-------------------
 5 files changed, 25 insertions(+), 25 deletions(-)

diff --git a/tools/libxc/include/xenguest.h b/tools/libxc/include/xenguest.h
index 973e5a6..029082d 100644
--- a/tools/libxc/include/xenguest.h
+++ b/tools/libxc/include/xenguest.h
@@ -93,7 +93,7 @@ typedef enum {
 int xc_domain_save(xc_interface *xch, int io_fd, uint32_t dom, uint32_t max_iters,
                    uint32_t max_factor, uint32_t flags /* XCFLAGS_xxx */,
                    struct save_callbacks* callbacks, int hvm,
-                   int checkpointed_stream);
+                   xc_migration_stream_t checkpointed_stream);
 
 /* callbacks provided by xc_domain_restore */
 struct restore_callbacks {
@@ -131,7 +131,7 @@ int xc_domain_restore(xc_interface *xch, int io_fd, uint32_t dom,
                       domid_t store_domid, unsigned int console_evtchn,
                       unsigned long *console_mfn, domid_t console_domid,
                       unsigned int hvm, unsigned int pae, int superpages,
-                      int checkpointed_stream,
+                      xc_migration_stream_t checkpointed_stream,
                       struct restore_callbacks *callbacks);
 
 /**
diff --git a/tools/libxc/xc_nomigrate.c b/tools/libxc/xc_nomigrate.c
index c9124df..77db59c 100644
--- a/tools/libxc/xc_nomigrate.c
+++ b/tools/libxc/xc_nomigrate.c
@@ -23,7 +23,7 @@
 int xc_domain_save(xc_interface *xch, int io_fd, uint32_t dom, uint32_t max_iters,
                    uint32_t max_factor, uint32_t flags,
                    struct save_callbacks* callbacks, int hvm,
-                   int checkpointed_stream)
+                   xc_migration_stream_t checkpointed_stream)
 {
     errno = ENOSYS;
     return -1;
@@ -34,7 +34,7 @@ int xc_domain_restore(xc_interface *xch, int io_fd, uint32_t dom,
                       domid_t store_domid, unsigned int console_evtchn,
                       unsigned long *console_mfn, domid_t console_domid,
                       unsigned int hvm, unsigned int pae, int superpages,
-                      int checkpointed_stream,
+                      xc_migration_stream_t checkpointed_stream,
                       struct restore_callbacks *callbacks)
 {
     errno = ENOSYS;
diff --git a/tools/libxc/xc_sr_restore.c b/tools/libxc/xc_sr_restore.c
index d4d33fd..b2a3558 100644
--- a/tools/libxc/xc_sr_restore.c
+++ b/tools/libxc/xc_sr_restore.c
@@ -725,7 +725,7 @@ int xc_domain_restore(xc_interface *xch, int io_fd, uint32_t dom,
                       domid_t store_domid, unsigned int console_evtchn,
                       unsigned long *console_gfn, domid_t console_domid,
                       unsigned int hvm, unsigned int pae, int superpages,
-                      int checkpointed_stream,
+                      xc_migration_stream_t checkpointed_stream,
                       struct restore_callbacks *callbacks)
 {
     struct xc_sr_context ctx =
diff --git a/tools/libxc/xc_sr_save.c b/tools/libxc/xc_sr_save.c
index e258b7c..fc51f60 100644
--- a/tools/libxc/xc_sr_save.c
+++ b/tools/libxc/xc_sr_save.c
@@ -830,7 +830,7 @@ static int save(struct xc_sr_context *ctx, uint16_t guest_type)
 int xc_domain_save(xc_interface *xch, int io_fd, uint32_t dom,
                    uint32_t max_iters, uint32_t max_factor, uint32_t flags,
                    struct save_callbacks* callbacks, int hvm,
-                   int checkpointed_stream)
+                   xc_migration_stream_t checkpointed_stream)
 {
     struct xc_sr_context ctx =
         {
diff --git a/tools/libxl/libxl_save_helper.c b/tools/libxl/libxl_save_helper.c
index 6bdcf13..5503311 100644
--- a/tools/libxl/libxl_save_helper.c
+++ b/tools/libxl/libxl_save_helper.c
@@ -246,14 +246,14 @@ int main(int argc, char **argv)
 
     if (!strcmp(mode,"--save-domain")) {
 
-        io_fd =                    atoi(NEXTARG);
-        uint32_t dom =             strtoul(NEXTARG,0,10);
-        uint32_t max_iters =       strtoul(NEXTARG,0,10);
-        uint32_t max_factor =      strtoul(NEXTARG,0,10);
-        uint32_t flags =           strtoul(NEXTARG,0,10);
-        int hvm =                  atoi(NEXTARG);
-        unsigned cbflags =         strtoul(NEXTARG,0,10);
-        int checkpointed_stream =  strtoul(NEXTARG,0,10);
+        io_fd =                                     atoi(NEXTARG);
+        uint32_t dom =                              strtoul(NEXTARG,0,10);
+        uint32_t max_iters =                        strtoul(NEXTARG,0,10);
+        uint32_t max_factor =                       strtoul(NEXTARG,0,10);
+        uint32_t flags =                            strtoul(NEXTARG,0,10);
+        int hvm =                                   atoi(NEXTARG);
+        unsigned cbflags =                          strtoul(NEXTARG,0,10);
+        xc_migration_stream_t checkpointed_stream = strtoul(NEXTARG,0,10);
         assert(!*++argv);
 
         helper_setcallbacks_save(&helper_save_callbacks, cbflags);
@@ -267,17 +267,17 @@ int main(int argc, char **argv)
 
     } else if (!strcmp(mode,"--restore-domain")) {
 
-        io_fd =                    atoi(NEXTARG);
-        uint32_t dom =             strtoul(NEXTARG,0,10);
-        unsigned store_evtchn =    strtoul(NEXTARG,0,10);
-        domid_t store_domid =      strtoul(NEXTARG,0,10);
-        unsigned console_evtchn =  strtoul(NEXTARG,0,10);
-        domid_t console_domid =    strtoul(NEXTARG,0,10);
-        unsigned int hvm =         strtoul(NEXTARG,0,10);
-        unsigned int pae =         strtoul(NEXTARG,0,10);
-        int superpages =           strtoul(NEXTARG,0,10);
-        unsigned cbflags =         strtoul(NEXTARG,0,10);
-        int checkpointed =         strtoul(NEXTARG,0,10);
+        io_fd =                                 atoi(NEXTARG);
+        uint32_t dom =                          strtoul(NEXTARG,0,10);
+        unsigned store_evtchn =                 strtoul(NEXTARG,0,10);
+        domid_t store_domid =                   strtoul(NEXTARG,0,10);
+        unsigned console_evtchn =               strtoul(NEXTARG,0,10);
+        domid_t console_domid =                 strtoul(NEXTARG,0,10);
+        unsigned int hvm =                      strtoul(NEXTARG,0,10);
+        unsigned int pae =                      strtoul(NEXTARG,0,10);
+        int superpages =                        strtoul(NEXTARG,0,10);
+        unsigned cbflags =                      strtoul(NEXTARG,0,10);
+        xc_migration_stream_t checkpointed =    strtoul(NEXTARG,0,10);
         assert(!*++argv);
 
         helper_setcallbacks_restore(&helper_restore_callbacks, cbflags);
-- 
2.5.0




_______________________________________________
Xen-devel mailing list
Xen-devel@lists.xen.org
http://lists.xen.org/xen-devel

^ permalink raw reply related	[flat|nested] 5+ messages in thread

* Re: [PATCH v2 1/2] libxc: move migration_stream's definition to xenguest.h
  2016-03-09  8:46 [PATCH v2 1/2] libxc: move migration_stream's definition to xenguest.h Wen Congyang
  2016-03-09  8:46 ` [PATCH v2 2/2] tools: change checkpointed_stream's type from int to xc_migration_stream_t Wen Congyang
@ 2016-03-10 17:28 ` Wei Liu
  1 sibling, 0 replies; 5+ messages in thread
From: Wei Liu @ 2016-03-10 17:28 UTC (permalink / raw)
  To: Wen Congyang; +Cc: Ian Jackson, Andrew Cooper, Wei Liu, Ian Campbell, xen devel

On Wed, Mar 09, 2016 at 04:46:36PM +0800, Wen Congyang wrote:
> xc_domain_save() and xc_domain_restore's parameter will use this type,
> so it should be public.
> 
> Signed-off-by: Wen Congyang <wency@cn.fujitsu.com>
> ---
>  tools/libxc/include/xenguest.h |  5 +++++
>  tools/libxc/xc_sr_common.h     | 10 ----------
>  2 files changed, 5 insertions(+), 10 deletions(-)
> 
> diff --git a/tools/libxc/include/xenguest.h b/tools/libxc/include/xenguest.h
> index affc42b..973e5a6 100644
> --- a/tools/libxc/include/xenguest.h
> +++ b/tools/libxc/include/xenguest.h
> @@ -75,6 +75,11 @@ struct save_callbacks {
>      void* data;
>  };
>  
> +typedef enum {
> +    MIG_STREAM_NONE, /* plain stream */
> +    MIG_STREAM_REMUS,

You also need to make them have XC_ prefix.

Wei.

_______________________________________________
Xen-devel mailing list
Xen-devel@lists.xen.org
http://lists.xen.org/xen-devel

^ permalink raw reply	[flat|nested] 5+ messages in thread

* Re: [PATCH v2 2/2] tools: change checkpointed_stream's type from int to xc_migration_stream_t
  2016-03-09  8:46 ` [PATCH v2 2/2] tools: change checkpointed_stream's type from int to xc_migration_stream_t Wen Congyang
@ 2016-03-10 17:28   ` Wei Liu
  2016-03-10 17:46   ` Andrew Cooper
  1 sibling, 0 replies; 5+ messages in thread
From: Wei Liu @ 2016-03-10 17:28 UTC (permalink / raw)
  To: Wen Congyang; +Cc: Ian Jackson, Andrew Cooper, Wei Liu, Ian Campbell, xen devel

On Wed, Mar 09, 2016 at 04:46:37PM +0800, Wen Congyang wrote:
> Signed-off-by: Wen Congyang <wency@cn.fujitsu.com>

Acked-by: Wei Liu <wei.liu2@citrix.com>

_______________________________________________
Xen-devel mailing list
Xen-devel@lists.xen.org
http://lists.xen.org/xen-devel

^ permalink raw reply	[flat|nested] 5+ messages in thread

* Re: [PATCH v2 2/2] tools: change checkpointed_stream's type from int to xc_migration_stream_t
  2016-03-09  8:46 ` [PATCH v2 2/2] tools: change checkpointed_stream's type from int to xc_migration_stream_t Wen Congyang
  2016-03-10 17:28   ` Wei Liu
@ 2016-03-10 17:46   ` Andrew Cooper
  1 sibling, 0 replies; 5+ messages in thread
From: Andrew Cooper @ 2016-03-10 17:46 UTC (permalink / raw)
  To: Wen Congyang, xen devel, Wei Liu; +Cc: Ian Jackson, Ian Campbell

On 09/03/16 08:46, Wen Congyang wrote:
> Signed-off-by: Wen Congyang <wency@cn.fujitsu.com>
> ---
>  tools/libxc/include/xenguest.h  |  4 ++--
>  tools/libxc/xc_nomigrate.c      |  4 ++--
>  tools/libxc/xc_sr_restore.c     |  2 +-
>  tools/libxc/xc_sr_save.c        |  2 +-
>  tools/libxl/libxl_save_helper.c | 38 +++++++++++++++++++-------------------
>  5 files changed, 25 insertions(+), 25 deletions(-)
>
> diff --git a/tools/libxc/include/xenguest.h b/tools/libxc/include/xenguest.h
> index 973e5a6..029082d 100644
> --- a/tools/libxc/include/xenguest.h
> +++ b/tools/libxc/include/xenguest.h
> @@ -93,7 +93,7 @@ typedef enum {
>  int xc_domain_save(xc_interface *xch, int io_fd, uint32_t dom, uint32_t max_iters,
>                     uint32_t max_factor, uint32_t flags /* XCFLAGS_xxx */,
>                     struct save_callbacks* callbacks, int hvm,
> -                   int checkpointed_stream);
> +                   xc_migration_stream_t checkpointed_stream);

s/checkpointed_stream/stream_type/

~Andrew

_______________________________________________
Xen-devel mailing list
Xen-devel@lists.xen.org
http://lists.xen.org/xen-devel

^ permalink raw reply	[flat|nested] 5+ messages in thread

end of thread, other threads:[~2016-03-10 17:46 UTC | newest]

Thread overview: 5+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2016-03-09  8:46 [PATCH v2 1/2] libxc: move migration_stream's definition to xenguest.h Wen Congyang
2016-03-09  8:46 ` [PATCH v2 2/2] tools: change checkpointed_stream's type from int to xc_migration_stream_t Wen Congyang
2016-03-10 17:28   ` Wei Liu
2016-03-10 17:46   ` Andrew Cooper
2016-03-10 17:28 ` [PATCH v2 1/2] libxc: move migration_stream's definition to xenguest.h Wei Liu

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).