xen-devel.lists.xenproject.org archive mirror
 help / color / mirror / Atom feed
From: Konrad Rzeszutek Wilk <konrad.wilk@oracle.com>
To: Jan Beulich <JBeulich@suse.com>, boris.ostrovsky@oracle.com
Cc: Wei Liu <wei.liu2@citrix.com>,
	Stefano Stabellini <stefano.stabellini@eu.citrix.com>,
	Ian Jackson <ian.jackson@eu.citrix.com>,
	xen-devel@lists.xen.org,
	Anthony PERARD <anthony.perard@citrix.com>,
	Roger Pau Monne <roger.pau@citrix.com>
Subject: Re: [PATCH v4 06/14] xen: Move the hvm_start_info C representation from libxc to public/xen.h
Date: Tue, 15 Mar 2016 21:00:40 -0400	[thread overview]
Message-ID: <20160316010040.GD29696@char.us.oracle.com> (raw)
In-Reply-To: <20160316005954.GC29696@char.us.oracle.com>

On Tue, Mar 15, 2016 at 08:59:54PM -0400, Konrad Rzeszutek Wilk wrote:
> On Tue, Mar 15, 2016 at 02:09:46AM -0600, Jan Beulich wrote:

Adding  Boris to the To:
> > >>> On 14.03.16 at 18:55, <anthony.perard@citrix.com> wrote:
> > > --- a/xen/include/public/xen.h
> > > +++ b/xen/include/public/xen.h
> > > @@ -841,6 +841,37 @@ typedef struct start_info start_info_t;
> > >   */
> > >  #define XEN_HVM_START_MAGIC_VALUE 0x336ec578
> > >  
> > > +#if defined(__i386__) || defined(__x86_64__)
> > > +/* C representation of the x86/HVM start info layout.
> > > + *
> > > + * The canonical definition of this layout is abrove, this is just a way to
> > > + * represent the layout described there using C types.
> > > + *
> > > + * NB: the packed attribute is not really needed, but it helps us enforce
> > > + * the fact this this is just a representation, and it might indeed
> > > + * be required in the future if there are alignment changes.
> > > + */
> > > +struct hvm_start_info {
> > > +    uint32_t magic;             /* Contains the magic value 0x336ec578       */
> > > +                                /* ("xEn3" with the 0x80 bit of the "E" set).*/
> > > +    uint32_t version;           /* Version of this structure.                */
> > > +    uint32_t flags;             /* SIF_xxx flags.                            */
> > > +    uint32_t cmdline_paddr;     /* Physical address of the command line.     */
> > > +    uint32_t nr_modules;        /* Number of modules passed to the kernel.   */
> > > +    uint32_t modlist_paddr;     /* Physical address of an array of           */
> > > +                                /* hvm_modlist_entry.                        */
> > > +    uint32_t rsdp_paddr;        /* Physical address of the RSDP ACPI data    */
> > > +                                /* structure.                                */
> > > +} __attribute__((packed));
> > > +
> > > +struct hvm_modlist_entry {
> > > +    uint64_t paddr;             /* Physical address of the module.           */
> > > +    uint64_t size;              /* Size of the module in bytes.              */
> > > +    uint64_t cmdline_paddr;     /* Physical address of the command line.     */
> > > +    uint64_t reserved;
> > > +} __attribute__((packed));
> > > +#endif /* x86 */
> > 
> > This needs extra care: Either the packed attributes need to be
> > dropped (Roger - why did they get put there in the first place?),
> 
> Presumarily b/c on 32-bit and 64-bit the size of the structure would
> be different otherwise...
> 
> > or their use needs to be shielded from compilers not understanding
> > them.
> 
> .. which begs the question - How come we didn't make the structure 64-bit nice?
> As in add another uint32_t to it? And then we can ditch the packed?
> 
> 
> 
> > 
> > Jan
> > 
> > 
> > _______________________________________________
> > Xen-devel mailing list
> > Xen-devel@lists.xen.org
> > http://lists.xen.org/xen-devel

_______________________________________________
Xen-devel mailing list
Xen-devel@lists.xen.org
http://lists.xen.org/xen-devel

  reply	other threads:[~2016-03-16  1:00 UTC|newest]

Thread overview: 73+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2016-03-14 17:55 [PATCH v4 00/14] Load BIOS via toolstack instead of been embedded in hvmloader Anthony PERARD
2016-03-14 17:55 ` [PATCH v4 01/14] libxc: Rework extra module initialisation Anthony PERARD
2016-03-16  0:06   ` Konrad Rzeszutek Wilk
2016-03-17 16:24     ` Anthony PERARD
2016-03-14 17:55 ` [PATCH v4 02/14] libxc: Prepare a start info structure for hvmloader Anthony PERARD
2016-03-16  0:18   ` Konrad Rzeszutek Wilk
2016-03-16 18:01     ` Boris Ostrovsky
2016-03-17 16:48       ` Anthony PERARD
2016-03-17 16:28     ` Anthony PERARD
2016-03-14 17:55 ` [PATCH v4 03/14] configure: #define SEABIOS_PATH and OVMF_PATH Anthony PERARD
2016-03-16  0:20   ` Konrad Rzeszutek Wilk
2016-04-08 13:38   ` Wei Liu
2016-03-14 17:55 ` [PATCH v4 04/14] firmware/makefile: install BIOS blob Anthony PERARD
2016-03-16  0:26   ` Konrad Rzeszutek Wilk
2016-03-16  8:54     ` Dario Faggioli
2016-03-16  8:56       ` Konrad Rzeszutek Wilk
2016-03-17 16:58     ` Anthony PERARD
2016-03-17 17:37   ` Doug Goldstein
2016-03-17 18:33     ` Anthony PERARD
2016-03-18 21:11       ` Jim Fehlig
2016-03-19  0:43       ` Doug Goldstein
2016-04-18 14:31   ` Doug Goldstein
2016-04-19 13:11     ` Stefano Stabellini
2016-03-14 17:55 ` [PATCH v4 05/14] libxl: Load guest BIOS from file Anthony PERARD
2016-03-16  0:53   ` Konrad Rzeszutek Wilk
2016-03-16  9:27     ` Dario Faggioli
2016-03-17 17:24       ` Anthony PERARD
2016-03-14 17:55 ` [PATCH v4 06/14] xen: Move the hvm_start_info C representation from libxc to public/xen.h Anthony PERARD
2016-03-15  8:09   ` Jan Beulich
2016-03-16  0:59     ` Konrad Rzeszutek Wilk
2016-03-16  1:00       ` Konrad Rzeszutek Wilk [this message]
2016-03-16  8:32       ` Jan Beulich
2016-03-21 17:04     ` Roger Pau Monné
2016-03-21 17:21       ` Jan Beulich
2016-03-14 17:55 ` [PATCH v4 07/14] hvmloader: Grab the hvm_start_info pointer Anthony PERARD
2016-03-16  1:07   ` Konrad Rzeszutek Wilk
2016-04-05 12:43   ` Jan Beulich
2016-03-14 17:55 ` [PATCH v4 08/14] hvmloader: Locate the BIOS blob Anthony PERARD
2016-03-16  1:14   ` Konrad Rzeszutek Wilk
2016-03-17 17:46     ` Anthony PERARD
2016-03-17 17:57       ` Konrad Rzeszutek Wilk
2016-03-18  7:34       ` Jan Beulich
2016-04-05 12:59   ` Jan Beulich
2016-04-05 14:05     ` Roger Pau Monné
2016-04-05 14:23       ` Jan Beulich
2016-04-07 15:10     ` Anthony PERARD
2016-04-07 15:30       ` Jan Beulich
2016-03-14 17:55 ` [PATCH v4 09/14] hvmloader: Check modules whereabouts in perform_tests Anthony PERARD
2016-03-16  1:23   ` Konrad Rzeszutek Wilk
2016-03-17 18:08     ` Anthony PERARD
2016-04-05 13:07   ` Jan Beulich
2016-03-14 17:55 ` [PATCH v4 10/14] hvmloader: Load SeaBIOS from hvm_start_info modules Anthony PERARD
2016-03-16  1:27   ` Konrad Rzeszutek Wilk
2016-03-16  1:27     ` Konrad Rzeszutek Wilk
2016-04-05 13:11   ` Jan Beulich
2016-03-14 17:55 ` [PATCH v4 11/14] hvmloader: Load OVMF from modules Anthony PERARD
2016-03-16  1:36   ` Konrad Rzeszutek Wilk
2016-04-05 13:16   ` Jan Beulich
2016-03-14 17:55 ` [PATCH v4 12/14] hvmloader: Specific bios_load function required Anthony PERARD
2016-03-16  1:38   ` Konrad Rzeszutek Wilk
2016-03-17 18:25     ` Anthony PERARD
2016-03-14 17:55 ` [PATCH v4 13/14] hvmloader: Always build-in SeaBIOS and OVMF loader Anthony PERARD
2016-03-14 17:55 ` [PATCH v4 14/14] configure: do not depend on SEABIOS_PATH or OVMF_PATH Anthony PERARD
2016-03-16  1:40   ` Konrad Rzeszutek Wilk
2016-04-08 13:38   ` Wei Liu
2016-03-24 17:55 ` [PATCH v4 00/14] Load BIOS via toolstack instead of been embedded in hvmloader Jim Fehlig
2016-03-30 17:22 ` Jim Fehlig
2016-03-31  7:20   ` Jan Beulich
     [not found]   ` <56FCEBCD02000078000E19BF@suse.com>
2016-03-31 14:36     ` Jim Fehlig
2016-03-31 16:49       ` George Dunlap
2016-04-01  9:12         ` George Dunlap
2016-04-01 14:24           ` Konrad Rzeszutek Wilk
2016-04-01 20:06           ` Jim Fehlig

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20160316010040.GD29696@char.us.oracle.com \
    --to=konrad.wilk@oracle.com \
    --cc=JBeulich@suse.com \
    --cc=anthony.perard@citrix.com \
    --cc=boris.ostrovsky@oracle.com \
    --cc=ian.jackson@eu.citrix.com \
    --cc=roger.pau@citrix.com \
    --cc=stefano.stabellini@eu.citrix.com \
    --cc=wei.liu2@citrix.com \
    --cc=xen-devel@lists.xen.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).