xen-devel.lists.xenproject.org archive mirror
 help / color / mirror / Atom feed
* [PATCH v2 0/3] xen/x86: support setting dom0_mem depending on host size
@ 2018-12-06  8:06 Juergen Gross
  2018-12-06  8:06 ` [PATCH v2 1/3] xen: introduce parse_size_and_unit_or_int Juergen Gross
                   ` (2 more replies)
  0 siblings, 3 replies; 12+ messages in thread
From: Juergen Gross @ 2018-12-06  8:06 UTC (permalink / raw)
  To: xen-devel
  Cc: Juergen Gross, Stefano Stabellini, Wei Liu,
	Konrad Rzeszutek Wilk, George Dunlap, Andrew Cooper, Ian Jackson,
	Tim Deegan, Julien Grall, Jan Beulich, Roger Pau Monné

Setting the memory size of dom0 on a server for the non autoballooning
case requires always specification of a boot parameter today. The value
to set will depend mostly on the host memory size.

In order to support that scenario add the possibility to set dom0_mem
depending on the amount of physical memory by allowing to specify a
percentage of host memory (e.g. 10%) with an offset (like 1G+10%).

To make it easy for a distributor to use such a setting as the default
make the standard setting for dom0_mem configurable via Kconfig.

Changes since V1:
- replaced old patch 1 by new one
- rewritten patch 2 according to remarks by Jan Beulich
- changed patch 3 to allow config item on arm, too

Juergen Gross (3):
  xen: introduce parse_size_and_unit_or_int
  xen/x86: add dom0 memory sizing variants
  xen: add CONFIG item for default dom0 memory size

 docs/misc/xen-command-line.markdown |  19 ++++--
 xen/arch/arm/domain_build.c         |   7 +++
 xen/arch/x86/dom0_build.c           | 112 +++++++++++++++++++++++++++---------
 xen/common/Kconfig                  |  13 +++++
 xen/common/lib.c                    |  11 +++-
 xen/include/xen/lib.h               |   2 +
 6 files changed, 130 insertions(+), 34 deletions(-)

-- 
2.16.4


_______________________________________________
Xen-devel mailing list
Xen-devel@lists.xenproject.org
https://lists.xenproject.org/mailman/listinfo/xen-devel

^ permalink raw reply	[flat|nested] 12+ messages in thread
* Re: [PATCH v2 1/3] xen: introduce parse_size_and_unit_or_int
@ 2018-12-06 10:19 Juergen Gross
  0 siblings, 0 replies; 12+ messages in thread
From: Juergen Gross @ 2018-12-06 10:19 UTC (permalink / raw)
  To: Jan Beulich
  Cc: Stefano Stabellini, Wei Liu, Konrad Rzeszutek Wilk,
	George Dunlap, Andrew Cooper, Ian Jackson, Tim Deegan,
	Julien Grall, xen-devel

On 06/12/2018 11:15, Jan Beulich wrote:
>>>> On 06.12.18 at 11:01, <jgross@suse.com> wrote:
>> On 06/12/2018 10:50, Jan Beulich wrote:
>>>>>> On 06.12.18 at 09:06, <jgross@suse.com> wrote:
>>>> @@ -477,7 +478,8 @@ unsigned long long parse_size_and_unit(const char *s, 
>> const char **ps)
>>>>          s1++;
>>>>          break;
>>>>      default:
>>>> -        ret <<= 10; /* default to kB */
>>>> +        if ( *s1 && *s1 != no_size )
>>>> +            ret <<= 10; /* default to kB */
>>>>          break;
>>>
>>> So did you figure anything wrong with simply special casing '%'
>>> here? '%' is a form of "unit", after all. Perhaps demanding "ps"
>>> to be non-NULL (to have some form of indication the caller will
>>> check the suffix char) might be reasonable.
>>
>> I thought a more general approach would be better. I can use the simple
>> '%' special case with the ps check in case you prefer that.
> 
> I'd indeed prefer that, first and foremost because that other
> function's name becomes too long for my taste, but give others
> a chance to voice differing opinions.

In case the function name is your main concern I could rename it to
parse_size_or_int() or similar.

I'm fine either way, so lets wait for some days and act then according
to the comments.


Juergen

_______________________________________________
Xen-devel mailing list
Xen-devel@lists.xenproject.org
https://lists.xenproject.org/mailman/listinfo/xen-devel

^ permalink raw reply	[flat|nested] 12+ messages in thread

end of thread, other threads:[~2018-12-06 11:28 UTC | newest]

Thread overview: 12+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2018-12-06  8:06 [PATCH v2 0/3] xen/x86: support setting dom0_mem depending on host size Juergen Gross
2018-12-06  8:06 ` [PATCH v2 1/3] xen: introduce parse_size_and_unit_or_int Juergen Gross
2018-12-06  9:50   ` Jan Beulich
     [not found]   ` <5C08F0CE0200007800203751@suse.com>
2018-12-06 10:01     ` Juergen Gross
2018-12-06 10:15       ` Jan Beulich
2018-12-06  8:06 ` [PATCH v2 2/3] xen/x86: add dom0 memory sizing variants Juergen Gross
2018-12-06 11:08   ` Jan Beulich
     [not found]   ` <5C09031502000078002039F0@suse.com>
2018-12-06 11:20     ` Juergen Gross
2018-12-06 11:28       ` Jan Beulich
2018-12-06  8:06 ` [PATCH v2 3/3] xen: add CONFIG item for default dom0 memory size Juergen Gross
2018-12-06 11:09   ` Jan Beulich
2018-12-06 10:19 [PATCH v2 1/3] xen: introduce parse_size_and_unit_or_int Juergen Gross

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).