xen-devel.lists.xenproject.org archive mirror
 help / color / mirror / Atom feed
From: Oleksandr Andrushchenko <Oleksandr_Andrushchenko@epam.com>
To: Paul Durrant <paul@xen.org>,
	"xen-devel@lists.xenproject.org" <xen-devel@lists.xenproject.org>
Cc: Paul Durrant <pdurrant@amazon.com>,
	Ian Jackson <iwj@xenproject.org>, Wei Liu <wl@xen.org>
Subject: Re: [PATCH v4 13/23] libxl: use COMPARE_PCI() macro is_pci_in_array()...
Date: Tue, 1 Dec 2020 15:20:26 +0000	[thread overview]
Message-ID: <7951d30a-006e-2c42-2373-117decfe4508@epam.com> (raw)
In-Reply-To: <20201124080159.11912-14-paul@xen.org>

Hi, Paul!

On 11/24/20 10:01 AM, Paul Durrant wrote:
> From: Paul Durrant <pdurrant@amazon.com>
>
> ... rather than an open-coded equivalent.
>
> This patch tidies up the is_pci_in_array() function, making it take a single
> 'libxl_device_pci' argument rather than separate domain, bus, device and
> function arguments. The already-available COMPARE_PCI() macro can then be
> used and it is also modified to return 'bool' rather than 'int'.
>
> The patch also modifies libxl_pci_assignable() to use is_pci_in_array() rather
> than a separate open-coded equivalent, and also modifies it to return a
> 'bool' rather than an 'int'.
>
> NOTE: The COMPARE_PCI() macro is also fixed to include the 'domain' in its
>        comparison, which should always have been the case.
>
> Signed-off-by: Paul Durrant <pdurrant@amazon.com>
Reviewed-by: Oleksandr Andrushchenko <oleksandr_andrushchenko@epam.com>

Thank you,

Oleksandr

> ---
> Cc: Ian Jackson <iwj@xenproject.org>
> Cc: Wei Liu <wl@xen.org>
> ---
>   tools/libs/light/libxl_internal.h |  7 ++++---
>   tools/libs/light/libxl_pci.c      | 38 +++++++++++++-------------------------
>   2 files changed, 17 insertions(+), 28 deletions(-)
>
> diff --git a/tools/libs/light/libxl_internal.h b/tools/libs/light/libxl_internal.h
> index ecee61b541..02f8a3179c 100644
> --- a/tools/libs/light/libxl_internal.h
> +++ b/tools/libs/light/libxl_internal.h
> @@ -4746,9 +4746,10 @@ void libxl__xcinfo2xlinfo(libxl_ctx *ctx,
>    * devices have same identifier. */
>   #define COMPARE_DEVID(a, b) ((a)->devid == (b)->devid)
>   #define COMPARE_DISK(a, b) (!strcmp((a)->vdev, (b)->vdev))
> -#define COMPARE_PCI(a, b) ((a)->func == (b)->func &&    \
> -                           (a)->bus == (b)->bus &&      \
> -                           (a)->dev == (b)->dev)
> +#define COMPARE_PCI(a, b) ((a)->domain == (b)->domain && \
> +                           (a)->bus == (b)->bus &&       \
> +                           (a)->dev == (b)->dev &&       \
> +                           (a)->func == (b)->func)
>   #define COMPARE_USB(a, b) ((a)->ctrl == (b)->ctrl && \
>                              (a)->port == (b)->port)
>   #define COMPARE_USBCTRL(a, b) ((a)->devid == (b)->devid)
> diff --git a/tools/libs/light/libxl_pci.c b/tools/libs/light/libxl_pci.c
> index 5a3352c2ec..e0b616fe18 100644
> --- a/tools/libs/light/libxl_pci.c
> +++ b/tools/libs/light/libxl_pci.c
> @@ -336,24 +336,17 @@ retry_transaction2:
>       return 0;
>   }
>   
> -static int is_pci_in_array(libxl_device_pci *assigned, int num_assigned,
> -                           int dom, int bus, int dev, int func)
> +static bool is_pci_in_array(libxl_device_pci *pcis, int num,
> +                            libxl_device_pci *pci)
>   {
>       int i;
>   
> -    for(i = 0; i < num_assigned; i++) {
> -        if ( assigned[i].domain != dom )
> -            continue;
> -        if ( assigned[i].bus != bus )
> -            continue;
> -        if ( assigned[i].dev != dev )
> -            continue;
> -        if ( assigned[i].func != func )
> -            continue;
> -        return 1;
> +    for (i = 0; i < num; i++) {
> +        if (COMPARE_PCI(pci, &pcis[i]))
> +            break;
>       }
>   
> -    return 0;
> +    return i < num;
>   }
>   
>   /* Write the standard BDF into the sysfs path given by sysfs_path. */
> @@ -1487,21 +1480,17 @@ int libxl_device_pci_add(libxl_ctx *ctx, uint32_t domid,
>       return AO_INPROGRESS;
>   }
>   
> -static int libxl_pci_assignable(libxl_ctx *ctx, libxl_device_pci *pci)
> +static bool libxl_pci_assignable(libxl_ctx *ctx, libxl_device_pci *pci)
>   {
>       libxl_device_pci *pcis;
> -    int num, i;
> +    int num;
> +    bool assignable;
>   
>       pcis = libxl_device_pci_assignable_list(ctx, &num);
> -    for (i = 0; i < num; i++) {
> -        if (pcis[i].domain == pci->domain &&
> -            pcis[i].bus == pci->bus &&
> -            pcis[i].dev == pci->dev &&
> -            pcis[i].func == pci->func)
> -            break;
> -    }
> +    assignable = is_pci_in_array(pcis, num, pci);
>       libxl_device_pci_assignable_list_free(pcis, num);
> -    return i != num;
> +
> +    return assignable;
>   }
>   
>   static void device_pci_add_stubdom_wait(libxl__egc *egc,
> @@ -1834,8 +1823,7 @@ static void do_pci_remove(libxl__egc *egc, pci_remove_state *prs)
>           goto out_fail;
>       }
>   
> -    attached = is_pci_in_array(pcis, num, pci->domain,
> -                               pci->bus, pci->dev, pci->func);
> +    attached = is_pci_in_array(pcis, num, pci);
>       libxl_device_pci_list_free(pcis, num);
>   
>       rc = ERROR_INVAL;

  reply	other threads:[~2020-12-01 15:20 UTC|newest]

Thread overview: 41+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-11-24  8:01 [PATCH v4 00/23] xl / libxl: named PCI pass-through devices Paul Durrant
2020-11-24  8:01 ` [PATCH v4 01/23] xl / libxl: s/pcidev/pci and remove DEFINE_DEVICE_TYPE_STRUCT_X Paul Durrant
2020-12-01 12:32   ` Oleksandr Andrushchenko
2020-12-03 13:00     ` Paul Durrant
2020-11-24  8:01 ` [PATCH v4 02/23] libxl: make libxl__device_list() work correctly for LIBXL__DEVICE_KIND_PCI Paul Durrant
2020-12-01 12:50   ` Oleksandr Andrushchenko
2020-11-24  8:01 ` [PATCH v4 03/23] libxl: Make sure devices added by pci-attach are reflected in the config Paul Durrant
2020-12-01 13:12   ` Oleksandr Andrushchenko
2020-12-03 13:17     ` Paul Durrant
2020-12-03 13:20       ` Oleksandr Andrushchenko
2020-11-24  8:01 ` [PATCH v4 04/23] libxl: add/recover 'rdm_policy' to/from PCI backend in xenstore Paul Durrant
2020-12-01 13:13   ` Oleksandr Andrushchenko
2020-11-24  8:01 ` [PATCH v4 05/23] libxl: s/detatched/detached in libxl_pci.c Paul Durrant
2020-12-01 13:15   ` Oleksandr Andrushchenko
2020-11-24  8:01 ` [PATCH v4 06/23] libxl: remove extraneous arguments to do_pci_remove() " Paul Durrant
2020-12-01 13:41   ` Oleksandr Andrushchenko
2020-11-24  8:01 ` [PATCH v4 07/23] libxl: stop using aodev->device_config in libxl__device_pci_add() Paul Durrant
2020-12-01 13:42   ` Oleksandr Andrushchenko
2020-11-24  8:01 ` [PATCH v4 08/23] libxl: generalise 'driver_path' xenstore access functions in libxl_pci.c Paul Durrant
2020-12-01 13:48   ` Oleksandr Andrushchenko
2020-11-24  8:01 ` [PATCH v4 09/23] libxl: remove unnecessary check from libxl__device_pci_add() Paul Durrant
2020-12-01 13:51   ` Oleksandr Andrushchenko
2020-11-24  8:01 ` [PATCH v4 10/23] libxl: remove get_all_assigned_devices() from libxl_pci.c Paul Durrant
2020-12-01 14:18   ` Oleksandr Andrushchenko
2020-11-24  8:01 ` [PATCH v4 11/23] libxl: make sure callers of libxl_device_pci_list() free the list after use Paul Durrant
2020-12-01 15:10   ` Oleksandr Andrushchenko
2020-11-24  8:01 ` [PATCH v4 12/23] libxl: add libxl_device_pci_assignable_list_free() Paul Durrant
2020-12-01 15:17   ` Oleksandr Andrushchenko
2020-11-24  8:01 ` [PATCH v4 13/23] libxl: use COMPARE_PCI() macro is_pci_in_array() Paul Durrant
2020-12-01 15:20   ` Oleksandr Andrushchenko [this message]
2020-11-24  8:01 ` [PATCH v4 14/23] docs/man: extract documentation of PCI_SPEC_STRING from the xl.cfg manpage Paul Durrant
2020-12-01 15:25   ` Oleksandr Andrushchenko
2020-11-24  8:01 ` [PATCH v4 15/23] docs/man: improve documentation of PCI_SPEC_STRING Paul Durrant
2020-11-24  8:01 ` [PATCH v4 16/23] docs/man: fix xl(1) documentation for 'pci' operations Paul Durrant
2020-11-24  8:01 ` [PATCH v4 17/23] libxl: introduce 'libxl_pci_bdf' in the idl Paul Durrant
2020-11-24  8:01 ` [PATCH v4 18/23] libxlu: introduce xlu_pci_parse_spec_string() Paul Durrant
2020-11-24  8:01 ` [PATCH v4 19/23] libxl: modify libxl_device_pci_assignable_add/remove/list/list_free() Paul Durrant
2020-11-24  8:01 ` [PATCH v4 20/23] docs/man: modify xl(1) in preparation for naming of assignable devices Paul Durrant
2020-11-24  8:01 ` [PATCH v4 21/23] xl / libxl: support " Paul Durrant
2020-11-24  8:01 ` [PATCH v4 22/23] docs/man: modify xl-pci-configuration(5) to add 'name' field to PCI_SPEC_STRING Paul Durrant
2020-11-24  8:01 ` [PATCH v4 23/23] xl / libxl: support 'xl pci-attach/detach' by name Paul Durrant

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=7951d30a-006e-2c42-2373-117decfe4508@epam.com \
    --to=oleksandr_andrushchenko@epam.com \
    --cc=iwj@xenproject.org \
    --cc=paul@xen.org \
    --cc=pdurrant@amazon.com \
    --cc=wl@xen.org \
    --cc=xen-devel@lists.xenproject.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).