xen-devel.lists.xenproject.org archive mirror
 help / color / mirror / Atom feed
From: Tamas K Lengyel <tamas@tklengyel.com>
To: Corneliu ZUZU <czuzu@bitdefender.com>
Cc: Razvan Cojocaru <rcojocaru@bitdefender.com>,
	George Dunlap <george.dunlap@eu.citrix.com>,
	Andrew Cooper <andrew.cooper3@citrix.com>,
	Xen-devel <xen-devel@lists.xen.org>,
	Paul Durrant <paul.durrant@citrix.com>,
	Jan Beulich <jbeulich@suse.com>
Subject: Re: [PATCH 14/16] x86/monitor: clarify separation between monitor subsys and vm-event as a whole
Date: Wed, 13 Jul 2016 12:56:27 -0600	[thread overview]
Message-ID: <CABfawhnMZit6mQUbLT-OHcq2hws+XQAaGGV4kNnpopZPc6bTDg@mail.gmail.com> (raw)
In-Reply-To: <bc35430f-ff04-d018-0743-d08564dc93c6@bitdefender.com>

On Tue, Jul 12, 2016 at 10:26 PM, Corneliu ZUZU <czuzu@bitdefender.com> wrote:
> On 7/9/2016 9:57 PM, Corneliu ZUZU wrote:
>>
>> On 7/9/2016 9:26 PM, Tamas K Lengyel wrote:
>>>>
>>>> diff --git a/xen/include/asm-x86/domain.h b/xen/include/asm-x86/domain.h
>>>> index ae1dcb4..7663da2 100644
>>>> --- a/xen/include/asm-x86/domain.h
>>>> +++ b/xen/include/asm-x86/domain.h
>>>> @@ -9,6 +9,7 @@
>>>>   #include <asm/e820.h>
>>>>   #include <asm/mce.h>
>>>>   #include <public/vcpu.h>
>>>> +#include <public/vm_event.h>
>>>>   #include <public/hvm/hvm_info_table.h>
>>>>
>>>>   #define has_32bit_shinfo(d) ((d)->arch.has_32bit_shinfo)
>>>> @@ -503,6 +504,20 @@ typedef enum __packed {
>>>>       SMAP_CHECK_DISABLED,        /* disable the check */
>>>>   } smap_check_policy_t;
>>>>
>>>> +/*
>>>> + * Should we emulate the next matching instruction on VCPU resume
>>>> + * after a vm_event?
>>>> + */
>>>> +struct arch_vm_event_monitor {
>>>
>>> This should be named struct arch_vcpu_monitor.
>>
>>
>> Good idea.
>>
>>>
>>>> +    uint32_t emulate_flags;
>>>> +    struct vm_event_emul_read_data emul_read_data;
>>>
>>> This should probably get renamed as well at some point to struct
>>> monitor_emul_read_data.
>>
>>
>> Ack.
>>
>>>> +    struct monitor_write_data write_data;
>>>> +};
>>>> +
>>>> +struct arch_vm_event {
>>>> +    struct arch_vm_event_monitor *monitor;
>>>> +};
>>>
>>> IMHO there is not much point in defining struct arch_vm_event this
>>> way, we could just as well store the pointer to the arch_monitor
>>> directly in arch_vcpu as we do right now.
>>>
>>
>> I stated the reason for that in the commit message (see 3rd '*'), Jan
>> insists it would be preferable to occupy just one pointer in arch_vcpu
>> (which would still hold if we do as you suggest but I was wondering how
>> probable would it be in the future for one of the paging/share vm-event
>> subsystems to need per-vCPU resources). But personally, yeah, I would have
>> preferred what you suggest as well..
>>
>> Zuzu.
>
>
> Tamas, any update on this? Do you think we should think now about per-vCPU
> resources being occupied in the future by paging/share or leave that for
> later and do what you suggested?

It's highly unlikely that either paging or sharing will have any use
of this struct in the near future provided but subsystems are pretty
much orphaned at this point. If we ever going to need it it's an easy
enough adjustment but for now it's not needed.

Tamas

_______________________________________________
Xen-devel mailing list
Xen-devel@lists.xen.org
https://lists.xen.org/xen-devel

  reply	other threads:[~2016-07-13 18:56 UTC|newest]

Thread overview: 54+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2016-07-09  4:11 [PATCH 00/16] x86/vm-event: numerous adjustments & fixes Corneliu ZUZU
2016-07-09  4:12 ` [PATCH 01/16] x86/vmx_update_guest_cr: minor optimization Corneliu ZUZU
2016-07-11  6:24   ` Corneliu ZUZU
2016-07-09  4:12 ` [PATCH 02/16] x86: fix: make atomic_read() param const Corneliu ZUZU
2016-07-11 15:18   ` Andrew Cooper
2016-07-12  5:11     ` Corneliu ZUZU
2016-07-12  9:42       ` Andrew Cooper
2016-07-12 10:11         ` Corneliu ZUZU
2016-07-12 10:22           ` Andrew Cooper
2016-07-12 10:35             ` Corneliu ZUZU
2016-07-12 10:38             ` Corneliu ZUZU
2016-07-12 12:49               ` Andrew Cooper
2016-07-12 13:45                 ` Corneliu ZUZU
2016-07-09  4:13 ` [PATCH 03/16] x86/monitor: mechanical renames Corneliu ZUZU
2016-07-09 18:10   ` Tamas K Lengyel
2016-07-09 18:46     ` Corneliu ZUZU
2016-07-11 16:43       ` Tamas K Lengyel
2016-07-12  6:10         ` Corneliu ZUZU
2016-07-15  7:18           ` Corneliu ZUZU
2016-07-18 18:07             ` Andrew Cooper
2016-07-19  9:36               ` Corneliu ZUZU
2016-07-09  4:14 ` [PATCH 04/16] x86/monitor: relocate vm_event_register_write_resume() function to monitor code Corneliu ZUZU
2016-07-09 18:14   ` Tamas K Lengyel
2016-07-09 18:47     ` Corneliu ZUZU
2016-07-09  4:15 ` [PATCH 05/16] x86/monitor: relocate code more appropriately Corneliu ZUZU
2016-07-11  6:19   ` Corneliu ZUZU
2016-07-12  7:45     ` Tian, Kevin
2016-07-12  8:07       ` Corneliu ZUZU
2016-07-15 11:41         ` Corneliu ZUZU
2016-07-09  4:15 ` [PATCH 06/16] x86/monitor: fix: set msr_bitmap to NULL after xfree Corneliu ZUZU
2016-07-09  4:16 ` [PATCH 07/16] x86/vm-event: fix: call cleanup when init fails, to free partial allocs Corneliu ZUZU
2016-07-09  4:17 ` [PATCH 08/16] x86/vm-event: call monitor init & cleanup funcs from respective vm_event funcs Corneliu ZUZU
2016-07-09  4:18 ` [PATCH 09/16] arm/monitor: move d->monitor cleanup to monitor_cleanup_domain() Corneliu ZUZU
2016-07-09  4:19 ` [PATCH 10/16] x86/vm-event: centralize vcpu-destroy cleanup in vm-events code Corneliu ZUZU
2016-07-09  4:20 ` [PATCH 11/16] x86/monitor: fix: treat -monitor- properly, as a subsys of the vm-event subsys Corneliu ZUZU
2016-07-09 17:34   ` Tamas K Lengyel
2016-07-09 17:46     ` Corneliu ZUZU
2016-07-11 16:38       ` Tamas K Lengyel
2016-07-11 20:20         ` Corneliu ZUZU
2016-07-11 21:27           ` Tamas K Lengyel
2016-07-11 21:47             ` Corneliu ZUZU
2016-07-09  4:20 ` [PATCH 12/16] x86/vm-event: fix: move cleanup of mem_access_emulate_each_rep to monitor stub Corneliu ZUZU
2016-07-09  4:21 ` [PATCH 13/16] x86/monitor: introduce writes_pending field in monitor_write_data Corneliu ZUZU
2016-07-09  4:22 ` [PATCH 14/16] x86/monitor: clarify separation between monitor subsys and vm-event as a whole Corneliu ZUZU
2016-07-09 18:26   ` Tamas K Lengyel
2016-07-09 18:57     ` Corneliu ZUZU
2016-07-13  4:26       ` Corneliu ZUZU
2016-07-13 18:56         ` Tamas K Lengyel [this message]
2016-07-09  4:23 ` [PATCH 15/16] x86/monitor: fix: don't compromise a monitor_write_data with pending CR writes Corneliu ZUZU
2016-07-09  4:23 ` [PATCH 16/16] x86/monitor: fix: xc_monitor _write_ctrlreg w/o previous _enable must fail Corneliu ZUZU
2016-07-09  4:34   ` Corneliu ZUZU
2016-07-11  2:54 ` [PATCH 00/16] x86/vm-event: numerous adjustments & fixes Tian, Kevin
2016-07-11  5:32   ` Corneliu ZUZU
2016-07-12  7:42     ` Tian, Kevin

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=CABfawhnMZit6mQUbLT-OHcq2hws+XQAaGGV4kNnpopZPc6bTDg@mail.gmail.com \
    --to=tamas@tklengyel.com \
    --cc=andrew.cooper3@citrix.com \
    --cc=czuzu@bitdefender.com \
    --cc=george.dunlap@eu.citrix.com \
    --cc=jbeulich@suse.com \
    --cc=paul.durrant@citrix.com \
    --cc=rcojocaru@bitdefender.com \
    --cc=xen-devel@lists.xen.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).