xen-devel.lists.xenproject.org archive mirror
 help / color / mirror / Atom feed
From: "Roger Pau Monné" <roger.pau@citrix.com>
To: Jan Beulich <jbeulich@suse.com>
Cc: Andrew Cooper <andrew.cooper3@citrix.com>, Wei Liu <wl@xen.org>,
	Jun Nakajima <jun.nakajima@intel.com>,
	Kevin Tian <kevin.tian@intel.com>,
	<xen-devel@lists.xenproject.org>
Subject: Re: [PATCH v3 09/11] x86/vpt: switch interrupt injection model
Date: Wed, 14 Apr 2021 16:20:38 +0200	[thread overview]
Message-ID: <YHb6NvqwSjFzrCrt@Air-de-Roger> (raw)
In-Reply-To: <4c65efcf-28fa-147d-8c82-7498cad19aeb@suse.com>

On Wed, Apr 14, 2021 at 04:05:20PM +0200, Jan Beulich wrote:
> On 14.04.2021 15:37, Roger Pau Monné wrote:
> > On Wed, Apr 14, 2021 at 12:28:43PM +0200, Jan Beulich wrote:
> >> On 31.03.2021 12:33, Roger Pau Monne wrote:
> >>> ---
> >>>  xen/arch/x86/hvm/svm/intr.c   |   3 -
> >>>  xen/arch/x86/hvm/vmx/intr.c   |  59 ------
> >>>  xen/arch/x86/hvm/vpt.c        | 334 ++++++++++++++--------------------
> >>>  xen/include/asm-x86/hvm/vpt.h |   5 +-
> >>>  4 files changed, 143 insertions(+), 258 deletions(-)
> >>
> >> Nice.
> >>
> >>> @@ -285,189 +238,144 @@ static void pt_irq_fired(struct vcpu *v, struct periodic_time *pt)
> >>>              list_del(&pt->list);
> >>>          pt->on_list = false;
> >>>          pt->pending_intr_nr = 0;
> >>> +
> >>> +        return;
> >>>      }
> >>> -    else if ( mode_is(v->domain, one_missed_tick_pending) ||
> >>> -              mode_is(v->domain, no_missed_ticks_pending) )
> >>> +
> >>> +    if ( mode_is(v->domain, one_missed_tick_pending) ||
> >>> +         mode_is(v->domain, no_missed_ticks_pending) )
> >>>      {
> >>> -        pt->last_plt_gtime = hvm_get_guest_time(v);
> >>>          pt_process_missed_ticks(pt);
> >>>          pt->pending_intr_nr = 0; /* 'collapse' all missed ticks */
> >>> +    }
> >>> +    else if ( !pt->pending_intr_nr )
> >>> +        pt_process_missed_ticks(pt);
> >>
> >> Did you lose a -- here? I.e. does the condition mean to match ...
> >>
> >>> +    if ( !pt->pending_intr_nr )
> >>>          set_timer(&pt->timer, pt->scheduled);
> >>> +}
> >>> +
> >>> +static void pt_timer_fn(void *data)
> >>> +{
> >>> +    struct periodic_time *pt = data;
> >>> +    struct vcpu *v;
> >>> +    time_cb *cb = NULL;
> >>> +    void *cb_priv;
> >>> +    unsigned int irq;
> >>> +
> >>> +    pt_lock(pt);
> >>> +
> >>> +    v = pt->vcpu;
> >>> +    irq = pt->irq;
> >>> +
> >>> +    if ( inject_interrupt(pt) )
> >>> +    {
> >>> +        pt->scheduled += pt->period;
> >>> +        pt->do_not_freeze = 0;
> >>> +        cb = pt->cb;
> >>> +        cb_priv = pt->priv;
> >>>      }
> >>>      else
> >>>      {
> >>> -        pt->last_plt_gtime += pt->period;
> >>> -        if ( --pt->pending_intr_nr == 0 )
> >>
> >> ... this original code? Otherwise I can't see why the condition
> >> guards a pt_process_missed_ticks() invocation.
> > 
> > I think the logic here changed enough to not match anymore. Certainly
> > pending_intr_nr shouldn't be decreased there, as pt_irq_fired is
> > invoked after an EOI in this patch, instead of being invoked when a
> > vpt related interrupt was injected. I think I should better rename
> > pt_irq_fired to pt_irq_eoi and that would make it clearer.
> 
> But pt_process_missed_ticks() should be called only when a tick was
> missed, shouldn't it?

No, I think the purpose of the function is to update the
pending_intr_nr field, ie: calculate if and how many ticks have been
missed.

It's fine for pt_process_missed_ticks to return without having changed
pending_intr_nr at all if no ticks have been missed.

> Or actually, looking at the function, I guess
> I'm confused. Does your patch change the meaning of the field?

Not really, I think pt_process_missed_ticks has always had this logic.
The pending_intr_nr filed should still have the same logic, account
for the amount of missed ticks up to the value in the scheduled field.

> > FWIW, decreasing pending_intr_nr should only be done after an
> > inject_interrupt call.
> 
> Then this line (which you leave in place)
> 
>          pt->pending_intr_nr = 0; /* 'collapse' all missed ticks */
> 
> is contradicting the (new) model.

Oh, right, that's mode specific. no_missed_ticks_pending will just
drop any interrupts that haven't been injected when they should have
been. I had the 'account missed ticks' mode in mind when I wrote that.

I now have pt_irq_fired as:

static void irq_eoi(struct periodic_time *pt)
{
    if ( pt->one_shot )
    {
        pt->pending_intr_nr = 0;
        return;
    }

    pt_process_missed_ticks(pt);
    /* 'collapse' missed ticks according to the selected mode. */
    switch ( pt->vcpu->domain->arch.hvm.params[HVM_PARAM_TIMER_MODE] )
    {
    case HVMPTM_one_missed_tick_pending:
        pt->pending_intr_nr = min(pt->pending_intr_nr, 1u);
        break;

    case HVMPTM_no_missed_ticks_pending:
        pt->pending_intr_nr = 0;
        break;
    }

    if ( !pt->pending_intr_nr )
    {
        /* Make sure timer follows vCPU. */
        migrate_timer(&pt->timer, current->processor);
        set_timer(&pt->timer, pt->scheduled);
    }
}

But I think it's best if I post it as a new version, so you can see
the context.

Thanks, Roger.


  reply	other threads:[~2021-04-14 14:21 UTC|newest]

Thread overview: 51+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2021-03-31 10:32 [PATCH v3 00/11] x86/intr: introduce EOI callbacks and fix vPT Roger Pau Monne
2021-03-31 10:32 ` [PATCH v3 01/11] x86/hvm: drop vcpu parameter from vlapic EOI callbacks Roger Pau Monne
2021-03-31 16:02   ` Jan Beulich
2021-03-31 16:24     ` Andrew Cooper
2021-04-01  9:12       ` Roger Pau Monné
2021-04-01 11:06   ` Jan Beulich
2021-04-07  7:41     ` Roger Pau Monné
2021-04-07  8:19       ` Jan Beulich
2021-03-31 10:32 ` [PATCH v3 02/11] x86/hvm: drop domain parameter from vioapic/vpic " Roger Pau Monne
2021-03-31 16:04   ` Jan Beulich
2021-04-01  9:15     ` Roger Pau Monné
2021-04-01  9:28       ` Jan Beulich
2021-03-31 10:32 ` [PATCH v3 03/11] x86/vlapic: introduce an EOI callback mechanism Roger Pau Monne
2021-03-31 11:47   ` Andrew Cooper
2021-03-31 12:50     ` Roger Pau Monné
2021-04-07 14:55   ` Jan Beulich
2021-04-07 16:27     ` Roger Pau Monné
2021-04-08  6:20       ` Jan Beulich
2021-04-08  9:12         ` Roger Pau Monné
2021-04-08 10:49           ` Jan Beulich
2021-04-08 10:56             ` Roger Pau Monné
2021-03-31 10:32 ` [PATCH v3 04/11] x86/vmsi: use the newly introduced EOI callbacks Roger Pau Monne
2021-04-07 14:59   ` Jan Beulich
2021-03-31 10:32 ` [PATCH v3 05/11] x86/vioapic: switch to use the EOI callback mechanism Roger Pau Monne
2021-04-07 15:19   ` Jan Beulich
2021-04-07 16:46     ` Roger Pau Monné
2021-04-08  6:27       ` Jan Beulich
2021-04-08  8:59         ` Roger Pau Monné
2021-04-08 10:52           ` Jan Beulich
2021-03-31 10:32 ` [PATCH v3 06/11] x86/hvm: allowing registering EOI callbacks for GSIs Roger Pau Monne
2021-04-07 15:51   ` Jan Beulich
2021-04-07 17:08     ` Roger Pau Monné
2021-04-08  6:34       ` Jan Beulich
2021-04-15 16:04       ` Roger Pau Monné
2021-04-16  7:29         ` Jan Beulich
2021-04-19  8:31           ` Roger Pau Monné
2021-04-08 12:52     ` Roger Pau Monné
2021-04-08 14:31       ` Jan Beulich
2021-04-08 15:06         ` Roger Pau Monné
2021-03-31 10:32 ` [PATCH v3 07/11] x86/dpci: move code Roger Pau Monne
2021-03-31 10:33 ` [PATCH v3 08/11] x86/dpci: switch to use a GSI EOI callback Roger Pau Monne
2021-04-08 14:49   ` Jan Beulich
2021-04-08 15:23     ` Roger Pau Monné
2021-03-31 10:33 ` [PATCH v3 09/11] x86/vpt: switch interrupt injection model Roger Pau Monne
2021-04-14 10:28   ` Jan Beulich
2021-04-14 13:37     ` Roger Pau Monné
2021-04-14 14:05       ` Jan Beulich
2021-04-14 14:20         ` Roger Pau Monné [this message]
2021-03-31 10:33 ` [PATCH v3 10/11] x86/vpt: remove vPT timers per-vCPU lists Roger Pau Monne
2021-04-14 10:38   ` Jan Beulich
2021-03-31 10:33 ` [PATCH v3 11/11] x86/vpt: introduce a per-vPT lock Roger Pau Monne

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=YHb6NvqwSjFzrCrt@Air-de-Roger \
    --to=roger.pau@citrix.com \
    --cc=andrew.cooper3@citrix.com \
    --cc=jbeulich@suse.com \
    --cc=jun.nakajima@intel.com \
    --cc=kevin.tian@intel.com \
    --cc=wl@xen.org \
    --cc=xen-devel@lists.xenproject.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).