xen-devel.lists.xenproject.org archive mirror
 help / color / mirror / Atom feed
From: Julien Grall <julien@xen.org>
To: Stefano Stabellini <sstabellini@kernel.org>
Cc: xen-devel@lists.xenproject.org, Wei.Chen@arm.com,
	Henry.Wang@arm.com, Penny.Zheng@arm.com,
	Bertrand.Marquis@arm.com, Julien Grall <jgrall@amazon.com>,
	Volodymyr Babchuk <Volodymyr_Babchuk@epam.com>
Subject: Re: [PATCH RFCv2 02/15] xen/arm: lpae: Use the generic helpers to defined the Xen PT helpers
Date: Wed, 14 Jul 2021 18:40:34 +0100	[thread overview]
Message-ID: <cb92cf2b-5e32-1774-deef-dd573f5eefc3@xen.org> (raw)
In-Reply-To: <alpine.DEB.2.21.2107131353000.23286@sstabellini-ThinkPad-T480s>

Hi Stefano,

On 13/07/2021 21:53, Stefano Stabellini wrote:
> On Sat, 3 Jul 2021, Julien Grall wrote:
>> Hi Stefano,
>>
>> Sorry for the late answer.
>>
>> On 13/05/2021 23:44, Stefano Stabellini wrote:
>>> On Wed, 12 May 2021, Julien Grall wrote:
>>>> Hi Stefano,
>>>>
>>>> On 12/05/2021 22:30, Stefano Stabellini wrote:
>>>>> On Wed, 12 May 2021, Julien Grall wrote:
>>>>>>>> +#define LPAE_SHIFT          LPAE_SHIFT_GS(PAGE_SHIFT)
>>>>>>>> +#define LPAE_ENTRIES        LPAE_ENTRIES_GS(PAGE_SHIFT)
>>>>>>>> +#define LPAE_ENTRY_MASK     LPAE_ENTRY_MASK_GS(PAGE_SHIFT)
>>>>>>>>
>>>>>>>> +#define LEVEL_SHIFT(lvl)    LEVEL_SHIFT_GS(PAGE_SHIFT, lvl)
>>>>>>>> +#define LEVEL_ORDER(lvl)    LEVEL_ORDER_GS(PAGE_SHIFT, lvl)
>>>>>>>> +#define LEVEL_SIZE(lvl)     LEVEL_SIZE_GS(PAGE_SHIFT, lvl)
>>>>>>>> +#define LEVEL_MASK(lvl)     (~(LEVEL_SIZE(lvl) - 1))
>>>>>>>
>>>>>>> I would avoid adding these 4 macros. It would be OK if they were
>>>>>>> just
>>>>>>> used within this file but lpae.h is a header: they could end up be
>>>>>>> used
>>>>>>> anywhere in the xen/ code and they have a very generic name. My
>>>>>>> suggestion would be to skip them and just do:
>>>>>>
>>>>>> Those macros will be used in follow-up patches. They are pretty useful
>>>>>> to
>>>>>> avoid introduce static array with the different information for each
>>>>>> level.
>>>>>>
>>>>>> Would prefix them with XEN_ be better?
>>>>>
>>>>> Maybe. The concern I have is that there are multiple page granularities
>>>>> (4kb, 16kb, etc) and multiple page sizes (4kb, 2mb, etc). If I just see
>>>>> LEVEL_ORDER it is not immediately obvious what granularity and what size
>>>>> we are talking about.
>>>>
>>>> I am a bit puzzled with your answer. AFAIU, you are happy with the
>>>> existing
>>>> macros (THIRD_*, SECOND_*) but not with the new macros.
>>>>
>>>> In reality, there is no difference because THIRD_* doesn't tell you the
>>>> exact
>>>> size but only "this is a level 3 mapping".
>>>>
>>>> So can you clarify what you are after? IOW is it reworking the current
>>>> naming
>>>> scheme?
>>>
>>> You are right -- there is no real difference between THIRD_*, SECOND_*
>>> and LEVEL_*.
>>>
>>> The original reason for my comments is that I hadn't read the following
>>> patches, and the definition of LEVEL_* macros is simple, they could be
>>> open coded. It looked like they were only going to be used to make the
>>> definition of THIRD_*, SECOND_* a bit easier. So, at first, I was
>>> wondering if they were needed at all.
>>>
>>> Secondly, I realized that they were going to be used in *.c files by
>>> other patches. That's why they are there. But I started thinking whether
>>> we should find a way to make it a bit clearer that they are for Xen
>>> pages, currently at 4KB granularity. THIRD_*, SECOND_*, etc. are already
>>> generic names which don't convey the granularity or whether they are Xen
>>> pages at all. But LEVEL_* seem even more generic.
>>>
>>> As I mentioned, I don't have any good suggestions for changes to make
>>> here, so unless you can come up with a good idea let's keep it as is.
>>
>> I am thinking to use the following naming (diff on top of this patch):
>>
>> -#define LPAE_SHIFT          LPAE_SHIFT_GS(PAGE_SHIFT)
>> -#define LPAE_ENTRIES        LPAE_ENTRIES_GS(PAGE_SHIFT)
>> -#define LPAE_ENTRY_MASK     LPAE_ENTRY_MASK_GS(PAGE_SHIFT)
>> +#define XEN_PT_SHIFT          LPAE_SHIFT_GS(PAGE_SHIFT)
>> +#define XEN_PT_ENTRIES        LPAE_ENTRIES_GS(PAGE_SHIFT)
>> +#define XEN_PT_ENTRY_MASK     LPAE_ENTRY_MASK_GS(PAGE_SHIFT)
>>
>> -#define LEVEL_SHIFT(lvl)    LEVEL_SHIFT_GS(PAGE_SHIFT, lvl)
>> -#define LEVEL_ORDER(lvl)    LEVEL_ORDER_GS(PAGE_SHIFT, lvl)
>> -#define LEVEL_SIZE(lvl)     LEVEL_SIZE_GS(PAGE_SHIFT, lvl)
>> -#define LEVEL_MASK(lvl)     (~(LEVEL_SIZE(lvl) - 1))
>> +#define XEN_PT_LEVEL_SHIFT(lvl)    LEVEL_SHIFT_GS(PAGE_SHIFT, lvl)
>> +#define XEN_PT_LEVEL_ORDER(lvl)    LEVEL_ORDER_GS(PAGE_SHIFT, lvl)
>> +#define XEN_PT_LEVEL_SIZE(lvl)     LEVEL_SIZE_GS(PAGE_SHIFT, lvl)
>> +#define XEN_PT_LEVEL_MASK(lvl)     (~(LEVEL_SIZE(lvl) - 1))
>>
>>   /* Convenience aliases */
>> -#define THIRD_SHIFT         LEVEL_SHIFT(3)
>> -#define THIRD_ORDER         LEVEL_ORDER(3)
>> -#define THIRD_SIZE          LEVEL_SIZE(3)
>> -#define THIRD_MASK          LEVEL_MASK(3)
>> -
>> -#define SECOND_SHIFT        LEVEL_SHIFT(2)
>> -#define SECOND_ORDER        LEVEL_ORDER(2)
>> -#define SECOND_SIZE         LEVEL_SIZE(2)
>> -#define SECOND_MASK         LEVEL_MASK(2)
>> -
>> -#define FIRST_SHIFT         LEVEL_SHIFT(1)
>> -#define FIRST_ORDER         LEVEL_ORDER(1)
>> -#define FIRST_SIZE          LEVEL_SIZE(1)
>> -#define FIRST_MASK          LEVEL_MASK(1)
>> -
>> -#define ZEROETH_SHIFT       LEVEL_SHIFT(0)
>> -#define ZEROETH_ORDER       LEVEL_ORDER(0)
>> -#define ZEROETH_SIZE        LEVEL_SIZE(0)
>> -#define ZEROETH_MASK        LEVEL_MASK(0)
>> +#define THIRD_SHIFT         XEN_PT_LEVEL_SHIFT(3)
>> +#define THIRD_ORDER         XEN_PT_LEVEL_ORDER(3)
>> +#define THIRD_SIZE          XEN_PT_LEVEL_SIZE(3)
>> +#define THIRD_MASK          XEN_PT_LEVEL_MASK(3)
>> +
>> +#define SECOND_SHIFT        XEN_PT_LEVEL_SHIFT(2)
>> +#define SECOND_ORDER        XEN_PT_LEVEL_ORDER(2)
>> +#define SECOND_SIZE         XEN_PT_LEVEL_SIZE(2)
>> +#define SECOND_MASK         XEN_PT_LEVEL_MASK(2)
>> +
>> +#define FIRST_SHIFT         XEN_PT_LEVEL_SHIFT(1)
>> +#define FIRST_ORDER         XEN_PT_LEVEL_ORDER(1)
>> +#define FIRST_SIZE          XEN_PT_LEVEL_SIZE(1)
>> +#define FIRST_MASK          XEN_PT_LEVEL_MASK(1)
>> +
>> +#define ZEROETH_SHIFT       XEN_PT_LEVEL_SHIFT(0)
>> +#define ZEROETH_ORDER       XEN_PT_LEVEL_ORDER(0)
>> +#define ZEROETH_SIZE        XEN_PT_LEVEL_SIZE(0)
>> +#define ZEROETH_MASK        XEN_PT_LEVEL_MASK(0)
>>
>> I don't plan to modify the nameing for ZEROETH*, FIRST*, SECOND*, THIRD*.
>>
>> Let me know if you prefer it over the currrent naming.
> 
> Yes, I think it is better, thanks!

Ok. I will try to respin the series soon.

Cheers,

-- 
Julien Grall


  reply	other threads:[~2021-07-14 17:40 UTC|newest]

Thread overview: 58+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2021-04-25 20:13 [PATCH RFCv2 00/15] xen/arm: mm: Remove open-coding mappings Julien Grall
2021-04-25 20:13 ` [PATCH RFCv2 01/15] xen/arm: lpae: Rename LPAE_ENTRIES_MASK_GS to LPAE_ENTRY_MASK_GS Julien Grall
2021-05-11 22:12   ` Stefano Stabellini
2021-04-25 20:13 ` [PATCH RFCv2 02/15] xen/arm: lpae: Use the generic helpers to defined the Xen PT helpers Julien Grall
2021-05-11 22:26   ` Stefano Stabellini
2021-05-12 14:26     ` Julien Grall
2021-05-12 21:30       ` Stefano Stabellini
2021-05-12 22:16         ` Julien Grall
2021-05-13 22:44           ` Stefano Stabellini
2021-07-03 17:32             ` Julien Grall
2021-07-13 20:53               ` Stefano Stabellini
2021-07-14 17:40                 ` Julien Grall [this message]
2021-04-25 20:13 ` [PATCH RFCv2 03/15] xen/arm: p2m: Replace level_{orders, masks} arrays with LEVEL_{ORDER, MASK} Julien Grall
2021-05-11 22:33   ` Stefano Stabellini
2021-05-12 14:39     ` Julien Grall
2021-04-25 20:13 ` [PATCH RFCv2 04/15] xen/arm: mm: Allow other mapping size in xen_pt_update_entry() Julien Grall
2021-05-11 22:42   ` Stefano Stabellini
2021-04-25 20:13 ` [PATCH RFCv2 05/15] xen/arm: mm: Avoid flushing the TLBs when mapping are inserted Julien Grall
2021-05-11 22:51   ` Stefano Stabellini
2021-04-25 20:13 ` [PATCH RFCv2 06/15] xen/arm: mm: Don't open-code Xen PT update in remove_early_mappings() Julien Grall
2021-05-11 22:58   ` Stefano Stabellini
2021-04-25 20:13 ` [PATCH RFCv2 07/15] xen/arm: mm: Re-implement early_fdt_map() using map_pages_to_xen() Julien Grall
2021-05-12 21:41   ` Stefano Stabellini
2021-05-12 22:18     ` Julien Grall
2021-04-25 20:13 ` [PATCH RFCv2 08/15] xen/arm32: mm: Check if the virtual address is shared before updating it Julien Grall
2021-05-12 22:00   ` Stefano Stabellini
2021-05-12 22:23     ` Julien Grall
2021-05-13 22:32       ` Stefano Stabellini
2021-05-13 22:59         ` Julien Grall
2021-05-14  1:04           ` Stefano Stabellini
2021-04-25 20:13 ` [PATCH RFCv2 09/15] xen/arm32: mm: Re-implement setup_xenheap_mappings() using map_pages_to_xen() Julien Grall
2021-05-12 22:07   ` Stefano Stabellini
2021-05-13 17:55     ` Julien Grall
2021-04-25 20:13 ` [PATCH RFCv2 10/15] xen/arm: mm: Allocate xen page tables in domheap rather than xenheap Julien Grall
2021-05-12 22:44   ` Stefano Stabellini
2021-05-13 18:09     ` Julien Grall
2021-05-13 22:27       ` Stefano Stabellini
2021-05-15  8:48         ` Julien Grall
2021-05-18  0:37           ` Stefano Stabellini
2021-04-25 20:13 ` [PATCH RFCv2 11/15] xen/arm: mm: Allow page-table allocation from the boot allocator Julien Grall
2021-05-13 22:58   ` Stefano Stabellini
2021-04-25 20:13 ` [PATCH RFCv2 12/15] xen/arm: add Persistent Map (PMAP) infrastructure Julien Grall
2021-04-26  9:41   ` Xia, Hongyan
2021-07-03 17:57     ` Julien Grall
2021-04-28 21:47   ` Wei Liu
2021-05-14 23:25   ` Stefano Stabellini
2021-05-15  8:54     ` Julien Grall
2021-04-25 20:13 ` [PATCH RFCv2 13/15] xen/arm: mm: Use the PMAP helpers in xen_{,un}map_table() Julien Grall
2021-05-14 23:35   ` Stefano Stabellini
2021-05-15  9:03     ` Julien Grall
2021-04-25 20:13 ` [PATCH RFCv2 14/15] xen/arm: mm: Rework setup_xenheap_mappings() Julien Grall
2021-05-14 23:51   ` Stefano Stabellini
2021-05-15  9:21     ` Julien Grall
2021-05-18  0:50       ` Stefano Stabellini
2021-04-25 20:13 ` [PATCH RFCv2 15/15] xen/arm: mm: Re-implement setup_frame_table_mappings() with map_pages_to_xen() Julien Grall
2021-05-15  0:02   ` Stefano Stabellini
2021-05-15  9:25     ` Julien Grall
2021-05-18  0:51       ` Stefano Stabellini

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=cb92cf2b-5e32-1774-deef-dd573f5eefc3@xen.org \
    --to=julien@xen.org \
    --cc=Bertrand.Marquis@arm.com \
    --cc=Henry.Wang@arm.com \
    --cc=Penny.Zheng@arm.com \
    --cc=Volodymyr_Babchuk@epam.com \
    --cc=Wei.Chen@arm.com \
    --cc=jgrall@amazon.com \
    --cc=sstabellini@kernel.org \
    --cc=xen-devel@lists.xenproject.org \
    --subject='Re: [PATCH RFCv2 02/15] xen/arm: lpae: Use the generic helpers to defined the Xen PT helpers' \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).