All of lore.kernel.org
 help / color / mirror / Atom feed
From: paul@paul-moore.com (Paul Moore)
To: linux-security-module@vger.kernel.org
Subject: [PATCH V3 02/10] capabilities: intuitive names for cap gain status
Date: Thu, 24 Aug 2017 17:17:50 -0400	[thread overview]
Message-ID: <CAHC9VhRzH=gHrBLPHB2GkeR_5pJqmoMAzDCH3EtmDfNpvPD0Jg@mail.gmail.com> (raw)
In-Reply-To: <CAGXu5jJbgoeBpaHt=2u+KkSsewwVdjZmtxMMuFOv927XkW0uig@mail.gmail.com>

On Thu, Aug 24, 2017 at 3:06 PM, Kees Cook <keescook@chromium.org> wrote:
> On Thu, Aug 24, 2017 at 9:37 AM, Serge E. Hallyn <serge@hallyn.com> wrote:
>> Quoting Richard Guy Briggs (rgb at redhat.com):
>>> On 2017-08-24 11:03, Serge E. Hallyn wrote:
>>> > Quoting Richard Guy Briggs (rgb at redhat.com):
>>> > > Introduce macros cap_gained, cap_grew, cap_full to make the use of the
>>> > > negation of is_subset() easier to read and analyse.
>>> > >
>>> > > Signed-off-by: Richard Guy Briggs <rgb@redhat.com>
>>> > > ---
>>> > >  security/commoncap.c |   16 ++++++++++------
>>> > >  1 files changed, 10 insertions(+), 6 deletions(-)
>>> > >
>>> > > diff --git a/security/commoncap.c b/security/commoncap.c
>>> > > index b7fbf77..6f05ec0 100644
>>> > > --- a/security/commoncap.c
>>> > > +++ b/security/commoncap.c
>>> > > @@ -513,6 +513,12 @@ void handle_privileged_root(struct linux_binprm *bprm, bool has_cap, bool *effec
>>> > >           *effective = true;
>>> > >  }
>>> > >
>>> >
>>> > It's subjective and so might be just me, but I think I'd find it easier
>>> > to read if it was cap_gained(source, target, field) and cap_grew(cred, source, target)
>>>
>>> In more than one place, I wanted to put the parameter that I was trying
>>> to read aloud closest to the function name to make reading it flow
>>> better, leaving the parameters less critical to comprehension towards
>>> the end.
>>
>> And I see that in the final patch it looks nicer the way you have it.
>>
>>> > This looks correct though, so either way
>>> >
>>> > Reviewed-by: Serge Hallyn <serge@hallyn.com>
>>>
>>> Thanks.  Did you want to put this through, or send it through Paul's
>>> audit tree?
>>
>> If Paul's around I'm happy to have it go through his tree.

Since Serge is okay with these I'll take a closer look and if it all
looks good I can pull it in to the audit tree (no objections from me
on the last revision, although I remember it being much smaller).

That said, since we are already at -rc6, I'm going to defer merging
this into audit/next *after* the upcoming merge window.  We are right
at where I normally draw the line and considering the scope and nature
of this patchset I think having a full RC cycle in linux-next would be
a good thing.

> Is this series based against -next with the changes that touch commoncap.c?
>
> Also, did you validate this with the existing LTP tests and selftests?
>
> https://git.kernel.org/pub/scm/linux/kernel/git/kees/linux.git/commit/?h=for-next/secureexec&id=ee67ae7ef6ff499137292ac8a9dfe86096796283

Another reason for keeping this in the queue a bit longer.  Richard,
can you do this testing before the upcoming merge window closes?

-- 
paul moore
www.paul-moore.com
--
To unsubscribe from this list: send the line "unsubscribe linux-security-module" in
the body of a message to majordomo at vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

WARNING: multiple messages have this Message-ID (diff)
From: Paul Moore <paul@paul-moore.com>
To: Kees Cook <keescook@chromium.org>,
	"Serge E. Hallyn" <serge@hallyn.com>,
	Richard Guy Briggs <rgb@redhat.com>
Cc: linux-security-module <linux-security-module@vger.kernel.org>,
	linux-audit@redhat.com, Andy Lutomirski <luto@kernel.org>,
	"Serge E. Hallyn" <serge.hallyn@ubuntu.com>,
	James Morris <james.l.morris@oracle.com>,
	Eric Paris <eparis@redhat.com>, Paul Moore <pmoore@redhat.com>,
	Steve Grubb <sgrubb@redhat.com>
Subject: Re: [PATCH V3 02/10] capabilities: intuitive names for cap gain status
Date: Thu, 24 Aug 2017 17:17:50 -0400	[thread overview]
Message-ID: <CAHC9VhRzH=gHrBLPHB2GkeR_5pJqmoMAzDCH3EtmDfNpvPD0Jg@mail.gmail.com> (raw)
In-Reply-To: <CAGXu5jJbgoeBpaHt=2u+KkSsewwVdjZmtxMMuFOv927XkW0uig@mail.gmail.com>

On Thu, Aug 24, 2017 at 3:06 PM, Kees Cook <keescook@chromium.org> wrote:
> On Thu, Aug 24, 2017 at 9:37 AM, Serge E. Hallyn <serge@hallyn.com> wrote:
>> Quoting Richard Guy Briggs (rgb@redhat.com):
>>> On 2017-08-24 11:03, Serge E. Hallyn wrote:
>>> > Quoting Richard Guy Briggs (rgb@redhat.com):
>>> > > Introduce macros cap_gained, cap_grew, cap_full to make the use of the
>>> > > negation of is_subset() easier to read and analyse.
>>> > >
>>> > > Signed-off-by: Richard Guy Briggs <rgb@redhat.com>
>>> > > ---
>>> > >  security/commoncap.c |   16 ++++++++++------
>>> > >  1 files changed, 10 insertions(+), 6 deletions(-)
>>> > >
>>> > > diff --git a/security/commoncap.c b/security/commoncap.c
>>> > > index b7fbf77..6f05ec0 100644
>>> > > --- a/security/commoncap.c
>>> > > +++ b/security/commoncap.c
>>> > > @@ -513,6 +513,12 @@ void handle_privileged_root(struct linux_binprm *bprm, bool has_cap, bool *effec
>>> > >           *effective = true;
>>> > >  }
>>> > >
>>> >
>>> > It's subjective and so might be just me, but I think I'd find it easier
>>> > to read if it was cap_gained(source, target, field) and cap_grew(cred, source, target)
>>>
>>> In more than one place, I wanted to put the parameter that I was trying
>>> to read aloud closest to the function name to make reading it flow
>>> better, leaving the parameters less critical to comprehension towards
>>> the end.
>>
>> And I see that in the final patch it looks nicer the way you have it.
>>
>>> > This looks correct though, so either way
>>> >
>>> > Reviewed-by: Serge Hallyn <serge@hallyn.com>
>>>
>>> Thanks.  Did you want to put this through, or send it through Paul's
>>> audit tree?
>>
>> If Paul's around I'm happy to have it go through his tree.

Since Serge is okay with these I'll take a closer look and if it all
looks good I can pull it in to the audit tree (no objections from me
on the last revision, although I remember it being much smaller).

That said, since we are already at -rc6, I'm going to defer merging
this into audit/next *after* the upcoming merge window.  We are right
at where I normally draw the line and considering the scope and nature
of this patchset I think having a full RC cycle in linux-next would be
a good thing.

> Is this series based against -next with the changes that touch commoncap.c?
>
> Also, did you validate this with the existing LTP tests and selftests?
>
> https://git.kernel.org/pub/scm/linux/kernel/git/kees/linux.git/commit/?h=for-next/secureexec&id=ee67ae7ef6ff499137292ac8a9dfe86096796283

Another reason for keeping this in the queue a bit longer.  Richard,
can you do this testing before the upcoming merge window closes?

-- 
paul moore
www.paul-moore.com

  reply	other threads:[~2017-08-24 21:17 UTC|newest]

Thread overview: 114+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2017-08-23 10:12 [PATCH V3 00/10] capabilities: do not audit log BPRM_FCAPS on set*id Richard Guy Briggs
2017-08-23 10:12 ` Richard Guy Briggs
2017-08-23 10:12 ` [PATCH V3 01/10] capabilities: factor out cap_bprm_set_creds privileged root Richard Guy Briggs
2017-08-23 10:12   ` Richard Guy Briggs
2017-08-24 15:42   ` Serge E. Hallyn
2017-08-24 15:42     ` Serge E. Hallyn
2017-08-25  5:55   ` James Morris
2017-08-25  5:55     ` James Morris
2017-08-25 10:49     ` Richard Guy Briggs
2017-08-25 10:49       ` Richard Guy Briggs
2017-08-23 10:12 ` [PATCH V3 02/10] capabilities: intuitive names for cap gain status Richard Guy Briggs
2017-08-23 10:12   ` Richard Guy Briggs
2017-08-24 16:03   ` Serge E. Hallyn
2017-08-24 16:03     ` Serge E. Hallyn
2017-08-24 16:19     ` Richard Guy Briggs
2017-08-24 16:19       ` Richard Guy Briggs
2017-08-24 16:37       ` Serge E. Hallyn
2017-08-24 16:37         ` Serge E. Hallyn
2017-08-24 19:06         ` Kees Cook
2017-08-24 19:06           ` Kees Cook
2017-08-24 21:17           ` Paul Moore [this message]
2017-08-24 21:17             ` Paul Moore
2017-08-28  9:19           ` Richard Guy Briggs
2017-08-28  9:19             ` Richard Guy Briggs
2017-08-28 11:08             ` Richard Guy Briggs
2017-08-28 11:08               ` Richard Guy Briggs
2017-09-01 10:18               ` Richard Guy Briggs
2017-09-01 10:18                 ` Richard Guy Briggs
2017-09-02  5:37                 ` Serge E. Hallyn
2017-09-02  5:37                   ` Serge E. Hallyn
2017-09-04  6:57                   ` Richard Guy Briggs
2017-09-04  6:57                     ` Richard Guy Briggs
2017-09-05  6:45                     ` Richard Guy Briggs
2017-09-05  6:45                       ` Richard Guy Briggs
2017-08-25  5:56   ` James Morris
2017-08-25  5:56     ` James Morris
2017-08-25 15:08   ` Andy Lutomirski
2017-08-25 15:08     ` Andy Lutomirski
2017-08-25 18:47     ` Serge E. Hallyn
2017-08-25 18:47       ` Serge E. Hallyn
2017-08-23 10:12 ` [PATCH V3 03/10] capabilities: rename has_cap to has_fcap Richard Guy Briggs
2017-08-23 10:12   ` Richard Guy Briggs
2017-08-24 16:10   ` Serge E. Hallyn
2017-08-24 16:10     ` Serge E. Hallyn
2017-08-25  5:56   ` James Morris
2017-08-25  5:56     ` James Morris
2017-08-23 10:12 ` [PATCH V3 04/10] capabilities: use root_priveleged inline to clarify logic Richard Guy Briggs
2017-08-23 10:12   ` Richard Guy Briggs
2017-08-24 16:14   ` Serge E. Hallyn
2017-08-24 16:14     ` Serge E. Hallyn
2017-08-25  5:58   ` James Morris
2017-08-25  5:58     ` James Morris
2017-08-28 12:03     ` Richard Guy Briggs
2017-08-28 12:03       ` Richard Guy Briggs
2017-08-31 14:49       ` Serge E. Hallyn
2017-08-31 14:49         ` Serge E. Hallyn
2017-08-23 10:12 ` [PATCH V3 05/10] capabilities: use intuitive names for id changes Richard Guy Briggs
2017-08-23 10:12   ` Richard Guy Briggs
2017-08-24 16:17   ` Serge E. Hallyn
2017-08-24 16:17     ` Serge E. Hallyn
2017-08-25  5:59   ` James Morris
2017-08-25  5:59     ` James Morris
2017-08-25 15:06   ` Andy Lutomirski
2017-08-25 15:06     ` Andy Lutomirski
2017-08-25 18:51     ` Serge E. Hallyn
2017-08-25 18:51       ` Serge E. Hallyn
2017-08-25 19:45       ` Andy Lutomirski
2017-08-25 19:45         ` Andy Lutomirski
2017-08-25 20:06         ` Serge E. Hallyn
2017-08-25 20:06           ` Serge E. Hallyn
2017-08-28  1:32           ` James Morris
2017-08-28  1:32             ` James Morris
2017-08-28  9:12           ` Richard Guy Briggs
2017-08-28  9:12             ` Richard Guy Briggs
2017-08-28 20:12             ` Andy Lutomirski
2017-08-28 20:12               ` Andy Lutomirski
2017-08-23 10:12 ` [PATCH V3 06/10] capabilities: move audit log decision to function Richard Guy Briggs
2017-08-23 10:12   ` Richard Guy Briggs
2017-08-24 16:18   ` Serge E. Hallyn
2017-08-24 16:18     ` Serge E. Hallyn
2017-08-25  6:01   ` James Morris
2017-08-25  6:01     ` James Morris
2017-08-23 10:12 ` [PATCH V3 07/10] capabilities: remove a layer of conditional logic Richard Guy Briggs
2017-08-23 10:12   ` Richard Guy Briggs
2017-08-24 16:20   ` Serge E. Hallyn
2017-08-24 16:20     ` Serge E. Hallyn
2017-08-25  5:47   ` James Morris
2017-08-25  5:47     ` James Morris
2017-08-25 15:11   ` Andy Lutomirski
2017-08-25 15:11     ` Andy Lutomirski
2017-08-25 18:53     ` Serge E. Hallyn
2017-08-25 18:53       ` Serge E. Hallyn
2017-08-23 10:12 ` [PATCH V3 08/10] capabilities: invert logic for clarity Richard Guy Briggs
2017-08-23 10:12   ` Richard Guy Briggs
2017-08-24 16:23   ` Serge E. Hallyn
2017-08-24 16:23     ` Serge E. Hallyn
2017-08-25  5:47   ` James Morris
2017-08-25  5:47     ` James Morris
2017-08-23 10:13 ` [PATCH V3 09/10] capabilities: fix logic for effective root or real root Richard Guy Briggs
2017-08-23 10:13   ` Richard Guy Briggs
2017-08-24 16:29   ` Serge E. Hallyn
2017-08-24 16:29     ` Serge E. Hallyn
2017-08-24 16:44     ` Richard Guy Briggs
2017-08-24 16:44       ` Richard Guy Briggs
2017-08-24 16:47       ` Serge E. Hallyn
2017-08-24 16:47         ` Serge E. Hallyn
2017-08-25  5:48   ` James Morris
2017-08-25  5:48     ` James Morris
2017-08-23 10:13 ` [PATCH V3 10/10] capabilities: audit log other surprising conditions Richard Guy Briggs
2017-08-23 10:13   ` Richard Guy Briggs
2017-08-24 16:35   ` Serge E. Hallyn
2017-08-24 16:35     ` Serge E. Hallyn
2017-08-25  5:50   ` James Morris
2017-08-25  5:50     ` James Morris

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to='CAHC9VhRzH=gHrBLPHB2GkeR_5pJqmoMAzDCH3EtmDfNpvPD0Jg@mail.gmail.com' \
    --to=paul@paul-moore.com \
    --cc=linux-security-module@vger.kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.