All of lore.kernel.org
 help / color / mirror / Atom feed
From: Phil Edworthy <phil.edworthy@renesas.com>
To: Wolfram Sang <wsa@the-dreams.de>
Cc: Bjorn Helgaas <bhelgaas@google.com>,
	Geert Uytterhoeven <geert@linux-m68k.org>,
	Simon Horman <horms@verge.net.au>,
	"linux-pci@vger.kernel.org" <linux-pci@vger.kernel.org>,
	"linux-sh@vger.kernel.org" <linux-sh@vger.kernel.org>,
	"linux-kernel@vger.kernel.org" <linux-kernel@vger.kernel.org>
Subject: RE: [PATCH 1/3] PCI: pcie-rcar: Convert to DT resource parsing API
Date: Mon, 09 Nov 2015 09:31:17 +0000	[thread overview]
Message-ID: <PS1PR06MB11807CD89B1DE501665BB9FCF5150@PS1PR06MB1180.apcprd06.prod.outlook.com> (raw)
In-Reply-To: <20151107132902.GA21726@katana>

Hi Wolfram,

On 07 November 2015 13:29, Wolfram wrote:
> On Mon, Nov 02, 2015 at 04:36:13PM +0000, Phil Edworthy wrote:
> > The main purpose of this change is to avoid calling pci_ioremap_io() as
> > this is not available on arm64. However, instead of doing the range passing
> > in this driver we can utilise of_pci_get_host_bridge_resources().
> >
> > This is similar to changes made to the generic PCI host driver in commit
> > dbf9826d "PCI: generic: Convert to DT resource parsing API".
> >
> > Signed-off-by: Phil Edworthy <phil.edworthy@renesas.com>
> 
> Reported-by: Wolfram Sang <wsa+renesas@sang-engineering.com>
> Tested-by: Wolfram Sang <wsa+renesas@sang-engineering.com>
> 
> Works for me and my USB3 card. I also like going the global io_offset
> variable away and the code readability improved, too, IMO.
> 
> One question:
> 
> 
> > +		case IORESOURCE_MEM:
> > +			parent = &iomem_resource;
> > +			res_valid |= !(res->flags & IORESOURCE_PREFETCH);
> > +			break;
> 
> res_valid doesn't seem to be actually used?
Ah, you are right. I'll remove this & send a v2

Thanks
Phil

WARNING: multiple messages have this Message-ID (diff)
From: Phil Edworthy <phil.edworthy@renesas.com>
To: Wolfram Sang <wsa@the-dreams.de>
Cc: Bjorn Helgaas <bhelgaas@google.com>,
	Geert Uytterhoeven <geert@linux-m68k.org>,
	Simon Horman <horms@verge.net.au>,
	"linux-pci@vger.kernel.org" <linux-pci@vger.kernel.org>,
	"linux-sh@vger.kernel.org" <linux-sh@vger.kernel.org>,
	"linux-kernel@vger.kernel.org" <linux-kernel@vger.kernel.org>
Subject: RE: [PATCH 1/3] PCI: pcie-rcar: Convert to DT resource parsing API
Date: Mon, 9 Nov 2015 09:31:17 +0000	[thread overview]
Message-ID: <PS1PR06MB11807CD89B1DE501665BB9FCF5150@PS1PR06MB1180.apcprd06.prod.outlook.com> (raw)
In-Reply-To: <20151107132902.GA21726@katana>

Hi Wolfram,

On 07 November 2015 13:29, Wolfram wrote:
> On Mon, Nov 02, 2015 at 04:36:13PM +0000, Phil Edworthy wrote:
> > The main purpose of this change is to avoid calling pci_ioremap_io() as
> > this is not available on arm64. However, instead of doing the range passing
> > in this driver we can utilise of_pci_get_host_bridge_resources().
> >
> > This is similar to changes made to the generic PCI host driver in commit
> > dbf9826d "PCI: generic: Convert to DT resource parsing API".
> >
> > Signed-off-by: Phil Edworthy <phil.edworthy@renesas.com>
> 
> Reported-by: Wolfram Sang <wsa+renesas@sang-engineering.com>
> Tested-by: Wolfram Sang <wsa+renesas@sang-engineering.com>
> 
> Works for me and my USB3 card. I also like going the global io_offset
> variable away and the code readability improved, too, IMO.
> 
> One question:
> 
> 
> > +		case IORESOURCE_MEM:
> > +			parent = &iomem_resource;
> > +			res_valid |= !(res->flags & IORESOURCE_PREFETCH);
> > +			break;
> 
> res_valid doesn't seem to be actually used?
Ah, you are right. I'll remove this & send a v2

Thanks
Phil

  reply	other threads:[~2015-11-09  9:31 UTC|newest]

Thread overview: 19+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2015-11-02 16:36 [PATCH 0/3] Fix rcar-pcie for arm64 Phil Edworthy
2015-11-02 16:36 ` Phil Edworthy
2015-11-02 16:36 ` [PATCH 1/3] PCI: pcie-rcar: Convert to DT resource parsing API Phil Edworthy
2015-11-02 16:36   ` Phil Edworthy
2015-11-07 13:29   ` Wolfram Sang
2015-11-07 13:29     ` Wolfram Sang
2015-11-09  9:31     ` Phil Edworthy [this message]
2015-11-09  9:31       ` Phil Edworthy
2015-11-02 16:36 ` [PATCH 2/3] Revert "PCI: rcar: Build pcie-rcar.c only on ARM" Phil Edworthy
2015-11-02 16:36   ` Phil Edworthy
     [not found] ` <1446482175-26507-1-git-send-email-phil.edworthy-zM6kxYcvzFBBDgjK7y7TUQ@public.gmane.org>
2015-11-02 16:36   ` [PATCH 3/3] PCI: pcie-rcar: Add support for R-Car H3 Phil Edworthy
2015-11-02 16:36     ` Phil Edworthy
2015-11-02 16:36     ` Phil Edworthy
2015-11-07 13:29     ` Wolfram Sang
2015-11-07 13:29       ` Wolfram Sang
2015-11-02 21:33 ` [PATCH 0/3] Fix rcar-pcie for arm64 Wolfram Sang
2015-11-02 21:33   ` Wolfram Sang
2015-11-03  9:00   ` Phil Edworthy
2015-11-03  9:00     ` Phil Edworthy

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=PS1PR06MB11807CD89B1DE501665BB9FCF5150@PS1PR06MB1180.apcprd06.prod.outlook.com \
    --to=phil.edworthy@renesas.com \
    --cc=bhelgaas@google.com \
    --cc=geert@linux-m68k.org \
    --cc=horms@verge.net.au \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-pci@vger.kernel.org \
    --cc=linux-sh@vger.kernel.org \
    --cc=wsa@the-dreams.de \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.