linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Sean Christopherson <seanjc@google.com>
To: David Matlack <dmatlack@google.com>
Cc: Paolo Bonzini <pbonzini@redhat.com>,
	LKML <linux-kernel@vger.kernel.org>,
	kvm list <kvm@vger.kernel.org>,
	Vitaly Kuznetsov <vkuznets@redhat.com>
Subject: Re: [PATCH 00/23] KVM: MMU: MMU role refactoring
Date: Thu, 10 Feb 2022 01:11:56 +0000	[thread overview]
Message-ID: <YgRmXDn7b8GQ+VzX@google.com> (raw)
In-Reply-To: <CALzav=d05sMd=ARkV+GMf9SkxKcg9c9n5ttb274M2fZrP27PDA@mail.gmail.com>

On Mon, Feb 07, 2022, David Matlack wrote:
> On Mon, Feb 7, 2022 at 3:27 PM Sean Christopherson <seanjc@google.com> wrote:
> > > What do you think about calling this the guest_role instead of cpu_role?
> > > There is a bit of a precedent for using "guest" instead of "cpu" already
> > > for this type of concept (e.g. guest_walker), and I find it more
> > > intuitive.
> >
> > Haven't looked at the series yet, but I'd prefer not to use guest_role, it's
> > too similar to is_guest_mode() and kvm_mmu_role.guest_mode.  E.g. we'd end up with
> >
> >   static union kvm_mmu_role kvm_calc_guest_role(struct kvm_vcpu *vcpu,
> >                                               const struct kvm_mmu_role_regs *regs)
> >   {
> >         union kvm_mmu_role role = {0};
> >
> >         role.base.access = ACC_ALL;
> >         role.base.smm = is_smm(vcpu);
> >         role.base.guest_mode = is_guest_mode(vcpu);
> >         role.base.direct = !____is_cr0_pg(regs);
> >
> >         ...
> >   }
> >
> > and possibly
> >
> >         if (guest_role.guest_mode)
> >                 ...
> >
> > which would be quite messy.  Maybe vcpu_role if cpu_role isn't intuitive?
> 
> I agree it's a little odd. But actually it's somewhat intuitive (the
> guest is in guest-mode, i.e. we're running a nested guest).
> 
> Ok I'm stretching a little bit :). But if the trade-off is just
> "guest_role.guest_mode" requires a clarifying comment, but the rest of
> the code gets more readable (cpu_role is used a lot more than
> role.guest_mode), it still might be worth it.

It's not just guest_mode, we also have guest_mmu, e.g. we'd end up with

	vcpu->arch.root_mmu.guest_role.base.level
	vcpu->arch.guest_mmu.guest_role.base.level
	vcpu->arch.nested_mmu.guest_role.base.level

In a vacuum, I 100% agree that guest_role is better than cpu_role or vcpu_role,
but the term "guest" has already been claimed for "L2" in far too many places.

While we're behind the bikeshed... the resulting:

	union kvm_mmu_role cpu_role;
	union kvm_mmu_page_role mmu_role;

is a mess.  Again, I really like "mmu_role" in a vacuum, but juxtaposed with
	
	union kvm_mmu_role cpu_role;

it's super confusing, e.g. I expected

	union kvm_mmu_role mmu_role;

Nested EPT is a good example of complete confusion, because we compute kvm_mmu_role,
compare it to cpu_role, then shove it into both cpu_role and mmu_ole.  It makes
sense once you reason about what it's doing, but on the surface it's confusing.

	struct kvm_mmu *context = &vcpu->arch.guest_mmu;
	u8 level = vmx_eptp_page_walk_level(new_eptp);
	union kvm_mmu_role new_role =
		kvm_calc_shadow_ept_root_page_role(vcpu, accessed_dirty,
						   execonly, level);

	if (new_role.as_u64 != context->cpu_role.as_u64) {
		/* EPT, and thus nested EPT, does not consume CR0, CR4, nor EFER. */
		context->cpu_role.as_u64 = new_role.as_u64;
		context->mmu_role.word = new_role.base.word;

Mabye this?

	union kvm_mmu_vcpu_role vcpu_role;
	union kvm_mmu_page_role mmu_role;

and some sample usage?

diff --git a/arch/x86/kvm/mmu/mmu.c b/arch/x86/kvm/mmu/mmu.c
index d25f8cb2e62b..9f9b97c88738 100644
--- a/arch/x86/kvm/mmu/mmu.c
+++ b/arch/x86/kvm/mmu/mmu.c
@@ -4836,13 +4836,16 @@ void kvm_init_shadow_ept_mmu(struct kvm_vcpu *vcpu, bool execonly,
 {
        struct kvm_mmu *context = &vcpu->arch.guest_mmu;
        u8 level = vmx_eptp_page_walk_level(new_eptp);
-       union kvm_mmu_role new_role =
+       union kvm_mmu_vcpu_role new_role =
                kvm_calc_shadow_ept_root_page_role(vcpu, accessed_dirty,
                                                   execonly, level);

-       if (new_role.as_u64 != context->cpu_role.as_u64) {
-               /* EPT, and thus nested EPT, does not consume CR0, CR4, nor EFER. */
-               context->cpu_role.as_u64 = new_role.as_u64;
+       if (new_role.as_u64 != context->vcpu_role.as_u64) {
+               /*
+                * EPT, and thus nested EPT, does not consume CR0, CR4, nor
+                * EFER, so the mmu_role is a strict subset of the vcpu_role.
+               */
+               context->vcpu_role.as_u64 = new_role.as_u64;
                context->mmu_role.word = new_role.base.word;

                context->page_fault = ept_page_fault;



And while I'm on a soapbox....  am I the only one that absolutely detests the use
of "context" and "g_context"?  I'd be all in favor of renaming those to "mmu"
throughout the code as a prep to this series.

I also think we should move the initializing of guest_mmu => mmu into the MMU
helpers.  Pulling the mmu from guest_mmu but then relying on the caller to wire
up guest_mmu => mmu so that e.g. kvm_mmu_new_pgd() works is gross and confused
the heck out of me.  E.g.

diff --git a/arch/x86/kvm/mmu/mmu.c b/arch/x86/kvm/mmu/mmu.c
index d25f8cb2e62b..4e7fe9758ce8 100644
--- a/arch/x86/kvm/mmu/mmu.c
+++ b/arch/x86/kvm/mmu/mmu.c
@@ -4794,7 +4794,7 @@ static void kvm_init_shadow_mmu(struct kvm_vcpu *vcpu,
 void kvm_init_shadow_npt_mmu(struct kvm_vcpu *vcpu, unsigned long cr0,
                             unsigned long cr4, u64 efer, gpa_t nested_cr3)
 {
-       struct kvm_mmu *context = &vcpu->arch.guest_mmu;
+       struct kvm_mmu *mmu = &vcpu->arch.guest_mmu;
        struct kvm_mmu_role_regs regs = {
                .cr0 = cr0,
                .cr4 = cr4 & ~X86_CR4_PKE,
@@ -4806,6 +4806,8 @@ void kvm_init_shadow_npt_mmu(struct kvm_vcpu *vcpu, unsigned long cr0,
        mmu_role = cpu_role.base;
        mmu_role.level = kvm_mmu_get_tdp_level(vcpu);

+       vcpu->arch.mmu = &vcpu->arch.guest_mmu;
+
        shadow_mmu_init_context(vcpu, context, cpu_role, mmu_role);
        kvm_mmu_new_pgd(vcpu, nested_cr3);
 }
@@ -4834,12 +4836,14 @@ void kvm_init_shadow_ept_mmu(struct kvm_vcpu *vcpu, bool execonly,
                             int huge_page_level, bool accessed_dirty,
                             gpa_t new_eptp)
 {
-       struct kvm_mmu *context = &vcpu->arch.guest_mmu;
+       struct kvm_mmu *mmu = &vcpu->arch.guest_mmu;
        u8 level = vmx_eptp_page_walk_level(new_eptp);
        union kvm_mmu_role new_role =
                kvm_calc_shadow_ept_root_page_role(vcpu, accessed_dirty,
                                                   execonly, level);

+       vcpu->arch.mmu = mmu;
+
        if (new_role.as_u64 != context->cpu_role.as_u64) {
                /* EPT, and thus nested EPT, does not consume CR0, CR4, nor EFER. */
                context->cpu_role.as_u64 = new_role.as_u64;
diff --git a/arch/x86/kvm/svm/nested.c b/arch/x86/kvm/svm/nested.c
index 1218b5a342fc..d0f8eddb32be 100644
--- a/arch/x86/kvm/svm/nested.c
+++ b/arch/x86/kvm/svm/nested.c
@@ -98,8 +98,6 @@ static void nested_svm_init_mmu_context(struct kvm_vcpu *vcpu)

        WARN_ON(mmu_is_nested(vcpu));

-       vcpu->arch.mmu = &vcpu->arch.guest_mmu;
-
        /*
         * The NPT format depends on L1's CR4 and EFER, which is in vmcb01.  Note,
         * when called via KVM_SET_NESTED_STATE, that state may _not_ match current




  reply	other threads:[~2022-02-10  1:57 UTC|newest]

Thread overview: 72+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2022-02-04 11:56 [PATCH 00/23] KVM: MMU: MMU role refactoring Paolo Bonzini
2022-02-04 11:56 ` [PATCH 01/23] KVM: MMU: pass uses_nx directly to reset_shadow_zero_bits_mask Paolo Bonzini
2022-02-04 17:59   ` David Matlack
2022-02-05 14:52     ` Paolo Bonzini
2022-02-07 16:09       ` Sean Christopherson
2022-02-07 21:50         ` David Matlack
2022-02-10  0:30     ` Sean Christopherson
2022-02-10 16:38       ` Paolo Bonzini
2022-02-04 11:56 ` [PATCH 02/23] KVM: MMU: nested EPT cannot be used in SMM Paolo Bonzini
2022-02-04 18:16   ` David Matlack
2022-02-09 22:43     ` Sean Christopherson
2022-02-04 11:56 ` [PATCH 03/23] KVM: MMU: remove valid from extended role Paolo Bonzini
2022-02-04 18:32   ` David Matlack
2022-02-05 14:50     ` Paolo Bonzini
2022-02-09 22:54   ` Sean Christopherson
2022-02-10  9:53     ` Paolo Bonzini
2022-02-04 11:56 ` [PATCH 04/23] KVM: MMU: constify uses of struct kvm_mmu_role_regs Paolo Bonzini
2022-02-04 18:41   ` David Matlack
2022-02-09 22:57   ` Sean Christopherson
2022-02-04 11:57 ` [PATCH 05/23] KVM: MMU: pull computation of kvm_mmu_role_regs to kvm_init_mmu Paolo Bonzini
2022-02-04 18:45   ` David Matlack
2022-02-04 11:57 ` [PATCH 06/23] KVM: MMU: load new PGD once nested two-dimensional paging is initialized Paolo Bonzini
2022-02-04 19:18   ` David Matlack
2022-02-07 13:50     ` Paolo Bonzini
2022-02-07 14:35       ` Paolo Bonzini
2022-02-09 12:34     ` Paolo Bonzini
2022-02-04 11:57 ` [PATCH 07/23] KVM: MMU: remove kvm_mmu_calc_root_page_role Paolo Bonzini
2022-02-04 19:32   ` David Matlack
2022-02-05 14:46     ` Paolo Bonzini
2022-02-10  0:47   ` Sean Christopherson
2022-02-10  9:52     ` Paolo Bonzini
2022-02-10 17:29       ` Sean Christopherson
2022-02-10 17:43         ` Paolo Bonzini
2022-02-04 11:57 ` [PATCH 08/23] KVM: MMU: rephrase unclear comment Paolo Bonzini
2022-02-04 19:38   ` David Matlack
2022-02-04 11:57 ` [PATCH 09/23] KVM: MMU: remove "bool base_only" arguments Paolo Bonzini
2022-02-04 19:41   ` David Matlack
2022-02-04 11:57 ` [PATCH 10/23] KVM: MMU: split cpu_role from mmu_role Paolo Bonzini
2022-02-04 21:57   ` David Matlack
2022-02-05 14:49     ` Paolo Bonzini
2022-02-07 21:38       ` David Matlack
2022-02-04 11:57 ` [PATCH 11/23] KVM: MMU: do not recompute root level from kvm_mmu_role_regs Paolo Bonzini
2022-02-07 22:10   ` David Matlack
2022-02-07 22:17     ` David Matlack
2022-02-04 11:57 ` [PATCH 12/23] KVM: MMU: remove ept_ad field Paolo Bonzini
2022-02-04 11:57 ` [PATCH 13/23] KVM: MMU: remove kvm_calc_shadow_root_page_role_common Paolo Bonzini
2022-02-07 22:25   ` David Matlack
2022-02-04 11:57 ` [PATCH 14/23] KVM: MMU: cleanup computation of MMU roles for two-dimensional paging Paolo Bonzini
2022-02-04 11:57 ` [PATCH 15/23] KVM: MMU: cleanup computation of MMU roles for shadow paging Paolo Bonzini
2022-02-04 11:57 ` [PATCH 16/23] KVM: MMU: remove extended bits from mmu_role Paolo Bonzini
2022-02-04 11:57 ` [PATCH 17/23] KVM: MMU: remove redundant bits from extended role Paolo Bonzini
2022-02-04 11:57 ` [PATCH 18/23] KVM: MMU: fetch shadow EFER.NX from MMU role Paolo Bonzini
2022-02-04 11:57 ` [PATCH 19/23] KVM: MMU: simplify and/or inline computation of shadow MMU roles Paolo Bonzini
2022-02-04 11:57 ` [PATCH 20/23] KVM: MMU: pull CPU role computation to kvm_init_mmu Paolo Bonzini
2022-02-07 22:42   ` David Matlack
2022-02-04 11:57 ` [PATCH 21/23] KVM: MMU: store shadow_root_level into mmu_role Paolo Bonzini
2022-02-07 23:00   ` David Matlack
2022-02-04 11:57 ` [PATCH 22/23] KVM: MMU: use cpu_role for root_level Paolo Bonzini
2022-02-07 23:01   ` David Matlack
2022-02-04 11:57 ` [PATCH 23/23] KVM: MMU: replace direct_map with mmu_role.direct Paolo Bonzini
2022-02-07 23:02   ` David Matlack
2022-02-07 23:08 ` [PATCH 00/23] KVM: MMU: MMU role refactoring David Matlack
2022-02-07 23:27   ` Sean Christopherson
2022-02-07 23:53     ` David Matlack
2022-02-10  1:11       ` Sean Christopherson [this message]
2022-02-10 11:58         ` Paolo Bonzini
2022-02-10 16:55           ` Sean Christopherson
2022-02-10 17:30             ` Paolo Bonzini
2022-02-10 19:28               ` Sean Christopherson
2022-02-09 22:31 ` Sean Christopherson
2022-02-10  9:54   ` Paolo Bonzini
2022-02-14 18:14   ` David Matlack

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=YgRmXDn7b8GQ+VzX@google.com \
    --to=seanjc@google.com \
    --cc=dmatlack@google.com \
    --cc=kvm@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=pbonzini@redhat.com \
    --cc=vkuznets@redhat.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).