All of lore.kernel.org
 help / color / mirror / Atom feed
From: Alexander Kochetkov <al.kochet@gmail.com>
To: Daniel Lezcano <daniel.lezcano@linaro.org>
Cc: Heiko Stuebner <heiko@sntech.de>,
	LKML <linux-kernel@vger.kernel.org>,
	devicetree@vger.kernel.org,
	LAK <linux-arm-kernel@lists.infradead.org>,
	linux-rockchip@lists.infradead.org,
	Thomas Gleixner <tglx@linutronix.de>,
	Mark Rutland <mark.rutland@arm.com>,
	Rob Herring <robh+dt@kernel.org>,
	Russell King <linux@armlinux.org.uk>,
	Caesar Wang <wxt@rock-chips.com>,
	Huang Tao <huangtao@rock-chips.com>
Subject: Re: [PATCH v5 5/8] clocksource/drivers/rockchip_timer: split bc_timer into rk_timer and rk_clock_event_device
Date: Mon, 30 Jan 2017 16:55:33 +0300	[thread overview]
Message-ID: <0E7077EE-0D5A-4653-99EF-E8F2E8FD2FB0@gmail.com> (raw)
In-Reply-To: <20170130131258.GF2206@mai>


> 30 янв. 2017 г., в 16:12, Daniel Lezcano <daniel.lezcano@linaro.org> написал(а):
> 
> I don't get the point of these changes. The patch does not explain why they are
> needed.

I’d like to extract timer API from current implementation.
And to make code more readable I’d like to introduce 'struct rk_timer’ what can be
reused with current implementation and with my patch (8/8). And in order keep patches
simple and readable I split that into three patches: 5/8, 6/8, 7/8.

Current implementation named rockchip timer as ‘struct bc_timer’ (broadcast timer).
I renamed it to more suitable to it role (may be bad choice).

Yes, the patch itself looks strange. You are right.

What do you think about that solution:
- in the patch 6/8 i will Introduce 'struct rk_timer’ and 'struct rk_time_clkevt’ (renamed ‘struct bc_timer’).
- rk_timer_init() changes from 5/8 I will merge with 8/8
- 8/8 introduce 'struct rk_time_clksrc' 
- 5/8 drop

Alexander.

WARNING: multiple messages have this Message-ID (diff)
From: Alexander Kochetkov <al.kochet-Re5JQEeQqe8AvxtiuMwx3w@public.gmane.org>
To: Daniel Lezcano <daniel.lezcano-QSEj5FYQhm4dnm+yROfE0A@public.gmane.org>
Cc: Heiko Stuebner <heiko-4mtYJXux2i+zQB+pC5nmwQ@public.gmane.org>,
	LKML <linux-kernel-u79uwXL29TY76Z2rM5mHXA@public.gmane.org>,
	devicetree-u79uwXL29TY76Z2rM5mHXA@public.gmane.org,
	LAK
	<linux-arm-kernel-IAPFreCvJWM7uuMidbF8XUB+6BGkLq7r@public.gmane.org>,
	linux-rockchip-IAPFreCvJWM7uuMidbF8XUB+6BGkLq7r@public.gmane.org,
	Thomas Gleixner <tglx-hfZtesqFncYOwBW4kG4KsQ@public.gmane.org>,
	Mark Rutland <mark.rutland-5wv7dgnIgG8@public.gmane.org>,
	Rob Herring <robh+dt-DgEjT+Ai2ygdnm+yROfE0A@public.gmane.org>,
	Russell King <linux-I+IVW8TIWO2tmTQ+vhA3Yw@public.gmane.org>,
	Caesar Wang <wxt-TNX95d0MmH7DzftRWevZcw@public.gmane.org>,
	Huang Tao <huangtao-TNX95d0MmH7DzftRWevZcw@public.gmane.org>
Subject: Re: [PATCH v5 5/8] clocksource/drivers/rockchip_timer: split bc_timer into rk_timer and rk_clock_event_device
Date: Mon, 30 Jan 2017 16:55:33 +0300	[thread overview]
Message-ID: <0E7077EE-0D5A-4653-99EF-E8F2E8FD2FB0@gmail.com> (raw)
In-Reply-To: <20170130131258.GF2206@mai>


> 30 янв. 2017 г., в 16:12, Daniel Lezcano <daniel.lezcano-QSEj5FYQhm4dnm+yROfE0A@public.gmane.org> написал(а):
> 
> I don't get the point of these changes. The patch does not explain why they are
> needed.

I’d like to extract timer API from current implementation.
And to make code more readable I’d like to introduce 'struct rk_timer’ what can be
reused with current implementation and with my patch (8/8). And in order keep patches
simple and readable I split that into three patches: 5/8, 6/8, 7/8.

Current implementation named rockchip timer as ‘struct bc_timer’ (broadcast timer).
I renamed it to more suitable to it role (may be bad choice).

Yes, the patch itself looks strange. You are right.

What do you think about that solution:
- in the patch 6/8 i will Introduce 'struct rk_timer’ and 'struct rk_time_clkevt’ (renamed ‘struct bc_timer’).
- rk_timer_init() changes from 5/8 I will merge with 8/8
- 8/8 introduce 'struct rk_time_clksrc' 
- 5/8 drop

Alexander.

--
To unsubscribe from this list: send the line "unsubscribe devicetree" in
the body of a message to majordomo-u79uwXL29TY76Z2rM5mHXA@public.gmane.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

WARNING: multiple messages have this Message-ID (diff)
From: al.kochet@gmail.com (Alexander Kochetkov)
To: linux-arm-kernel@lists.infradead.org
Subject: [PATCH v5 5/8] clocksource/drivers/rockchip_timer: split bc_timer into rk_timer and rk_clock_event_device
Date: Mon, 30 Jan 2017 16:55:33 +0300	[thread overview]
Message-ID: <0E7077EE-0D5A-4653-99EF-E8F2E8FD2FB0@gmail.com> (raw)
In-Reply-To: <20170130131258.GF2206@mai>


> 30 ???. 2017 ?., ? 16:12, Daniel Lezcano <daniel.lezcano@linaro.org> ???????(?):
> 
> I don't get the point of these changes. The patch does not explain why they are
> needed.

I?d like to extract timer API from current implementation.
And to make code more readable I?d like to introduce 'struct rk_timer? what can be
reused with current implementation and with my patch (8/8). And in order keep patches
simple and readable I split that into three patches: 5/8, 6/8, 7/8.

Current implementation named rockchip timer as ?struct bc_timer? (broadcast timer).
I renamed it to more suitable to it role (may be bad choice).

Yes, the patch itself looks strange. You are right.

What do you think about that solution:
- in the patch 6/8 i will Introduce 'struct rk_timer? and 'struct rk_time_clkevt? (renamed ?struct bc_timer?).
- rk_timer_init() changes from 5/8 I will merge with 8/8
- 8/8 introduce 'struct rk_time_clksrc' 
- 5/8 drop

Alexander.

  reply	other threads:[~2017-01-30 13:55 UTC|newest]

Thread overview: 58+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2017-01-24 12:16 [PATCH v5 0/8] Implement clocksource for rockchip SoC using rockchip timer Alexander Kochetkov
2017-01-24 12:16 ` Alexander Kochetkov
2017-01-24 12:16 ` Alexander Kochetkov
2017-01-24 12:16 ` [PATCH v5 1/8] dt-bindings: clarify compatible property for rockchip timers Alexander Kochetkov
2017-01-24 12:16   ` Alexander Kochetkov
2017-01-24 12:16   ` Alexander Kochetkov
2017-01-24 12:16 ` [PATCH v5 2/8] ARM: dts: rockchip: update compatible property for rk322x timer Alexander Kochetkov
2017-01-24 12:16   ` Alexander Kochetkov
2017-01-24 12:16 ` [PATCH v5 3/8] ARM: dts: rockchip: add timer entries to rk3188 SoC Alexander Kochetkov
2017-01-24 12:16   ` Alexander Kochetkov
2017-01-30 11:04   ` Daniel Lezcano
2017-01-30 11:04     ` Daniel Lezcano
2017-01-30 11:04     ` Daniel Lezcano
2017-01-30 11:20     ` Alexander Kochetkov
2017-01-30 11:20       ` Alexander Kochetkov
2017-01-30 12:04       ` Daniel Lezcano
2017-01-30 12:04         ` Daniel Lezcano
2017-01-30 13:13         ` Alexander Kochetkov
2017-01-30 13:13           ` Alexander Kochetkov
2017-01-30 13:13           ` Alexander Kochetkov
2017-01-30 13:35           ` Daniel Lezcano
2017-01-30 13:35             ` Daniel Lezcano
2017-01-30 13:35             ` Daniel Lezcano
2017-01-24 12:16 ` [PATCH v5 4/8] ARM: dts: rockchip: disable arm-global-timer for rk3188 Alexander Kochetkov
2017-01-24 12:16   ` Alexander Kochetkov
2017-01-30 10:21   ` Daniel Lezcano
2017-01-30 10:21     ` Daniel Lezcano
2017-01-24 12:16 ` [PATCH v5 5/8] clocksource/drivers/rockchip_timer: split bc_timer into rk_timer and rk_clock_event_device Alexander Kochetkov
2017-01-24 12:16   ` Alexander Kochetkov
2017-01-24 12:16   ` Alexander Kochetkov
2017-01-24 15:02   ` Heiko Stübner
2017-01-24 15:02     ` Heiko Stübner
2017-01-24 15:02     ` Heiko Stübner
2017-01-24 15:16     ` Alexander Kochetkov
2017-01-24 15:16       ` Alexander Kochetkov
2017-01-24 15:16       ` Alexander Kochetkov
2017-01-29 20:30       ` Heiko Stuebner
2017-01-29 20:30         ` Heiko Stuebner
2017-01-29 20:30         ` Heiko Stuebner
2017-01-30 13:12   ` Daniel Lezcano
2017-01-30 13:12     ` Daniel Lezcano
2017-01-30 13:12     ` Daniel Lezcano
2017-01-30 13:55     ` Alexander Kochetkov [this message]
2017-01-30 13:55       ` Alexander Kochetkov
2017-01-30 13:55       ` Alexander Kochetkov
2017-01-30 14:20       ` Daniel Lezcano
2017-01-30 14:20         ` Daniel Lezcano
2017-01-30 14:20         ` Daniel Lezcano
2017-01-24 12:16 ` [PATCH v5 6/8] clocksource/drivers/rockchip_timer: low level routines take rk_timer as parameter Alexander Kochetkov
2017-01-24 12:16   ` Alexander Kochetkov
2017-01-24 12:16 ` [PATCH v5 7/8] clocksource/drivers/rockchip_timer: move TIMER_INT_UNMASK out of rk_timer_enable() Alexander Kochetkov
2017-01-24 12:16   ` Alexander Kochetkov
2017-01-24 12:16 ` [PATCH v5 8/8] clocksource/drivers/rockchip_timer: implement clocksource timer Alexander Kochetkov
2017-01-24 12:16   ` Alexander Kochetkov
2017-01-24 12:16   ` Alexander Kochetkov
2017-01-30 13:54   ` Daniel Lezcano
2017-01-30 13:54     ` Daniel Lezcano
2017-01-30 13:54     ` Daniel Lezcano

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=0E7077EE-0D5A-4653-99EF-E8F2E8FD2FB0@gmail.com \
    --to=al.kochet@gmail.com \
    --cc=daniel.lezcano@linaro.org \
    --cc=devicetree@vger.kernel.org \
    --cc=heiko@sntech.de \
    --cc=huangtao@rock-chips.com \
    --cc=linux-arm-kernel@lists.infradead.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-rockchip@lists.infradead.org \
    --cc=linux@armlinux.org.uk \
    --cc=mark.rutland@arm.com \
    --cc=robh+dt@kernel.org \
    --cc=tglx@linutronix.de \
    --cc=wxt@rock-chips.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.