All of lore.kernel.org
 help / color / mirror / Atom feed
From: Joe Perches <joe@perches.com>
To: Dan Williams <dan.j.williams@intel.com>,
	Vishal Verma <vishal.l.verma@intel.com>,
	Dave Jiang <dave.jiang@intel.com>,
	Keith Busch <keith.busch@intel.com>,
	Ira Weiny <ira.weiny@intel.com>
Cc: linux-kernel@vger.kernel.org,
	Dan Carpenter <dan.carpenter@oracle.com>,
	linux-nvdimm@lists.01.org
Subject: [PATCH 05/13] nvdimm: Use "unsigned int" in preference to "unsigned"
Date: Wed, 11 Sep 2019 19:54:35 -0700	[thread overview]
Message-ID: <11b118ab06da3d2c54fe3ec62f42bd89914878bc.1568256707.git.joe@perches.com> (raw)
In-Reply-To: <cover.1568256705.git.joe@perches.com>

Use the more common kernel type.

Signed-off-by: Joe Perches <joe@perches.com>
---
 drivers/nvdimm/label.c | 2 +-
 drivers/nvdimm/nd.h    | 6 +++---
 2 files changed, 4 insertions(+), 4 deletions(-)

diff --git a/drivers/nvdimm/label.c b/drivers/nvdimm/label.c
index 2c780c5352dc..5700d9b35b8f 100644
--- a/drivers/nvdimm/label.c
+++ b/drivers/nvdimm/label.c
@@ -34,7 +34,7 @@ static u32 best_seq(u32 a, u32 b)
 		return a;
 }
 
-unsigned sizeof_namespace_label(struct nvdimm_drvdata *ndd)
+unsigned int sizeof_namespace_label(struct nvdimm_drvdata *ndd)
 {
 	return ndd->nslabel_size;
 }
diff --git a/drivers/nvdimm/nd.h b/drivers/nvdimm/nd.h
index c10a4b94d44a..1636061b1f93 100644
--- a/drivers/nvdimm/nd.h
+++ b/drivers/nvdimm/nd.h
@@ -81,7 +81,7 @@ static inline struct nd_namespace_index *to_next_namespace_index(
 	return to_namespace_index(ndd, ndd->ns_next);
 }
 
-unsigned sizeof_namespace_label(struct nvdimm_drvdata *ndd);
+unsigned int sizeof_namespace_label(struct nvdimm_drvdata *ndd);
 
 #define namespace_label_has(ndd, field)			\
 	(offsetof(struct nd_namespace_label, field)	\
@@ -170,9 +170,9 @@ struct nd_blk_region {
 /*
  * Lookup next in the repeating sequence of 01, 10, and 11.
  */
-static inline unsigned nd_inc_seq(unsigned seq)
+static inline unsigned int nd_inc_seq(unsigned int seq)
 {
-	static const unsigned next[] = { 0, 2, 3, 1 };
+	static const unsigned int next[] = { 0, 2, 3, 1 };
 
 	return next[seq & 3];
 }
-- 
2.15.0

_______________________________________________
Linux-nvdimm mailing list
Linux-nvdimm@lists.01.org
https://lists.01.org/mailman/listinfo/linux-nvdimm

WARNING: multiple messages have this Message-ID (diff)
From: Joe Perches <joe@perches.com>
To: Dan Williams <dan.j.williams@intel.com>,
	Vishal Verma <vishal.l.verma@intel.com>,
	Dave Jiang <dave.jiang@intel.com>,
	Keith Busch <keith.busch@intel.com>,
	Ira Weiny <ira.weiny@intel.com>
Cc: Dan Carpenter <dan.carpenter@oracle.com>,
	linux-nvdimm@lists.01.org, linux-kernel@vger.kernel.org
Subject: [PATCH 05/13] nvdimm: Use "unsigned int" in preference to "unsigned"
Date: Wed, 11 Sep 2019 19:54:35 -0700	[thread overview]
Message-ID: <11b118ab06da3d2c54fe3ec62f42bd89914878bc.1568256707.git.joe@perches.com> (raw)
In-Reply-To: <cover.1568256705.git.joe@perches.com>

Use the more common kernel type.

Signed-off-by: Joe Perches <joe@perches.com>
---
 drivers/nvdimm/label.c | 2 +-
 drivers/nvdimm/nd.h    | 6 +++---
 2 files changed, 4 insertions(+), 4 deletions(-)

diff --git a/drivers/nvdimm/label.c b/drivers/nvdimm/label.c
index 2c780c5352dc..5700d9b35b8f 100644
--- a/drivers/nvdimm/label.c
+++ b/drivers/nvdimm/label.c
@@ -34,7 +34,7 @@ static u32 best_seq(u32 a, u32 b)
 		return a;
 }
 
-unsigned sizeof_namespace_label(struct nvdimm_drvdata *ndd)
+unsigned int sizeof_namespace_label(struct nvdimm_drvdata *ndd)
 {
 	return ndd->nslabel_size;
 }
diff --git a/drivers/nvdimm/nd.h b/drivers/nvdimm/nd.h
index c10a4b94d44a..1636061b1f93 100644
--- a/drivers/nvdimm/nd.h
+++ b/drivers/nvdimm/nd.h
@@ -81,7 +81,7 @@ static inline struct nd_namespace_index *to_next_namespace_index(
 	return to_namespace_index(ndd, ndd->ns_next);
 }
 
-unsigned sizeof_namespace_label(struct nvdimm_drvdata *ndd);
+unsigned int sizeof_namespace_label(struct nvdimm_drvdata *ndd);
 
 #define namespace_label_has(ndd, field)			\
 	(offsetof(struct nd_namespace_label, field)	\
@@ -170,9 +170,9 @@ struct nd_blk_region {
 /*
  * Lookup next in the repeating sequence of 01, 10, and 11.
  */
-static inline unsigned nd_inc_seq(unsigned seq)
+static inline unsigned int nd_inc_seq(unsigned int seq)
 {
-	static const unsigned next[] = { 0, 2, 3, 1 };
+	static const unsigned int next[] = { 0, 2, 3, 1 };
 
 	return next[seq & 3];
 }
-- 
2.15.0


  parent reply	other threads:[~2019-09-12  2:55 UTC|newest]

Thread overview: 68+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2019-09-12  2:54 [PATCH 00/13] nvdimm: Use more common kernel coding style Joe Perches
2019-09-12  2:54 ` Joe Perches
2019-09-12  2:54 ` [PATCH 01/13] nvdimm: Use more typical whitespace Joe Perches
2019-09-12  2:54   ` Joe Perches
2019-09-12 12:17   ` Christoph Hellwig
2019-09-12 12:17     ` Christoph Hellwig
2019-09-12 15:01     ` Joe Perches
2019-09-12 15:01       ` Joe Perches
2019-09-16  7:07       ` Christoph Hellwig
2019-09-16  7:07         ` Christoph Hellwig
2019-09-12  2:54 ` [PATCH 02/13] nvdimm: Move logical continuations to previous line Joe Perches
2019-09-12  2:54   ` Joe Perches
2019-09-12  2:54 ` [PATCH 03/13] nvdimm: Use octal permissions Joe Perches
2019-09-12  2:54   ` Joe Perches
2019-09-12  2:54 ` [PATCH 04/13] nvdimm: Use a more common kernel spacing style Joe Perches
2019-09-12  2:54   ` Joe Perches
2019-09-12  2:54 ` Joe Perches [this message]
2019-09-12  2:54   ` [PATCH 05/13] nvdimm: Use "unsigned int" in preference to "unsigned" Joe Perches
2019-09-12  2:54 ` [PATCH 06/13] nvdimm: Add and remove blank lines Joe Perches
2019-09-12  2:54   ` Joe Perches
2019-09-12  2:54 ` [PATCH 07/13] nvdimm: Use typical kernel brace styles Joe Perches
2019-09-12  2:54   ` Joe Perches
2019-09-12  2:54 ` [PATCH 08/13] nvdimm: Use typical kernel style indentation Joe Perches
2019-09-12  2:54   ` Joe Perches
2019-09-12  2:54 ` [PATCH 09/13] nvdimm: btt.h: Neaten #defines to improve readability Joe Perches
2019-09-12  2:54   ` Joe Perches
2019-09-12  2:54 ` [PATCH 10/13] nvdimm: namespace_devs: Move assignment operators Joe Perches
2019-09-12  2:54   ` Joe Perches
2019-09-12  2:54 ` [PATCH 11/13] nvdimm: Use more common logic testing styles and bare ; positions Joe Perches
2019-09-12  2:54   ` Joe Perches
2019-09-12  3:52   ` Verma, Vishal L
2019-09-12  3:52     ` Verma, Vishal L
2019-09-12  2:54 ` [PATCH 12/13] nvdimm: namespace_devs: Change progess typo to progress Joe Perches
2019-09-12  2:54   ` Joe Perches
2019-09-12  2:54 ` [PATCH 13/13] nvdimm: Miscellaneous neatening Joe Perches
2019-09-12  2:54   ` Joe Perches
2019-09-12  8:00 ` [PATCH 00/13] nvdimm: Use more common kernel coding style Dan Williams
2019-09-12  8:00   ` Dan Williams
2019-09-12  8:15   ` Joe Perches
2019-09-12  8:15     ` Joe Perches
2019-09-12  8:42     ` Miguel Ojeda
2019-09-12  8:42       ` Miguel Ojeda
2019-09-12 14:00 ` Jeff Moyer
2019-09-12 14:00   ` Jeff Moyer
2019-09-12 14:06   ` Johannes Thumshirn
2019-09-12 14:06     ` Johannes Thumshirn
2019-09-12 14:35     ` Dan Williams
2019-09-12 14:35       ` Dan Williams
2019-09-12 14:21   ` Miguel Ojeda
2019-09-12 14:21     ` Miguel Ojeda
2019-09-12 21:08     ` Joe Perches
2019-09-12 21:08       ` Joe Perches
2019-09-12 21:58       ` Miguel Ojeda
2019-09-12 21:58         ` Miguel Ojeda
2019-09-12 22:15         ` Joe Perches
2019-09-12 22:15           ` Joe Perches
2019-09-12 22:38         ` Joe Perches
2019-09-12 22:38           ` Joe Perches
2019-09-12 23:00           ` Nick Desaulniers
2019-09-12 23:00             ` Nick Desaulniers
2019-09-12 23:07             ` Joe Perches
2019-09-12 23:07               ` Joe Perches
2019-09-12 22:58         ` Nick Desaulniers
2019-09-12 22:58           ` Nick Desaulniers
2019-09-12 23:26         ` clang-format and 'clang-format on' and 'clang-format off' Joe Perches
2019-09-12 23:26           ` Joe Perches
2019-09-15 18:25           ` Miguel Ojeda
2019-09-15 18:25             ` Miguel Ojeda

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=11b118ab06da3d2c54fe3ec62f42bd89914878bc.1568256707.git.joe@perches.com \
    --to=joe@perches.com \
    --cc=dan.carpenter@oracle.com \
    --cc=dan.j.williams@intel.com \
    --cc=dave.jiang@intel.com \
    --cc=ira.weiny@intel.com \
    --cc=keith.busch@intel.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-nvdimm@lists.01.org \
    --cc=vishal.l.verma@intel.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.