All of lore.kernel.org
 help / color / mirror / Atom feed
From: Nicolin Chen <nicoleotsuka@gmail.com>
To: broonie@kernel.org
Cc: linux-kernel@vger.kernel.org, linuxppc-dev@lists.ozlabs.org,
	alsa-devel@alsa-project.org, lgirdwood@gmail.com,
	fabio.estevam@nxp.com, timur@tabi.org,
	mail@maciej.szmigiero.name, caleb@crome.org,
	arnaud.mouiche@invoxia.com, lukma@denx.de, kernel@pengutronix.de
Subject: [PATCH v2 00/11] ASoC: fsl_ssi: Clean up - coding style level
Date: Tue, 12 Dec 2017 22:34:23 -0800	[thread overview]
Message-ID: <1513146874-25476-1-git-send-email-nicoleotsuka@gmail.com> (raw)

==Changelog==
v1->v2
 * Dropped one patch to remove "struct device"
 * Revised PATCH-03 "Refine all comments"
 * Revised PATCH-05 "Refine indentations and wrappings"
 * Rebased all other patches
 * Added PATCH-10 "Rename i2smode to i2s_net"
 * Added PATCH-11 "Define ternary macros to simplify code"

 # Detialed changes are described in each updated patch.

==Background==
The fsl_ssi driver was designed for PPC originally and then it has
been updated to support different modes for i.MX Series, including
SDMA, I2S Master mode, AC97 and older i.MXs with FIQ, by different
contributors for different use cases in different coding styles.

Additionally, in order to fix/work-around hardware bugs and design
flaws, the driver made a lot of compromise so now its program flow
looks very complicated and it's getting hard to maintain or update.

So I am going to clean up the driver on both coding style level and
program flow level.

==Introduction==
This series of patches is the first set to clean up fsl_ssi driver
in the coding style level. Any patch here is not supposed to change
the program flow.

==Verification==
Theoretically, since these patches do not change program flow, they
only need code review, build or sanity tests. I have done build and
sanity tests on an i.MX6SoloX with WM8962 using imx_v6_v7_defconfig
and playback/record tests in I2S Master/Slave modes.

Nicolin Chen (11):
  ASoC: fsl_ssi: Rename fsl_ssi_private to fsl_ssi
  ASoC: fsl_ssi: Cache pdev->dev pointer
  ASoC: fsl_ssi: Refine all comments
  ASoC: fsl_ssi: Rename registers and fields macros
  ASoC: fsl_ssi: Refine indentations and wrappings
  ASoC: fsl_ssi: Refine printk outputs
  ASoC: fsl_ssi: Rename cpu_dai parameter to dai
  ASoC: fsl_ssi: Rename scr_val to scr
  ASoC: fsl_ssi: Replace fsl_ssi_rxtx_reg_val with fsl_ssi_regvals
  ASoC: fsl_ssi: Rename i2smode to i2s_net
  ASoC: fsl_ssi: Define ternary macros to simplify code

 sound/soc/fsl/fsl_ssi.c     | 1373 +++++++++++++++++++------------------------
 sound/soc/fsl/fsl_ssi.h     |  427 ++++++++------
 sound/soc/fsl/fsl_ssi_dbg.c |   59 +-
 3 files changed, 876 insertions(+), 983 deletions(-)

-- 
2.7.4

WARNING: multiple messages have this Message-ID (diff)
From: Nicolin Chen <nicoleotsuka@gmail.com>
To: broonie@kernel.org
Cc: alsa-devel@alsa-project.org, kernel@pengutronix.de,
	lgirdwood@gmail.com, timur@tabi.org, caleb@crome.org,
	linux-kernel@vger.kernel.org, arnaud.mouiche@invoxia.com,
	lukma@denx.de, fabio.estevam@nxp.com, mail@maciej.szmigiero.name,
	linuxppc-dev@lists.ozlabs.org
Subject: [PATCH v2 00/11] ASoC: fsl_ssi: Clean up - coding style level
Date: Tue, 12 Dec 2017 22:34:23 -0800	[thread overview]
Message-ID: <1513146874-25476-1-git-send-email-nicoleotsuka@gmail.com> (raw)

==Changelog==
v1->v2
 * Dropped one patch to remove "struct device"
 * Revised PATCH-03 "Refine all comments"
 * Revised PATCH-05 "Refine indentations and wrappings"
 * Rebased all other patches
 * Added PATCH-10 "Rename i2smode to i2s_net"
 * Added PATCH-11 "Define ternary macros to simplify code"

 # Detialed changes are described in each updated patch.

==Background==
The fsl_ssi driver was designed for PPC originally and then it has
been updated to support different modes for i.MX Series, including
SDMA, I2S Master mode, AC97 and older i.MXs with FIQ, by different
contributors for different use cases in different coding styles.

Additionally, in order to fix/work-around hardware bugs and design
flaws, the driver made a lot of compromise so now its program flow
looks very complicated and it's getting hard to maintain or update.

So I am going to clean up the driver on both coding style level and
program flow level.

==Introduction==
This series of patches is the first set to clean up fsl_ssi driver
in the coding style level. Any patch here is not supposed to change
the program flow.

==Verification==
Theoretically, since these patches do not change program flow, they
only need code review, build or sanity tests. I have done build and
sanity tests on an i.MX6SoloX with WM8962 using imx_v6_v7_defconfig
and playback/record tests in I2S Master/Slave modes.

Nicolin Chen (11):
  ASoC: fsl_ssi: Rename fsl_ssi_private to fsl_ssi
  ASoC: fsl_ssi: Cache pdev->dev pointer
  ASoC: fsl_ssi: Refine all comments
  ASoC: fsl_ssi: Rename registers and fields macros
  ASoC: fsl_ssi: Refine indentations and wrappings
  ASoC: fsl_ssi: Refine printk outputs
  ASoC: fsl_ssi: Rename cpu_dai parameter to dai
  ASoC: fsl_ssi: Rename scr_val to scr
  ASoC: fsl_ssi: Replace fsl_ssi_rxtx_reg_val with fsl_ssi_regvals
  ASoC: fsl_ssi: Rename i2smode to i2s_net
  ASoC: fsl_ssi: Define ternary macros to simplify code

 sound/soc/fsl/fsl_ssi.c     | 1373 +++++++++++++++++++------------------------
 sound/soc/fsl/fsl_ssi.h     |  427 ++++++++------
 sound/soc/fsl/fsl_ssi_dbg.c |   59 +-
 3 files changed, 876 insertions(+), 983 deletions(-)

-- 
2.7.4

             reply	other threads:[~2017-12-13  6:35 UTC|newest]

Thread overview: 31+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2017-12-13  6:34 Nicolin Chen [this message]
2017-12-13  6:34 ` [PATCH v2 00/11] ASoC: fsl_ssi: Clean up - coding style level Nicolin Chen
2017-12-13  6:34 ` [PATCH v2 01/11] ASoC: fsl_ssi: Rename fsl_ssi_private to fsl_ssi Nicolin Chen
2017-12-13  6:34   ` Nicolin Chen
2017-12-13  6:34 ` [PATCH v2 02/11] ASoC: fsl_ssi: Cache pdev->dev pointer Nicolin Chen
2017-12-13  6:34   ` Nicolin Chen
2017-12-13  6:34 ` [PATCH v2 03/11] ASoC: fsl_ssi: Refine all comments Nicolin Chen
2017-12-13 22:28   ` Maciej S. Szmigiero
2017-12-13 22:28     ` Maciej S. Szmigiero
2017-12-13 22:36     ` Nicolin Chen
2017-12-13 22:36       ` Nicolin Chen
2017-12-13  6:34 ` [PATCH v2 04/11] ASoC: fsl_ssi: Rename registers and fields macros Nicolin Chen
2017-12-13  6:34 ` [PATCH v2 05/11] ASoC: fsl_ssi: Refine indentations and wrappings Nicolin Chen
2017-12-13  6:34   ` Nicolin Chen
2017-12-13 22:30   ` Maciej S. Szmigiero
2017-12-13 22:33     ` Nicolin Chen
2017-12-13  6:34 ` [PATCH v2 06/11] ASoC: fsl_ssi: Refine printk outputs Nicolin Chen
2017-12-13  6:34   ` Nicolin Chen
2017-12-13  6:34 ` [PATCH v2 07/11] ASoC: fsl_ssi: Rename cpu_dai parameter to dai Nicolin Chen
2017-12-19 11:00   ` Applied "ASoC: fsl_ssi: Rename cpu_dai parameter to dai" to the asoc tree Mark Brown
2017-12-19 11:00     ` Mark Brown
2017-12-13  6:34 ` [PATCH v2 08/11] ASoC: fsl_ssi: Rename scr_val to scr Nicolin Chen
2017-12-13  6:34 ` [PATCH v2 09/11] ASoC: fsl_ssi: Replace fsl_ssi_rxtx_reg_val with fsl_ssi_regvals Nicolin Chen
2017-12-13  6:34 ` [PATCH v2 10/11] ASoC: fsl_ssi: Rename i2smode to i2s_net Nicolin Chen
2017-12-19 10:59   ` Applied "ASoC: fsl_ssi: Rename i2smode to i2s_net" to the asoc tree Mark Brown
2017-12-19 10:59     ` Mark Brown
2017-12-13  6:34 ` [PATCH v2 11/11] ASoC: fsl_ssi: Define ternary macros to simplify code Nicolin Chen
2017-12-19 10:59   ` Applied "ASoC: fsl_ssi: Define ternary macros to simplify code" to the asoc tree Mark Brown
2017-12-19 10:59     ` Mark Brown
2017-12-13 22:37 ` [PATCH v2 00/11] ASoC: fsl_ssi: Clean up - coding style level Maciej S. Szmigiero
2017-12-13 22:37   ` Maciej S. Szmigiero

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=1513146874-25476-1-git-send-email-nicoleotsuka@gmail.com \
    --to=nicoleotsuka@gmail.com \
    --cc=alsa-devel@alsa-project.org \
    --cc=arnaud.mouiche@invoxia.com \
    --cc=broonie@kernel.org \
    --cc=caleb@crome.org \
    --cc=fabio.estevam@nxp.com \
    --cc=kernel@pengutronix.de \
    --cc=lgirdwood@gmail.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linuxppc-dev@lists.ozlabs.org \
    --cc=lukma@denx.de \
    --cc=mail@maciej.szmigiero.name \
    --cc=timur@tabi.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.