All of lore.kernel.org
 help / color / mirror / Atom feed
From: Chris Wilson <chris@chris-wilson.co.uk>
To: Daniele Ceraolo Spurio <daniele.ceraolospurio@intel.com>,
	intel-gfx@lists.freedesktop.org
Subject: Re: [PATCH v2 1/8] drm/i915: prefer i915_runtime_pm in intel_runtime function
Date: Wed, 12 Jun 2019 23:10:20 +0100	[thread overview]
Message-ID: <156037742058.10298.14177010806149156346@skylake-alporthouse-com> (raw)
In-Reply-To: <20190612183748.7693-2-daniele.ceraolospurio@intel.com>

Quoting Daniele Ceraolo Spurio (2019-06-12 19:37:40)
> As a first step towards updating the code to work on the runtime_pm
> structure instead of i915, rework all the internals to use and pass
> around that.
> 
> v2: add comment for kdev (Jani), move rpm init after pdev init for
> mock_device
> 
> Signed-off-by: Daniele Ceraolo Spurio <daniele.ceraolospurio@intel.com>
> Cc: Jani Nikula <jani.nikula@linux.intel.com>
> ---
>  drivers/gpu/drm/i915/i915_drv.h               |   2 +
>  drivers/gpu/drm/i915/intel_drv.h              |  10 +-
>  drivers/gpu/drm/i915/intel_runtime_pm.c       | 122 ++++++++----------
>  .../gpu/drm/i915/selftests/mock_gem_device.c  |   4 +-
>  4 files changed, 68 insertions(+), 70 deletions(-)
> 
> diff --git a/drivers/gpu/drm/i915/i915_drv.h b/drivers/gpu/drm/i915/i915_drv.h
> index 0ea7f78ae227..3e7186362bb0 100644
> --- a/drivers/gpu/drm/i915/i915_drv.h
> +++ b/drivers/gpu/drm/i915/i915_drv.h
> @@ -1073,6 +1073,8 @@ struct skl_wm_params {
>   */
>  struct i915_runtime_pm {
>         atomic_t wakeref_count;
> +       struct device *kdev; /* points to i915->drm.pdev->dev */
> +       bool available;
>         bool suspended;
>         bool irqs_enabled;
>  
> diff --git a/drivers/gpu/drm/i915/intel_drv.h b/drivers/gpu/drm/i915/intel_drv.h
> index 3e337317f77e..aec40adf4876 100644
> --- a/drivers/gpu/drm/i915/intel_drv.h
> +++ b/drivers/gpu/drm/i915/intel_drv.h
> @@ -1656,13 +1656,17 @@ ____assert_rpm_wakelock_held(struct i915_runtime_pm *rpm, int wakeref_count)
>  }
>  
>  static inline void
> -assert_rpm_raw_wakeref_held(struct drm_i915_private *i915)
> +__assert_rpm_raw_wakeref_held(struct i915_runtime_pm *rpm)

Our naming scheme would make this intel_runtime_pm as it is more HW
facing than user. Plus, Jani will point out it's intel_runtime_pm.c
-Chris
_______________________________________________
Intel-gfx mailing list
Intel-gfx@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/intel-gfx

  reply	other threads:[~2019-06-12 22:10 UTC|newest]

Thread overview: 15+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2019-06-12 18:37 [PATCH v2 0/8] RPM Encapsulation Daniele Ceraolo Spurio
2019-06-12 18:37 ` [PATCH v2 1/8] drm/i915: prefer i915_runtime_pm in intel_runtime function Daniele Ceraolo Spurio
2019-06-12 22:10   ` Chris Wilson [this message]
2019-06-12 18:37 ` [PATCH v2 2/8] drm/i915: Remove rpm asserts that use i915 Daniele Ceraolo Spurio
2019-06-12 18:37 ` [PATCH v2 3/8] drm/i915: make enable/disable rpm assert function use the rpm structure Daniele Ceraolo Spurio
2019-06-12 18:37 ` [PATCH v2 4/8] drm/i915: move and rename i915_runtime_pm Daniele Ceraolo Spurio
2019-06-12 22:14   ` Chris Wilson
2019-06-12 22:16     ` Daniele Ceraolo Spurio
2019-06-12 18:37 ` [PATCH v2 5/8] drm/i915: move a few more functions to accept the rpm structure Daniele Ceraolo Spurio
2019-06-12 18:37 ` [PATCH v2 6/8] drm/i915: update rpm_get/put to use " Daniele Ceraolo Spurio
2019-06-12 18:37 ` [PATCH v2 7/8] drm/i915: update with_intel_runtime_pm " Daniele Ceraolo Spurio
2019-06-12 18:37 ` [PATCH v2 8/8] drm/i915: make intel_wakeref work on the rpm struct Daniele Ceraolo Spurio
2019-06-12 22:18   ` Chris Wilson
2019-06-12 19:24 ` ✗ Fi.CI.BAT: failure for RPM Encapsulation Patchwork
2019-06-12 22:24 ` [PATCH v2 0/8] " Chris Wilson

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=156037742058.10298.14177010806149156346@skylake-alporthouse-com \
    --to=chris@chris-wilson.co.uk \
    --cc=daniele.ceraolospurio@intel.com \
    --cc=intel-gfx@lists.freedesktop.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.