All of lore.kernel.org
 help / color / mirror / Atom feed
From: Christoph Hellwig <hch@infradead.org>
To: Amir Goldstein <amir73il@gmail.com>
Cc: Christoph Hellwig <hch@infradead.org>,
	"Darrick J. Wong" <darrick.wong@oracle.com>,
	Dave Chinner <david@fromorbit.com>,
	Eric Sandeen <sandeen@redhat.com>,
	Linux NFS Mailing List <linux-nfs@vger.kernel.org>,
	linux-cifs@vger.kernel.org,
	overlayfs <linux-unionfs@vger.kernel.org>,
	linux-xfs <linux-xfs@vger.kernel.org>,
	Linux MM <linux-mm@kvack.org>,
	Linux Btrfs <linux-btrfs@vger.kernel.org>,
	linux-fsdevel <linux-fsdevel@vger.kernel.org>,
	ocfs2-devel@oss.oracle.com
Subject: Re: [PATCH 07/25] vfs: combine the clone and dedupe into a single remap_file_range
Date: Mon, 15 Oct 2018 05:47:19 -0700	[thread overview]
Message-ID: <20181015124719.GA15379@infradead.org> (raw)
In-Reply-To: <CAOQ4uxiReFJRxKJbsoUgWWNP75_Qsoh1fWC_dLYV_zBU_jaGbA@mail.gmail.com>

On Mon, Oct 15, 2018 at 09:04:13AM +0300, Amir Goldstein wrote:
> I supposed you figured out the reason already.

No, I hadn't.

> It makes it appearance in patch 16/25 as RFR_VFS_FLAGS.
> All those "advisory" flags, we want to pass them in to filesystem as FYI,
> but we don't want to explicitly add support for e.g. RFR_CAN_SHORTEN
> to every filesystem, when vfs has already taken care of the advice.

I don't think this model makes sense.  If they really are purely
handled in the VFS we can mask them before passing them to the file
system, if not we need to check them, or the they are avisory and
we can have a simple #define instead of the helper.

RFR_TO_SRC_EOF is checked in generic_remap_file_range_prep,
so the file system should know about it  Also looking at it again now
it seems entirely superflous - we can just pass down then len == we
use in higher level code instead of having a flag and will side step
the issue here.

RFR_CAN_SHORTEN is advisory as no one has to shorten, but that can
easily be solved by including it everywhere.

RFR_SHORT_DEDUPE is as far as I can tell entirely superflous to
start with, as RFR_CAN_SHORTEN can be used instead.

So something like this in fs.h:

#define REMAP_FILE_ADVISORY_FLAGS	REMAP_FILE_CAN_SHORTEN

And then in the file system:

	if (flags & ~REMAP_FILE_ADVISORY_FLAGS)
		-EINVAL;

or

	if (flags & ~(REMAP_FILE_ADVISORY_FLAGS | REMAP_FILE_DEDUP))
		-EINVAL;

should be all that is needed.

WARNING: multiple messages have this Message-ID (diff)
From: Christoph Hellwig <hch@infradead.org>
To: Amir Goldstein <amir73il@gmail.com>
Cc: Christoph Hellwig <hch@infradead.org>,
	"Darrick J. Wong" <darrick.wong@oracle.com>,
	Dave Chinner <david@fromorbit.com>,
	Eric Sandeen <sandeen@redhat.com>,
	Linux NFS Mailing List <linux-nfs@vger.kernel.org>,
	linux-cifs@vger.kernel.org,
	overlayfs <linux-unionfs@vger.kernel.org>,
	linux-xfs <linux-xfs@vger.kernel.org>,
	Linux MM <linux-mm@kvack.org>,
	Linux Btrfs <linux-btrfs@vger.kernel.org>,
	linux-fsdevel <linux-fsdevel@vger.kernel.org>,
	ocfs2-devel@oss.oracle.com
Subject: [Ocfs2-devel] [PATCH 07/25] vfs: combine the clone and dedupe into a single remap_file_range
Date: Mon, 15 Oct 2018 05:47:19 -0700	[thread overview]
Message-ID: <20181015124719.GA15379@infradead.org> (raw)
In-Reply-To: <CAOQ4uxiReFJRxKJbsoUgWWNP75_Qsoh1fWC_dLYV_zBU_jaGbA@mail.gmail.com>

On Mon, Oct 15, 2018 at 09:04:13AM +0300, Amir Goldstein wrote:
> I supposed you figured out the reason already.

No, I hadn't.

> It makes it appearance in patch 16/25 as RFR_VFS_FLAGS.
> All those "advisory" flags, we want to pass them in to filesystem as FYI,
> but we don't want to explicitly add support for e.g. RFR_CAN_SHORTEN
> to every filesystem, when vfs has already taken care of the advice.

I don't think this model makes sense.  If they really are purely
handled in the VFS we can mask them before passing them to the file
system, if not we need to check them, or the they are avisory and
we can have a simple #define instead of the helper.

RFR_TO_SRC_EOF is checked in generic_remap_file_range_prep,
so the file system should know about it  Also looking at it again now
it seems entirely superflous - we can just pass down then len == we
use in higher level code instead of having a flag and will side step
the issue here.

RFR_CAN_SHORTEN is advisory as no one has to shorten, but that can
easily be solved by including it everywhere.

RFR_SHORT_DEDUPE is as far as I can tell entirely superflous to
start with, as RFR_CAN_SHORTEN can be used instead.

So something like this in fs.h:

#define REMAP_FILE_ADVISORY_FLAGS	REMAP_FILE_CAN_SHORTEN

And then in the file system:

	if (flags & ~REMAP_FILE_ADVISORY_FLAGS)
		-EINVAL;

or

	if (flags & ~(REMAP_FILE_ADVISORY_FLAGS | REMAP_FILE_DEDUP))
		-EINVAL;

should be all that is needed.

  reply	other threads:[~2018-10-15 12:47 UTC|newest]

Thread overview: 101+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2018-10-13  0:05 [PATCH v4 00/25] fs: fixes for serious clone/dedupe problems Darrick J. Wong
2018-10-13  0:05 ` [Ocfs2-devel] " Darrick J. Wong
2018-10-13  0:05 ` [PATCH 01/25] xfs: add a per-xfs trace_printk macro Darrick J. Wong
2018-10-13  0:05   ` [Ocfs2-devel] " Darrick J. Wong
2018-10-13  0:05 ` [PATCH 02/25] vfs: vfs_clone_file_prep_inodes should return EINVAL for a clone from beyond EOF Darrick J. Wong
2018-10-13  0:05   ` [Ocfs2-devel] " Darrick J. Wong
2018-10-13  0:06 ` [PATCH 03/25] vfs: check file ranges before cloning files Darrick J. Wong
2018-10-13  0:06   ` [Ocfs2-devel] " Darrick J. Wong
2018-10-13  0:06 ` [PATCH 04/25] vfs: strengthen checking of file range inputs to generic_remap_checks Darrick J. Wong
2018-10-13  0:06   ` [Ocfs2-devel] " Darrick J. Wong
2018-10-13  0:06 ` [PATCH 05/25] vfs: avoid problematic remapping requests into partial EOF block Darrick J. Wong
2018-10-13  0:06   ` [Ocfs2-devel] " Darrick J. Wong
2018-10-14 17:11   ` Christoph Hellwig
2018-10-14 17:11     ` [Ocfs2-devel] " Christoph Hellwig
2018-10-13  0:06 ` [PATCH 06/25] vfs: skip zero-length dedupe requests Darrick J. Wong
2018-10-13  0:06   ` [Ocfs2-devel] " Darrick J. Wong
2018-10-13  0:06 ` [PATCH 07/25] vfs: combine the clone and dedupe into a single remap_file_range Darrick J. Wong
2018-10-13  0:06   ` [Ocfs2-devel] " Darrick J. Wong
2018-10-14 17:19   ` Christoph Hellwig
2018-10-14 17:19     ` [Ocfs2-devel] " Christoph Hellwig
2018-10-15  6:04     ` Amir Goldstein
2018-10-15 12:47       ` Christoph Hellwig [this message]
2018-10-15 12:47         ` [Ocfs2-devel] " Christoph Hellwig
2018-10-15 12:54         ` Amir Goldstein
2018-10-15 17:13         ` Darrick J. Wong
2018-10-15 17:13           ` [Ocfs2-devel] " Darrick J. Wong
2018-10-15 18:32           ` Christoph Hellwig
2018-10-15 18:32             ` [Ocfs2-devel] " Christoph Hellwig
2018-10-15 13:18     ` Matthew Wilcox
2018-10-15 16:42     ` Darrick J. Wong
2018-10-15 16:42       ` [Ocfs2-devel] " Darrick J. Wong
2018-10-13  0:06 ` [PATCH 08/25] vfs: rename vfs_clone_file_prep to be more descriptive Darrick J. Wong
2018-10-13  0:06   ` [Ocfs2-devel] " Darrick J. Wong
2018-10-13  0:06 ` [PATCH 09/25] vfs: rename clone_verify_area to remap_verify_area Darrick J. Wong
2018-10-13  0:06   ` [Ocfs2-devel] " Darrick J. Wong
2018-10-13  0:06 ` [PATCH 10/25] vfs: create generic_remap_file_range_touch to update inode metadata Darrick J. Wong
2018-10-13  0:06   ` [Ocfs2-devel] " Darrick J. Wong
2018-10-14 17:21   ` Christoph Hellwig
2018-10-14 17:21     ` [Ocfs2-devel] " Christoph Hellwig
2018-10-15 16:30     ` Darrick J. Wong
2018-10-15 16:30       ` [Ocfs2-devel] " Darrick J. Wong
2018-10-15 18:19       ` Christoph Hellwig
2018-10-15 18:19         ` [Ocfs2-devel] " Christoph Hellwig
2018-10-13  0:06 ` [PATCH 11/25] vfs: pass remap flags to generic_remap_file_range_prep Darrick J. Wong
2018-10-13  0:06   ` [Ocfs2-devel] " Darrick J. Wong
2018-10-14 17:22   ` Christoph Hellwig
2018-10-14 17:22     ` [Ocfs2-devel] " Christoph Hellwig
2018-10-14 17:37   ` Christoph Hellwig
2018-10-14 17:37     ` [Ocfs2-devel] " Christoph Hellwig
2018-10-15 15:42     ` Darrick J. Wong
2018-10-15 15:42       ` [Ocfs2-devel] " Darrick J. Wong
2018-10-13  0:07 ` [PATCH 12/25] vfs: pass remap flags to generic_remap_checks Darrick J. Wong
2018-10-13  0:07   ` [Ocfs2-devel] " Darrick J. Wong
2018-10-13  0:07 ` [PATCH 13/25] vfs: make remap_file_range functions take and return bytes completed Darrick J. Wong
2018-10-13  0:07   ` [Ocfs2-devel] " Darrick J. Wong
2018-10-13  0:07 ` [PATCH 14/25] vfs: plumb RFR_* remap flags through the vfs clone functions Darrick J. Wong
2018-10-13  0:07   ` [Ocfs2-devel] " Darrick J. Wong
2018-10-13  0:07   ` Darrick J. Wong
2018-10-13  0:07 ` [PATCH 15/25] vfs: plumb RFR_* remap flags through the vfs dedupe functions Darrick J. Wong
2018-10-13  0:07   ` [Ocfs2-devel] " Darrick J. Wong
2018-10-13  0:07 ` [PATCH 16/25] vfs: make remapping to source file eof more explicit Darrick J. Wong
2018-10-13  0:07   ` [Ocfs2-devel] " Darrick J. Wong
2018-10-14 17:24   ` Christoph Hellwig
2018-10-14 17:24     ` [Ocfs2-devel] " Christoph Hellwig
2018-10-14 17:24     ` Christoph Hellwig
2018-10-14 17:24     ` Christoph Hellwig
2018-10-15 15:32     ` Darrick J. Wong
2018-10-15 15:32       ` [Ocfs2-devel] " Darrick J. Wong
2018-10-15 18:28       ` Christoph Hellwig
2018-10-15 18:28         ` [Ocfs2-devel] " Christoph Hellwig
2018-10-13  0:07 ` [PATCH 17/25] vfs: enable remap callers that can handle short operations Darrick J. Wong
2018-10-13  0:07   ` [Ocfs2-devel] " Darrick J. Wong
2018-10-13  0:07 ` [PATCH 18/25] vfs: hide file range comparison function Darrick J. Wong
2018-10-13  0:07   ` [Ocfs2-devel] " Darrick J. Wong
2018-10-14 17:43   ` Christoph Hellwig
2018-10-14 17:43     ` [Ocfs2-devel] " Christoph Hellwig
2018-10-13  0:07 ` [PATCH 19/25] vfs: implement opportunistic short dedupe Darrick J. Wong
2018-10-13  0:07   ` [Ocfs2-devel] " Darrick J. Wong
2018-10-14 17:26   ` Christoph Hellwig
2018-10-14 17:26     ` [Ocfs2-devel] " Christoph Hellwig
2018-10-13  0:08 ` [PATCH 20/25] ocfs2: truncate page cache for clone destination file before remapping Darrick J. Wong
2018-10-13  0:08   ` [Ocfs2-devel] " Darrick J. Wong
2018-10-13  0:08 ` [PATCH 21/25] ocfs2: fix pagecache truncation prior to reflink Darrick J. Wong
2018-10-13  0:08   ` [Ocfs2-devel] " Darrick J. Wong
2018-10-13  0:08 ` [PATCH 22/25] ocfs2: support partial clone range and dedupe range Darrick J. Wong
2018-10-13  0:08   ` [Ocfs2-devel] " Darrick J. Wong
2018-10-14 17:41   ` Christoph Hellwig
2018-10-14 17:41     ` [Ocfs2-devel] " Christoph Hellwig
2018-10-13  0:08 ` [PATCH 23/25] xfs: fix pagecache truncation prior to reflink Darrick J. Wong
2018-10-13  0:08   ` [Ocfs2-devel] " Darrick J. Wong
2018-10-13  0:08 ` [PATCH 24/25] xfs: support returning partial reflink results Darrick J. Wong
2018-10-13  0:08   ` [Ocfs2-devel] " Darrick J. Wong
2018-10-14 17:35   ` Christoph Hellwig
2018-10-14 17:35     ` [Ocfs2-devel] " Christoph Hellwig
2018-10-14 23:05     ` Dave Chinner
2018-10-14 23:05       ` [Ocfs2-devel] " Dave Chinner
2018-10-15 15:49       ` Darrick J. Wong
2018-10-15 15:49         ` [Ocfs2-devel] " Darrick J. Wong
2018-10-13  0:08 ` [PATCH 25/25] xfs: remove redundant remap partial EOF block checks Darrick J. Wong
2018-10-13  0:08   ` [Ocfs2-devel] " Darrick J. Wong
  -- strict thread matches above, loose matches on Subject: below --
2018-10-11  4:12 [PATCH v3 00/25] fs: fixes for serious clone/dedupe problems Darrick J. Wong
2018-10-11  4:13 ` [PATCH 07/25] vfs: combine the clone and dedupe into a single remap_file_range Darrick J. Wong

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20181015124719.GA15379@infradead.org \
    --to=hch@infradead.org \
    --cc=amir73il@gmail.com \
    --cc=darrick.wong@oracle.com \
    --cc=david@fromorbit.com \
    --cc=linux-btrfs@vger.kernel.org \
    --cc=linux-cifs@vger.kernel.org \
    --cc=linux-fsdevel@vger.kernel.org \
    --cc=linux-mm@kvack.org \
    --cc=linux-nfs@vger.kernel.org \
    --cc=linux-unionfs@vger.kernel.org \
    --cc=linux-xfs@vger.kernel.org \
    --cc=ocfs2-devel@oss.oracle.com \
    --cc=sandeen@redhat.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is an external index of several public inboxes,
see mirroring instructions on how to clone and mirror
all data and code used by this external index.